Download Complete PDF Send Feedback Print This Page

Previous

Synchronize Contents

Route Maps

Related Topics

Route Maps Overview

match aggregate-contributors

match as

match as-path

match as-path-list

match community

match community-set

match distance

match extended-community-set

match instance

match interface

match ip address access-list

match ip address prefix-list

match ip address prefix-tree

match ip gateway

match ip next-hop

match ip route-source prefix-tree

match localpref

match med

match metric

match metric-type

match protocol

match ribs

match tag

route-map

set as-path prepend

set community-set

set dampen-flap

set ip next-hop

set local-preference

set med

set metric

set metric-type

set origin

set preference

set propagate

set ribs

set tag

Route Maps Overview

Route maps can be used to filter learned routes or to redistribute routes between protocols. Route map commands specify match and set criteria associated with the route map.

match aggregate-contributors

Name

match aggregate-contributors - specifies that in order for a route to match, it must be a contributor to an aggregate route

Syntax

match aggregate-contributors [invert]?

no match aggregate-contributors [invert]?

Mode

Route Map Configuration

Parameters

invert - optionally specify to reverse the result of a match

Description

Use the match aggregate-contributors command to specifies that, in order for a route to match, it must be a contributor to an aggregate route.

Default

This command is configured by default. Therefore, if match aggregate-contributors is not specified, it is the same as if the user had specified the following:

(config-route-map)# match aggregate-contributors

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route being matched is an aggregate contributor and has an AS_PATH matching the AS path list labeled "list1", then the following set actions will be executed:

  • Communities specified in community "com-set-1" will be added to the matching route.
  • Communities specified in community set "com-set-2 will be deleted from the matching route.
  • The metric for the matching routes will be set to 1.

(config)# route-map abc

(config-route-map)# match aggregate-contributors

(config-route-map)# match as-path-list list1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 1

(config-route-map)# exit

(config)#

match as

Name

match as - filters BGP routes learned from peers within a particular autonomous system (AS)

Syntax

match as as_number [invert]?

no match as as_number [invert]?

Mode

Route Map Configuration

Parameters

as_number - an integer between 1 and 65535, inclusive, specifying the number of an AS

invert - optionally specify to reverse the result of a match

Description

Use the match as command to filter BGP routes learned from peers within a particular autonomous system.

Note: This command applies only to BGP routes. It will be ignored for any other protocol.

Default

AS matching policy is not configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

The following example configures route map "matchbgp" and specifies to match BGP routes learned from peers within AS 65535.

(config)# route map matchbgp

(config-route-map)# match as 65535

(config-route-map)# exit

(config)#

match as-path

Name

match as-path - specifies the name of the AS Path Regular Expression to be matched

Syntax

match as-path name [invert]?

no match as-path name [invert]?

Mode

Router Map Configuration

Parameters

name - the name of the AS Path Regular Expression to be matched

invert - optionally specify to reverse the result of a match

Description

Use the match as-path command to specify a pre-configured AS Path Regular Expression that you want to be matched in this route map. If the referenced AS Path Regular Expression has not yet been configured, then the result is that the match fails.

Note: This command applies only to BGP routes. It will be ignored for all other protocols.

Default

No AS Path matches are configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route being evaluated against route map "abc" matches interface "fxp1" and the AS path regular expression "aspath1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in community set "com-set-2" will be deleted from the matching route.
  • The metric for the matching route will be set to 50.

(config)# route-map abc

(config-route-map)# match interface fxp1

(config-route-map)# match as-path aspath1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 50

(config-route-map)# exit

(config)#

match as-path-list

Name

match as-path-list - specifies a pre-configured AS Path list to be matched

Syntax

match as-path-list name [invert]?

no match as-path-list name [invert]?

Mode

Route Map Configuration

Parameters

name - the name of a pre-configured AS Path list

invert - optionally specify to reverse the result of a match

Description

Use the match as-path-list command to specify a pre-configured AS Path list that you want to be matched in this route map. If the referenced AS Path list has not yet been configured, then the result is that the match fails.

Note: This command applies only to BGP routes. It will be ignored for all other protocols.

Default

No AS Path lists are matched by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route being evaluated against route map "abc" matches interface "fxp1" and the AS path list labeled "list1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in community set "com-set-2" will be deleted from the matching route.
  • The metric for the matching route will be set to 50.

(config)# route-map abc

(config-route-map)# match interface fxp1

(config-route-map)# match as-path-list list1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 50

(config-route-map)# exit

(config)#

match community

Name

match community - specifies a BGP community list to be matched in a route map

Syntax

match community name [invert]?

no match community name [invert]?

Mode

Route Map Configuration

Parameters

name - the name of a BGP community list

invert - optionally specify to reverse the result of a match

Description

Use the match community command to specify a BGP community list that you want to be matched in this route map. If the referenced community list has not yet been configured, then the result is that the match fails.

Note: This command applies only to BGP routes. It will be ignored for all other protocols.

Default

No BGP community lists are matched by default.

Command History

NGC 2.2 - This command was introduced.

Examples

Example 1

In the following example, if the route being evaluated against route map "abc" matches the BGP Community List "commlist1" and the AS path list labeled "aspathlist1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in community set "com-set-2" will be deleted from the matching route.
  • The metric for the matching route will be set to 50.

(config)# route-map abc

(config-route-map)# match community commlist1

(config-route-map)# match as-path-list aspathlist1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 50

(config-route-map)# exit

(config)#

Example 2

The following example configures route map "abc". If a route being evaluated against this route map does not match community list "comm-list-1", then communities specified in the community set "comm-set-1" will be deleted from the route, and the route will be considered to have matched.

(config)# route-map abc

(config-route-map)# match community comm-list-1 invert

(config-route-map)# set community-set comm-set-1 delete

(config-route-map)# exit

(config)#

match community-set

Name

match community-set - specifies a set of BGP communities to be matched

Syntax

match community-set name [exact]? [invert]?

no match community-set name [exact]? [invert]?

Mode

Route Map Configuration

Parameters

name - the name of the community set

exact - optionally specify that a community set must be matched exactly. Ordinarily, supersets are considered to match a community set.

invert - optionally specify to reverse the result of a match

Description

Use the match community-set command to specify a set of BGP communities that you want to be matched in this route map. If the referenced community set has not yet been configured, then the result is that the match fails.

Note: This command applies only to BGP routes. It will be ignored for all other protocols.

Default

No community sets are matched by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route being evaluated against route map "abc" matches interface "fxp1" and the BGP Community labeled "bgpcomm1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in the community set "com-set-2" will be deleted from the matching route.
  • The metric for the matching route will be set to 50.

(config)# route-map abc

(config-route-map)# match interface fxp1

(config-route-map)# match community-set bgpcomm1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 50

(config-route-map)# exit

(config)#

match distance

Name

match distance - specifies to match a route’s distance (or preference) in the route map

Syntax

match distance dist [invert]?

no match distance dist [invert]?

Mode

Route Map Configuration

Parameters

dist - an integer from 0 to 255, inclusive

invert - optionally specify to reverse the result of a match

Description

This command specifies to match a route’s preference in this route map.

Default

Distances (or preferences) are not matched by default.

Command History

NGC 2.2 - This command was introduced.

Examples

The following example configures a route map, xyz, that specifies to match routes with a distance of 10.

(config)# route-map xyz

(config-route-map)# match distance 10

(config-route-map)# exit

(config)#

match extended-community-set

Name

match community-set - specifies a set of BGP extended communities to be matched

Syntax

match extended-community-set name [exact]? [invert]?

no match extended-community-set name [exact]? [invert]?

Mode

Route Map Configuration

Parameters

name - the name of the community set

exact - optionally specify that a community set must be matched exactly. Ordinarily, supersets are considered to match a community set.

invert - optionally specify to reverse the result of a match

Description

Use the match extended-community-set command to specify a set of BGP extended communities that you want to be matched in this route map. If the referenced extended community set has not yet been configured, then the result is that the match fails.

Note: This command applies only to BGP routes. It will be ignored for all other protocols.

Default

No extended community sets are matched by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route being evaluated against route map "abc" matches interface "fxp1" and the BGP Extended Community labeled "extcomm1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in the community set "com-set-2" will be deleted from the matching route.
  • The metric for the matching route will be set to 50.

(config)# route-map abc

(config-route-map)# match interface fxp1

(config-route-map)# match extended-community-set extcomm1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 50

(config-route-map)# exit

(config)#

match instance

Name

match instance - specifies an OSPF instance to be matched by a route map

Syntax

match instance instance-id [invert]?

no match instance instance-id [invert]?

Mode

Route Map Configuration

Parameters

instance-id - an integer from 1 to 65535, inclusive, specifying an OSPF instance

invert - optionally specify to reverse the result of a match

Description

Use the match instance command to specify an OSPF instance to be matched. Note: This command applies only to OSPF. It will be ignored for all other protocols.

Default

This command is not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route matches instance 1, then the route will only be exported to level 1.

(config)# route-map abc

(config-route-map)# match instance 1

(config-route-map)# set level 1

match interface

Name

match interface - specifies an interface or set of interfaces to be matched

Syntax

match interface [interface_name | all | ip_address] [invert]? {1,n}

no match interface [interface_name | all | ip_address] [invert]? {1,n}

Mode

Route Map Configuration

Parameters

interface_name - specify the physical interface name

all - specify to include match all interfaces

ip_address - specify a valid IPv4 logical interface address

invert - optionally specify to reverse the result of a match

{1,n} - You can use this command an unlimited number of times to specify an unlimited number of interfaces

Description

Use match interface to specify an interface or set of interfaces that you want to be matched in this route map.

Default

This option is not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route being evaluated against route map "abc" matches interface "fxp1" and the AS path list labeled "list1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in community set "com-set-2" will be deleted from the matching route.
  • The metric for the matching route will be set to 50.

(config)# route-map abc

(config-route-map)# match interface fxp1

(config-route-map)# match as-path-list list1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 50

(config-route-map)# exit

(config)#

match ip address access-list

Name

match ip address access-list - specifies an access list to be matched in this route map

Syntax

match ip address access-list name [invert]?

no match ip address access-list name [invert]?

Mode

Route Map Configuration

Parameters

name - the name of the access list to be matched

invert - optionally specify to reverse the result of a match

Description

Use the match ip address access-list command to specify an access list that you want to be matched in this route map. If the referenced access list has not yet been configured, then the result is that the match fails.

Default

Access list matches are not configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route matches the prefix list labeled, "list1" and the access list labeled "list1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in community set "com-set-2" will be deleted from the matching route.
  • The MED for routes will be set to 1.

(config)# route-map abc

(config-route-map)# match ip address prefix-list list1

(config-route-map)# match ip address access-list list1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 1

(config-route-map)# exit

(config)#

match ip address prefix-list

Name

match ip address prefix-list - specifies a prefix list to be matched in this route map

Syntax

match ip address prefix-list name [invert]?

no match ip address prefix-list name [invert]?

Mode

Route Map Configuration

Parameters

name - the name of the prefix list to be matched

invert - optionally specify to reverse the result of a match

Description

Use the match ip address prefix-list command to add a prefix list that you want to be matched in this route map. If the referenced prefix list has not yet been configured, then the result is that the match fails.

Default

Prefix list matches are not configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route matches the prefix list labeled, "list1" and the access list labeled "list1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in community set "com-set-2" will be deleted from the matching route.
  • The MED for the matching route will be set to 1.

(config)# route-map abc

(config-route-map)# match ip address prefix-list list1

(config-route-map)# match ip address access-list list1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 1

(config-route-map)# exit

(config)#

match ip address prefix-tree

Name

match ip address prefix-tree - specifies a prefix tree to be matched in this route map

Syntax

match ip address prefix-tree name [invert]?

no match ip address prefix-tree name [invert]?

Mode

Route Map Configuration

Parameters

name - the name of the prefix tree to be matched

invert - optionally specify to reverse the result of a match

Description

Use the match ip address prefix-tree command to add a prefix tree that you want to be matched in this route map. If the referenced prefix tree has not yet been configured, then the result is that the match fails.

Default

Prefix tree matches are not configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route matches the prefix tree labeled, "tree1" and the access list labeled "list1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in community set "com-set-2" will be deleted from the matching route.
  • The MED for the matching route will be set to 1.

(config)# route-map abc

(config-route-map)# match ip address prefix-tree tree1

(config-route-map)# match ip address access-list list1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 1

(config-route-map)# exit

(config)#

match ip gateway

Name

match ip gateway - specifies a gateway to be matched

Syntax

match ip gateway ipv4_address [invert]?

no match ip gateway ipv4_address [invert]?

Mode

Route Map Configuration

Parameters

ip_address - specifies a valid IPv4 logical address for the gateway

invert - optionally specify to reverse the result of a match

Description

Use the match ip gateway command to match IPv4 gateways and to specify those gateway addresses.

Default

Gateway values are not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

The following example specifies to match gateway 1.2.3.4 in route map abc.

(config)# route-map abc

(config-route-map)# match ip gateway 1.2.3.4

(config-route-map)# exit

(config)#

match ip next-hop

Name

match ip next-hop - specifies to match a nexthop address in a route map

Syntax

match ip [bgp]? next-hop [ipv4_address | all] [invert]?

no match ip [bgp]? next-hop [ipv4_address | all] [invert]?

Mode

Route Map Configuration

Parameters

bgp - optionally specify to match a BGP nexthop address in the route map

ipv4_address - specifies a valid IPv4 logical address for the nexthop

all - specifies that all nexthops of a route must match

invert - optionally specify to reverse the result of a match

Description

Use the match ip next-hop command to specify the IPv4 nexthop address to be matched.

Default

Nexthop values are not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

The following example specifies to match nexthop 1.2.3.4 in route map abc.

(config)# route-map abc

(config-route-map)# match ip next-hop 1.2.3.4

(config-route-map)# exit

(config)#

match ip route-source prefix-tree

Name

match ip route-source prefix-tree - specifies the name of a prefix tree to be matched

Syntax

match ip route-source prefix-tree name [invert]?

no match ip route-source prefix-tree name [invert]?

Mode

Route Map Configuration

Parameters

name - the name of the prefix-tree to be matched

invert - optionally specify to reverse the result of a match

Description

Use match ip route-source prefix-tree to specify prefix trees that you want to be matched in the associated route map. If the referenced prefix tree has not yet been configured, then the result is that the match fails.

Default

Prefix tree matches are not configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route matches the community list labeled, "list1" and the prefix tree labeled "tree1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in community set "com-set-2" will be deleted from the matching route.
  • The MED for the matching route will be set to 1.

(config)# route-map abc

(config-route-map)# match ip route-source prefix-tree tree1

(config-route-map)# match community list1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 1

(config-route-map)# exit

(config)#

match localpref

Name

match localpref - specifies a BGP Local_Pref value to be matched

Syntax

match localpref value [invert]?

no match localpref value [invert]?

Mode

Route Map Configuration

Parameters

value - an integer from 0 to 4,294,967,295, inclusive

invert - optionally specify to reverse the result of a match

Description

Use the match localpref command to filter BGP routes with a specific Local_Pref value.

Note: This command applies only to BGP routes. It will be ignored for any other protocol.

Default

This command is not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route has a BGP Local Preference value of 20, then the MED will be set to 1.

(config)# route-map abc

(config-route-map)# match localpref 20

(config-route-map)# set med 1

(config-route-map)# exit

match med

Name

match med - specifies a BGP Multi-Exit Discriminator (MED) to be matched

Syntax

match med value [invert]?

no match med value [invert]?

Mode

Route Map Configuration

Parameters

value - an integer from 0 to 4,294,967,295, inclusive

invert - optionally specify to reverse the result of a match

Description

Use the match med command to specify a BGP MED value to be matched. Note: This command applies only to BGP. It will be ignored for all other protocols.

Default

This command is not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route has a BGP MED value of 20, then the Local Pref value will be set to 1.

(config)# route-map abc

(config-route-map)# match med 20

(config-route-map)# set local-preference 1

(config-route-map)# exit

match metric

Name

match metric - specifies a route metric to be matched

Syntax

match metric value [invert]?

no match metric value [invert]?

Mode

Route Map Configuration

Parameters

value - an integer from 0 to 4,294,967,295, inclusive

invert - optionally specify to reverse the result of a match

Description

Use the match metric command to specify a route’s metric value to be matched.

Default

This command is not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route has a metric value of 4, then the preference will be set to 50.

(config)# route-map xyz

(config-route-map)# match metric 4

(config-route-map)# set preference 50

(config-route-map)# exit

(config)#

match metric-type

Name

match metric-type - compares the metric types for OSPF

Syntax

match metric-type [type-1 | type-2] [invert]?

no match metric-type [type-1 | type-2] [invert]?

Mode

Route Map Configuration

Parameters

type-1 - specifies to match the OSPF external type 1 metric

type-2 - specifies to match the OSPF external type 2 metric

invert - optionally specify to reverse the result of a match

Description

Use the match metric-type command when comparing metric types for OSPF. The meanings are specific to each protocol.

Note: You cannot include more than one parameter for a single match metric-type command

Default

If match metric-type is not specified, it is the same as if the user had specified the following
for OSPF: (config-route-map)# match metric-type type-2

Command History

NGC 2.2 - This command was introduced.

match protocol

Name

match protocol - specifies a protocol to be matched

Syntax

match protocol proto [invert]?

match protocol proto [invert]?

Mode

Route Map Configuration

Parameters

proto - specifies a protocol to be matched. Valid values include the following:

aggregate – Aggregate routes

all – All protocols

bgp – BGP routes

direct – Directly connected routes

kernel – Kernel routes

ospf – OSPF routes

ospf-ase – OSPF ASE routes

ospf3-ase – OSPFv3 ASE routes

rip – RIP routes

ripng – RIPng routes

static – Static routes

invert - optionally specify to reverse the result of a match

Description

Use the match protocol command to specify routes from a specific protocol to be matched.

Default

This command is not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route is a BGP route, then the preference will be set to 50.

(config)# route-map xyz

(config-route-map)# match protocol bgp

(config-route-map)# set preference 50

(config-route-map)# exit

(config)#

match ribs

Name

match ribs - specifies RIBs to be matched

Syntax

match ribs [unicast || multicast] [invert]?

no match ribs [unicast || multicast] [invert]?

Mode

Route Map Configuration

Parameters

unicast - specifies unicast RIB

multicast - specifies multicast RIB

invert - optionally specify to reverse the result of a match

Description

Use the match ribs command to limit the match to a set of either unicast and/or multicast RIBs. By default, a route map applies to all RIBs to which any contributing route applies. For example, a route map applies to the Unicast RIB if and only if any contributing route applies to the Unicast RIB.

Note: If a set ribs command is not specified, then no action is taken if the routes match.

Default

If match ribs is not specified, it is as if the user had specified the following:

(config)# match unicast multicast

Command History

NGC 2.2 - This command was introduced.

Examples

The following example causes routes in the unicast RIB to be exported into both the unicast and multicast RIBs.

(config)# route-map abc

(config-route-map)# match ribs unicast

(config-route-map)# set ribs multicast

(config-route-map)# set ribs unicast

match tag

Name

match tag - specifies the tag value with which routes are announced in OSPFASE, RIP, or RIPng

Syntax

match tag tag_value [invert]?

no match tag tag_value? [invert]?

Mode

Route Map Configuration

Parameters

tag_value - an integer from 0 to 4,294,967,295, inclusive

invert - optionally specify to reverse the result of a match

Description

Use the match tag command specifies a tag value with which routes are announced in OSPFASE, RIP, or RIPng. The negative form of this command, no match tag, removes the configured tag_value and returns this to its default value of 0.

Notes:

  • Specifying a value for tag_value in the no form has no effect on the configuration. Thus, it is displayed above as optional.
  • This command will be ignored for any protocol that is not OSPFASE, RIP, or RIPng.

Default

If match tag is not specified, it is the same as if the user had specified the following:

(config-route-map)# match tag 0

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if routes are announced with a tag value of 4, then when this route map is imported into a protocol, the preference for that protocol will be configured as 50.

(config)# route-map abc

(config-route-map)# match tag 4

(config-route-map)# set preference 50

(config-route-map)# exit

(config)#

route-map

Name

route-map - enters route-map configuration mode for a specified route map

Syntax

route-map name [permit | deny]? [seq_value]?

no route-map name [permit | deny]? [seq_value]?

Mode

Global Configuration

Parameters

name - a string of characters that identifies this route map

permit | deny - accepts or rejects routes matching this route map. If neither is specified, this option defaults to permit.

seq_value - an integer indicating the position a new route map is to have in a list of previously configured route maps

Description

The route-map command specifies the name of a route map and optionally whether to permit or deny routes matching the route map. A sequence number can also be specified. Specifying this command enters you in Route Map Configuration mode, where further commands can be specified.

Default

Route maps are not configured by default. When one is configured, however, the default behavior is to permit the route map.

Command History

NGC 2.2 - This command was introduced.

Examples

The following configuration enters Route Map Configuration mode for route map abc.

(config)# route-map abc

(config-route-map)#

set as-path prepend

Name

set as-path prepend - specifies a series of AS numbers to be prepended to a route’s AS_PATH before announcement

Syntax

set as-path prepend as_number

no set as-path prepend as_number

Mode

Route Map Configuration

Parameters

as_number - an AS number or list of AS numbers specified using integers. The value range is 0 to 65535, inclusive.

Description

Use the set as-path prepend command to specify a series of AS numbers to be prepended to a route’s AS_PATH before announcement. These AS numbers are included in a lending sequence of the type appropriate for the peer they are being sent to.

Note: This command applies only to BGP. It will be ignored for all other protocols.

Default

The set as-path prepend command is not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if a route matches AS Path list "alist1", then the numbers 655 will be prepended to a route’s AS_PATH before announcement, and the origin advertised to BGP will be "incomplete".

(config)# route-map xyz

(config-route-map)# match as-path-list alist1

(config-route-map)# set as-path prepend 655

(config-route-map)# set origin incomplete

(config-route-map)# exit

(config)#

set community-set

Name

set community-set - specifies a community set that should be added to a route, removed from a route, or overwritten

Syntax

set community-set name [extended]? [delete | additive? | overwrite]

no set community-set name [extended]? [delete | additive | overwrite]?

Mode

Route Map Configuration

Parameters

name - the name of a community set

extended - specifies that the referenced community set is of the extended type

delete - removes a set of communities or extended communities from a route

additive - adds a set of communities or extended communities to a route. Because this is the default action, specifying this is optional.

overwrite - specifies that the community set overwrites any communities received with the route

Description

Use the set community-set command to specify a community set in a route map and whether that community set should be added to a route, deleted from a route, or overwritten. The negative form of this command, no set community-set, removes the configured list from the actions to take in this route map.

Notes:

  • This command applies only to BGP.
  • Specifying an argument for the community set name in the no form of this command has no effect on the configuration. Thus, delete, additive, and overwrite are displayed above as optional.

Default

Community sets are not explicitly added to this route map by default. If one is configured, however, the default action is additive.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route being evaluated against route map "abc" matches interface "fxp1" and the AS path list labeled "list1", then the following set actions will be executed:

  • Communities specified in community set "com-set-1" will be added to the matching route.
  • Communities specified in community set "com-set-2" will be deleted from the matching route.
  • The metric for routes will be set to 50.

(config)# route-map abc

(config-route-map)# match interface fxp1

(config-route-map)# match as-path-list list1

(config-route-map)# set community-set com-set-1 additive

(config-route-map)# set community-set com-set-2 delete

(config-route-map)# set metric 50

(config-route-map)# exit

(config)#

set dampen-flap

Name

set dampen-flap - specifies the name of a route flap dampening configuration to be matched

Syntax

set dampen-flap name

no set dampen-flap name

Mode

Route Map Configuration

Parameters

name - a string of characters specifying a dampen flap

Description

In order for any damping to take place, routes must match against a route map that specifies damping parameters. The set dampen-flap command specifies a dampen flap that contains these parameters.

Default

The set dampen-flap command is not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if a route matches AS path list "list1", then damping will occur as specified by the parameters in the dampen flap named rfd1.

(config)# route-map abc

(config-route-map)# match as-path-list list1

(config-route-map)# set dampen-flap rfd1

(config-route-map)# exit

(config)#

set ip next-hop

Name

set ip next-hop - specifies the nexthop with which a BGP route is to be advertised

Syntax

set ip next-hop ipv4_address

no set ip next-hop ipv4_address

Mode

Route Map Configuration

Parameters

ipv4_address - a valid IPv4 address in dotted-quad format

Description

Use the set ip next-hop command to specify the nexthop with which a BGP route is to be advertised.

Note: This command only applies to BGP. It will be ignored for all other protocols.

Default

BGP will not modify the nexthop value by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if a route matches AS path list "list1", then the nexthop when the route is announced by BGP will be 192.10.2.1.

(config)# route-map abc

(config-route-map)# match as-path-list list1

(config-route-map)# set ip next-hop 192.10.2.1

(config-route-map)# exit

(config)#

set local-preference

Name

set local-preference - sets a route’s local preference

Syntax

set local-preference num

no set local-preference num?

Mode

Route Map Configuration

Parameters

num - an integer from 0 to 4,294,967,295, inclusive

Description

Use the set local-preference command to set a route’s BGP Local Preference value. The negative form of this command, no set local-preference, removes the configured num value.

Notes:

  • This command applies only to BGP routes. It will be ignored for all other routes.
  • Specifying a value for num in the no form has no effect on the configuration. Thus, it is displayed above as optional.

Default

This command is not explicitly configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route matches the AS Path list labeled "aspathlist1", then the local preference value will be set to 10.

(config)# route-map abc

(config-route-map)# match as-path-list aspathlist1

(config-route-map)# set local-preference 10

(config-route-map)# exit

set med

Name

set med - specifies the MED with which a matching route will be announced

Syntax

set med [ +value | +igp | value | igp ]

no set med [ +value | +igp | value | igp ]

Mode

Route Map Configuration

Parameters

+value - an integer to be added to the route’s current MED. This value can be from 0 to 4,294,967,295, inclusive.

value - an integer to be used as the route’s MED. This value can be from 0 to 4,294,967,295, inclusive.

+igp - specifies to add the route’s IGP metric to the MED

igp - specifies to use the routes IGP metric as the MED

Description

Use the set med command to change or configure a MED value with which a route will be announced if a match occurs in this route map. Note: This command only applies to BGP. It will be ignored for all other protocols.

Default

The MED value is not configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route matches the AS Path list labeled "aspathlist1", then the MED will be set to 1.

(config)# route-map abc

(config-route-map)# match as-path-list aspathlist1

(config-route-map)# set med 1

(config-route-map)# exit

(config)#

set metric

Name

set metric - specifies the metric with which a matching route will be announced

Syntax

set metric value

no set metric value

Mode

Route Map Configuration

Parameters

value - an integer

Description

Use the set metric command to change or configure a metric with which a route will be announced if a match occurs in this route map. Note: This command has no effect on BGP routes.

Default

The metric value is not configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route matches the AS Path list labeled "aspathlist1", then the metric will be set to 1.

(config)# route-map abc

(config-route-map)# match as-path-list aspathlist1

(config-route-map)# set metric 1

(config-route-map)# exit

(config)#

set metric-type

Name

set metric-type - configures the metric types for OSPF and BGP

Syntax

set metric-type [internal | type-1 | type-2]

no set metric-type [internal | type-1 | type-2]

Mode

Route Map Configuration

Parameters

internal - specifies that BGP should use IGP metrics as the MED value

type-1 - specifies OSPF external type 1 metric

type-2 - specifies OSPF external type 2 metric

Description

Use the set metric-type command to configure metric types for OSPF and BGP. The meanings are specific to each protocol.

Note: You cannot include more than one parameter for a single set metric-type command

Default

If set metric-type is not specified, it is the same as if the user had specified the following
for OSPF: (config-route-map)# set metric-type type-2
for BGP: (config-route-map)# no set metric-type internal

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if routes are announced with a tag value of 4, then when this route map is imported into a protocol, the metric-type for OSPF routes will be configured as type-2.

(config)# route-map abc

(config-route-map)# match tag 4

(config-route-map)# set metric-type type-2

(config-route-map)# exit

(config)#

set origin

Name

set origin - sets the origin attribute on matching routes to be advertised to BGP

Syntax

set origin [egp | igp | incomplete]

no set origin [egp | igp | incomplete]

Mode

Route Map Configuration

Parameters

egp - specifies routes learned from the EGP protocol. This path is most likely not complete.

igp - specifies routes learned from an Intra-Domain Routing Protocol. This path is most likely complete.

incomplete - specifies routes learned from a source other than IGP and EGP

Description

Use the set origin command to configure the origin attribute on matching routes to be advertised to BGP when this route is exported. An origin of igp indicates the route was learned from an Intra-Domain Routing Protocol and is most likely complete. An origin of egp indicates the route was learned from the EGP protocol, and the path is most likely not complete. When the route is learned from another source, an origin of incomplete is used.

Notes:

  • This command applies only to BGP.
  • Some competitors set the BGP ORIGIN attribute differently on routes configured via the static statement (origin incomplete) than via the BGP network statement (origin IGP). Advanced Routing Suite always sets origin incomplete. Use the "set origin" Route Map command to modify the origin.

Default

The set origin command is not configured by default.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if a route matches AS Path list "as-path-list1", then the numbers 655 will be prepended to the route’s AS_PATH before announcement, and the origin will be set to "incomplete".

(config)# route-map xyz

(config-route-map)# match as-path-list as-path-list1

(config-route-map)# set as-path prepend 655

(config-route-map)# set origin incomplete

(config-route-map)# exit

(config)#

set preference

Name

set preference - configures the Advanced Routing Suite preference on routes matching this route map

Syntax

set preference pref

no set preference pref

Mode

Route Map Configuration

Parameters

pref - an integer between 1 and 255, inclusive

Description

Use the set preference command to configure the Advanced Routing Suite preference on routes that match this route map.

Default

The default preference value is the preference value of the protocol.

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if a route’s AS Path matches the AS Path list labeled "aspathlist1", then the preference will be set to 50.

(config)# route map abc

(config-route-map)# match as-path-list aspathlist1

(config-route-map)# set preference 50

(config-route-map)# exit

(config)#

set propagate

Name

set propagate - specifies whether type-7 (nssa) routes get translated into type-5 routes on the backbone

Syntax

set propagate

no set propagate

Mode

Route Map Configuration

Parameters

none

Description

Use the set propagate command to specify whether type-7 (nssa) routes get translated into type-5 routes on the backbone. If the flag is not set on a route, then it is not translated.

Note: This command applies only to OSPF. It will be ignored for all other protocols.

Default

If set propagate is not specified, it is the same as if the user had specified the following:

(config-route-map)# no set propagate

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if the route being evaluated against route map "abc" matches the BGP Community List "commlist1" and the AS path list labeled "aspathlist1", then exported routes will be propagated.

(config)# route-map abc

(config-route-map)# match community commlist1

(config-route-map)# match as-path-list aspathlist1

(config-route-map)# set propagate

(config-route-map)# exit

(config)#

set ribs

Name

set ribs - specifies the RIBs into which a route will be imported or from which a route will be exported

Syntax

set ribs [ unicast | multicast ]

no set ribs [ unicast | multicast ]

Mode

Route Map Configuration

Parameters

unicast - specifies unicast RIB

multicast - specifies multicast RIB

Description

Use the set ribs command to specify the RIBs into which a route will be imported or from which a route will be exported.

Default

By default, a route map applies to all RIBs.

Command History

NGC 2.2 - This command was introduced.

Examples

The following example causes routes in the unicast RIB to be exported into both the unicast and multicast RIBs.

(config)# route-map abc

(config-route-map)# match ribs unicast

(config-route-map)# set ribs unicast

(config-route-map)# set ribs multicast

(config-route-map)# exit

(config)#

set tag

Name

set tag - specifies the tag value with which routes will be announced into OSPFASE, RIP, or RIPng

Syntax

set tag tag_value

no set tag tag_value?

Mode

Route Map Configuration

Parameters

tag_value - a 32-bit value for the tag specified using a decimal (base 10) number

Description

Use the set tag command to propagate tag data from an exterior gateway protocol (such as BGP) through OSPFASE, RIP, or RIPng. The negative form of this command, no set tag, removes the configured tag_value and returns this to its default value of 0.

Notes:

  • Specifying a value for tag_value in the no form has no effect on the configuration. Thus, it is displayed above as optional.
  • This command will be ignored for any protocol that is not OSPFASE, RIP, or RIPng.

Default

If set tag is not specified, it is the same as if the user had specified the following:

(config-route-map)# set tag 0

Command History

NGC 2.2 - This command was introduced.

Examples

In the following example, if routes are received with a tag value of 4, then when a matching route is imported into a protocol, the preference for that route will be configured as 50, and the new tag value will be 5.

(config)# route-map abc

(config-route-map)# match tag 4

(config-route-map)# set preference 50

(config-route-map)# set tag 5

(config-route-map)# exit

(config)#

 
Top of Page ©2013 Check Point Software Technologies Ltd. All rights reserved. Download Complete PDF Send Feedback Print