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Introduction to Logging and
Monitoring

Check Point provides comprehensive logging and monitoring capabilities, integrating security
data, event management, reporting, and policy enforcement into a unified system.
Administrators can efficiently access security trends and details through customizable widgets
and chart templates, allowing for clear, visual representation of data at a glance. Logs are
seamlessly integrated with security policy rules, enabling quick access to logs associated with
specific rules. By simply selecting a rule, admin can view the related logs and events instantly.

Powerful free-text search capabilities allow users to retrieve results from millions of logs in
seconds, offering quick insights into specific incidents Administrators can move effortlessly
between high-level overviews and detailed event information, such as attack types, timelines,
applications, and sources. Based on event severity, you can choose to ignore, delay action,
block, or refine policy rules directly linked to the event for real-time adjustments.

The system also facilitates reporting, enabling the creation of tailored reports for managers,
auditors, or stakeholders, focusing only on relevant content. This functionality is integrated
within the unified SmartConsole platform, providing access to rich, customizable views for both
log analysis and event monitoring.

For web-based access, the SmartView application allows administrators to browse logs and
monitor data remotely through a browser by connecting to the Security Management Server or
SmartEvent Server.

These integrated tools streamline incident investigation, policy refinement, and reporting,
making Check Point a powerful solution for proactive security management.
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Getting Started

This section introduces the logging and monitoring clients, and explains how to install and
configure logging and monitoring products.

Logging and Monitoring Clients

Monitor logs and events using customizable views and reports. Use these GUI clients:

GUI Client Description

SmartConsole >
Logs & Events

SmartView Web
Application

CPView

Analyze events that occur in your environment with customizable views
and reports.

The Logs view replaces the SmartView Tracker and SmartLog GUI
clients.

It has the same real-time event monitoring and analysis views as
SmartConsole, with the convenience of not having to install a client.
Browse to: https://<Server IP>/smartview/,where <Server
I1P> is IP address of the Security Management Server or SmartEvent
Server.

On Security Gateways, shows the rate of the generated logs.

On Management Servers / Log Servers, shows the rate of the received
logs, indexed logs, and exported logs.

For the information, see sk101878.

These GUI clients are still supported:

GUI Clients Description

SmartEvent

SmartView
Monitor

® For initial settings - configure the SmartEvent Correlation Unit, Log
Server, Domains and Internal Network.

® For the correlation policy (event definitions)

® For Automatic Reactions

To monitor tunnels

To monitor users

For suspicious activity rules

To monitor alerts - Thresholds configuration

For more about monitoring, see "Monitoring Traffic and Connections" on
page 169.
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Getting Started

SmartView GUI Clients

Administrator access permissions can be limited by the GUI Clients list based on IP address,
IP range, a network or a host name.This list is based on the GUI clients' access configuration
as defined on the relevant Security Management Server or a Multi-Domain Server.

See the R82 Security Management Administration Guide > Chapter Managing Administrator
Accounts > Section Defining Trusted Clients.

To open the SmartEvent GUI:
1. Open SmartConsole > Logs & Events.
2. Click (+) for a Catalog (new tab).

3. Inthe External Apps section, click SmartEvent Settings & Policy.

To open the SmartView Monitor GUI:
1. Open SmartConsole > Logs & Events.
2. Click (+) for a Catalog (new tab).

3. Inthe External Apps section, click Tunnel & User Monitoring.
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Understanding Logging

Understanding Logging

Security Gateways / Cluster Members generate network logs, and the Management Server
generates audit logs, which are a record of actions taken by administrators. The Security
Policy that is installed on each Security Gateway / Cluster determines which rules generate
logs.

Logs can be stored on a:

® Management Server that receives logs from the managed Security Gateways / Clusters.
This is the default.

® | og Server on a dedicated machine. This is recommended for organizations that
generate a lot of logs.

B Security Gateways / Cluster Members. This is called local logging.

o Note - Logs can be automatically forwarded to the Security Management Server or
Log Server, according to a schedule, or manually imported with the Remote File
Management operation via CLI (with the "fw fetchlogs" command). The
management servers and log servers can also forward logs to other servers.

To find out how much storage is necessary for logging, see the R82 Release Notes.

A Log Server handles log management activities:

® Automatically starts a new log file when the existing log file gets to the defined maximum
size.

® Stores log files for export and import.

® Makes an index of the logs to enable faster responses to log queries.

o Notes:

» SmartLog Indexing mode is not enabled by default after upgrade or new
installation, on Smart-1 205, Smart-1 210, or Open Servers with less than
4 cores.

» To change SmartLog mode from Indexing to Non-Indexing on a Domain
Management Server or Domain Log Server, edit the Domain Server object
on the Domain level. There is no option to change the entire Multi-Domain
Server or Multi-Domain Log Server to Non-Indexing mode.

An administrator can configure Backup Log Servers:

® |f all Primary Log Servers are disconnected, the Security Gateway / Cluster starts to
send logs only to the first configured Backup Log Server.

® |f the first Backup Log Server is also disconnected, the Security Gateway / Cluster sends
logs to the second configured Backup Log Server, and so on.
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Understanding Logging

Configuring the Age of Log Files to Migrate During an
Upgrade

Starting in R81.20, when you upgrade a Management Server / Log Server to a new version,
log file migration to the new version is limited to logs for the past 180 days.

You can change the age of log files to a number between 30 and 360 days.

To configure the number of days for log file migration:

o Important - You must do this procedure before you upgrade.

Procedure

1.

Connect to the command line on the server (Security Management Server, Multi-
Domain Server, Multi-Domain Log Server, dedicated Log Server, dedicated
SmartEvent Server):

Log in to the Expert mode.

Create the required XML file:
touch S$FWDIR/conf/upgradeLogData.xml
Edit this XML file:

vi SFWDIR/conf/upgradeLogData.xml

This XML file must contain these lines:

<config>
<ImportLogDays>NUMBER_OF_DAYS</ImportlLogDays>
</config>

The number of days must be an integer between 30 and 360.

Save the changes in the file and exit the editor.
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Dedicated Log Servers and Domain Dedicated Log Servers

To decrease the load on the Management Server, you can install a dedicated Log Server and
configure the Security Gateways to send their logs to this Log Server.

To see the logs from all Log Servers, connect to the Management Server with SmartConsole,
and go to the Logs & Events view > Logs tab.

See:
® "Deploying Logging" on page 32

® "Deploying a Domain Dedicated Log Server" on page 43

Dynamic Log Distribution

In R81 and lower versions, each Log Server received a copy of every log. If one Log Server
was disconnected, the Security Gateway / Cluster connected to the backup Log Server and
sent it a copy of every log.

Starting in R81.10, with Dynamic Log Distribution, you can configure the Security Gateway /
Cluster to distribute its logs between the active Log Servers.

If all the primary Log Servers are disconnected, logs are distributed between backup Log
Servers.

If no Log Servers are connected, the Security Gateway / Cluster writes the logs locally.
Use Case - Log distribution reduces:
® The high utilization of resources on the Log Servers.

® The log traffic on each network that connects the Security Gateway / Cluster to its Log
Server.

Configuring log distribution between multiple Log Servers

1. Connect with SmartConsole to the Management Server that manages this Security
Gateway / Cluster.

From the left navigation panel, click Gateways & Servers.
Open the Security Gateway / Cluster object.

From the left tree, click Logs > Log Distribution.

a bk~ N

In the section Log Distribution, select Distribute logs between log servers for
improved performance (applies to primary and backup log servers).

6. Inthe section Log Servers > Primary log server, select the applicable primary Log
Server object(s).
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In the section Log Servers > Backup log server, select the applicable backup Log
Server object(s).
Click OK.
Publish the SmartConsole session.

Install the Access Control policy on the Security Gateway / Cluster object.
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Understanding Logging

SmartEvent Server and Log Server use an optimization algorithm to manage disk space and
other system resources. When the Logs and Events database becomes too large, the server
automatically deletes the oldest logs and events based on the configured thresholds.

Procedure for a Management Server / SmartEvent Server / Log Server

—_—

s W N

Connect with SmartConsole to the Management Server.
From the left navigation panel, click Gateways & Servers.
Open the object of the Management Server / SmartEvent Server / Log Server.

From the left tree, go to Logs > Storage.

Note - The Logs section appears only if you enabled the Logging & Status
Software Blade on the General Properties page > Management tab.

Measure free
disk space in

When disk
space is below
<number>
Mbytes, issue
alert <type>

When disk
space is below
<number>
Mbytes, start
deleting old
files

Run the
following
script before
deleting old
files

. In the Disk Management section, configure these settings:

Field Description / Instructions

Select MBytes or Percentage.

Get an alert when the available disk space for logs and log index
files is below this threshold.

This value must be at least 5 MB greater than the value in the
When disk space is below <number> Mbytes, stop logging
field on the Additional Logging Configuration page.

Delete the oldest logs and log index files when the available disk
space is below this threshold.

The server examines the available space in the log partition
every 1 minute. When the threshold is reached, the log disk
maintenance occurs- deleting the oldest day of log and index
data and repeating until reaching the available space above the
configured threshold.

This value must be at least 5 MB greater than the value in the
When disk space is below <number> Mbytes, issue alert
<type> field on this page.

Enter an absolute path to the shell script (path and the file name).
This shell script must exist on the server.
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Understanding Logging

In the Daily Logs Retention Configuration section, configure these settings:

For more information, see "Daily Logs Retention" on page 26.

First, select Apply the following logs retention policy.

Field Description / Instructions

Keep indexed logs
for no longer than
<number> days

Keep log files for
an extra <number>
days

Occurs daily at midnight.
Deleting oldest index files by days, keeping today + the
configured number of index days (14 = 14 days + today).

Occurs daily at midnight.

Deleting oldest log files by days, keeping today + the
configured number of index days + extra log days (3664 =
14 [from index settings] + 3650 days + today).

As 3664 is more than 10 years, effectively keeping all log
files.

o Note - The maximum total value of both indexed logs and log files is 3664 days.

Click OK.

8. Publish the SmartConsole session.

9.

Install the database (click Menu > Install database > select all server objects > click

Install)

Procedure for a Security Gateway / Cluster

a &~ b

Connect with SmartConsole to the Management Server.

From the left navigation panel, click Gateways & Servers.

Open the object of the Security Gateway / Cluster.

From the left tree, go to Logs > Storage.

In the Disk Management section, configure these settings:

Description / Instructions

Measure free Select MBytes or Percentage.

disk space in
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Field Description / Instructions

When disk Get an alert when the available disk space for logs and log index
space is below | files is below this threshold.
<number> This value must be at least 5 MB greater than the value in the
Mbytes, issue | When disk space is below <number> Mbytes, stop logging
alert <type> field on the Additional Logging Configuration page.
When disk Delete the oldest logs and log index files when the available disk
space is below | space is below this threshold.
<number> The server examines the available space in the log partition
Mbytes, start every 1 minute. When the threshold is reached, the log disk
deleting old maintenance occurs- deleting the oldest day of log and index
files data and repeating until reaching the available space above the
configured threshold.
This value must be at least 5 MB greater than the value in the
When disk space is below <number> Mbytes, issue alert
<type> field on this page.
Run the Enter an absolute path to the shell script (path and the file name).
following This shell script must exist on the server.
script before
deleting old
files
Reserve Some types of logs can also capture the packets that created the
<number> log event. Set the amount, in megabytes or percent, that you
<units> for want to use for captured packets.
packet
capturing

6. Inthe Daily Logs Retention Configuration section, configure these settings:
For more information, see "Daily Logs Retention" on page 26.

First, select Apply the following logs retention policy.

Description / Instructions

Keep indexed logs
for no longer than
<number> days

Occurs daily at midnight.
Deleting oldest index files by days, keeping today + the
configured number of index days (14 = 14 days + today).
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Field Description / Instructions

Keep log files for Occurs daily at midnight.

an extra <number> | Deleting oldest log files by days, keeping today + the
days configured number of index days + extra log days (3664 =
14 [from index settings] + 3650 days + today).

As 3664 is more than 10 years, effectively keeping all log
files.

o Note - The maximum total value of both indexed logs and log files is 3664 days.
7. Click OK.
8. Publish the SmartConsole session.

9. Install the Access Control policy on the Security Gateway / Cluster object.
Examples

For these examples, the administrator enables these thresholds:
® When disk space is below [5000] Mbytes, start deleting old files
® Daily logs retention
» Keep indexed logs for 14 days
» Keep log files for an extra 6 days (6 + 14 = 20 days of log files)

Example Description

1 The server has 3000 MBytes of free disk space, and 5 days of logs and
index files.

The server deletes logs and index files, one day at a time, until there is
5000 Mbytes of free disk space.

2 The server has 10 GBytes of free disk space and 30 days of logs and index
files.

The server deletes all log files older than 20 days ago (6 + 14), each day at
midnight.

The server deletes all index files older than 14 days ago, each day at
midnight.
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Example Description

3 A server produces 1GB of logs and 1GB of index files each day. The
server now has 35 days of logs and 30 days of index files and only 2.5GB
of free disk space left. The configured disk space threshold is 5GB, which
means the server is now 2.5GB below the threshold.

The index files threshold is 14 days.

The log file threshold is 20 days.

When the disk space threshold (5GB) is reached, disk space maintenance
deletes logs and index data until there is again more than 5GB of free
space.

In this example:

1. Logs from day one are deleted first, as they are older. Three days of
the oldest logs are deleted to clear 3GB of logs and leave 6GB of
free space on the drive, 1GB above the threshold, leaving the server
with 32 log days and 30 index days.

2. The server still has more than 14 days of index files - an extra 16
days (30 days of index files now)

And more than 20 days of logs - an extra 12 days (32 days of log files
now).

At midnight, the extra log & index files are deleted until only the
current day’s log files plus the last 20 days remain.

Index days are deleted until only the current day’s index plus the last
14 days remain.

The deletion of three days of logs left 5.5GB of free space.

The deletion of 12 log file days + 16 index file days frees up a total of
28GB (12 + 16) of space.

33.5GB of space is now free.

The daily logs retention occurs every day at midnight keeping the
chosen number of days of log + index data.

Most likely, this means it will never reach the log disk space
threshold. But if the log disk space threshold is again reached, the
log disk maintenance process repeats to make sure space never
runs out.

Daily Logs Retention

In R80.40 and higher, daily logs retention refers to how long logs are stored before they are
deleted. Configure this value to help you manage free disk space.

The Management Server does not delete audit log files, even in a case of emergency disk
space maintenance, regardless of the configured log retention value. You cannot configure the
daily retention for the Management Server audit logs.
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The Management Server does not delete audit indexes as part of daily maintenance
regardless of the value configured in SmartConsole. The Management Server deletes audit
log indexes (not the log files) only in a disk space emergency. In a Multi-Domain environment,
you can change this behavior only for the Global SmartEvent Serverinthe 1og
maintenance domain conf.csv file (see the corresponding section below).

o Note - The server deletes old logs daily at midnight.

You can configure log retention policy on different servers:

Configuring daily logs retention for a Security Management Server / dedicated SmartEvent
Server / dedicated Log Server

1. Connect with SmartConsole to the applicable server:
® Security Management Server if managed Security Gateways send their logs to it

® Security Management Server that manages the dedicated SmartEvent Server or
dedicated Log Server

2. From the left navigation panel, click Gateways & Servers.

3. Open the object of the Management Server / dedicated SmartEvent Server/
dedicated Log Server.

4. From the left tree, go to Logs > Storage.
5. In the section Daily Logs Retention Configuration:
a. Select Apply the following logs retention policy.

b. In the field Keep indexed logs for no longer than <number> days, configure
the required number of days.

c. Inthe field Keep log files for an extra <number> days, configure the required
number of days.

Notes:
® When this value is 0, the servers keeps the indexed logs and the
log files for the same number of days.
® |f you configure a value greater than 0, the server keeps the log
files for the additional configured number of days (after the
configured number of days for indexed logs).

0 Note - The maximum total value of both indexed logs and log files is 3664 days.

6. Click OK.

7. Publish the SmartConsole session.
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8. Install the database (click Menu > Install database > select all server objects > click
Install).

Configuring daily logs retention in a Multi-Domain environment - for all Domain Management
Servers / Domain Log Servers

o Notes:

® Only Super User can configure these settings.

® This configuration applies to all Domain Management Servers and Domain
Log Servers that are not configured explicitly (see the corresponding
section).

® The daily index deletion on the Multi-Domain Server / Multi-Domain Log
Server is enforced based on the greatest value configured between the
Domain and the Multi-Domain Server levels.

1. Connect with SmartConsole to the applicable Multi-Domain Server / Multi-Domain Log
Server to the MDS context.

N

From the left navigation panel, click Multi-Domain > Domains.

w

In the table, locate the column for this Multi-Domain Server / Multi-Domain Log Server.

4. Right-click the cell for this Multi-Domain Server / Multi-Domain Log Server and click
Edit.

The Multi-Domain Server window opens.

o

From the left tree, go to Log Settings > General.

D

. In the section Daily Logs Retention Configuration:
a. Select Apply the following logs retention policy.

b. Inthe field Keep indexed logs for no longer than <number> days, configure
the required number of days.

c. Inthe field Keep log files for an extra <number> days, configure the required
number of days.

Notes:

® When this value is 0, the servers keep the logs and the indexed
logs for the same number of days.

® |f you configure a value greater than 0, the server keeps the logs
for the additional configured number of days.

o Note - The maximum total value of both indexed logs and log files is 3664 days.
7. Click OK.

8. Publish the SmartConsole session.
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Configuring daily logs retention in a Multi-Domain environment - for a specific Domain
Management Server / Domain Log Server

0 Notes:

® Only Super User can configure these settings.

® By default, all Domain Management Servers use the settings a Super User
configured in the Multi-Domain Server / Multi-Domain Log Server object.

® The Multi-Domain Server / Multi-Domain Log Server deletes a log index only
when no Domains use this log index.
For example, if you configured one Domain to keep its log index for 5 days
and another Domain to keep its log index for 30 days, then the server deletes
the log index only after 30 days.

1. Connect with SmartConsole to the applicable Domain Management Server.

2. From the left navigation panel, click Gateways & Servers.
3. Open the object of the Domain Management Server / Domain Log Server.
4. From the left tree, go to Logs > Storage.
5. Inthe section Daily Logs Retention Configuration:
a. Select Override Multi-Domain Settings.
b. Inthe field Keep indexed logs for no longer than <number> days, configure
the required number of days.
c. Inthe field Keep log files for an extra <number> days, configure the required
number of days.
Notes:
® When this value is 0, the servers keep the logs and the indexed
logs for the same number of days.
® |f you configure a value greater than 0, the server keeps the logs
for the additional configured number of days.
o Note - The maximum total value of both indexed logs and log files is 3664 days.
6. Click OK.

7. Publish the SmartConsole session.

8. Install the database (click Menu > Install database > select all server objects > click
Install)

Configuring daily logs retention in a Multi-Domain environment - for a Global SmartEvent Server

You must configure the required settings only in the corresponding configuration file:
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Settings Configuration File Comment
General settings that apply to all Domain log policy See
Management Servers that use this Global extended.C sk117317
SmartEvent Server

Settings that apply to only to a specific Domain log See below
Management Server that uses this Global maintenance

SmartEvent Server domain conf.csv

0 Note - If you do not configure settings explicitly, then the default values apply.

To configure settings for specific Domain Management Servers:

1.
2.

Connect to the command line on the Multi-Domain Server over SSH.
Log in to the Expert mode.

Back up the current file:

cp -v SRTDIR/conf/log maintenance domain conf.csv{,
ORIGINAL}

Get the contents of the current file:

cat SRTDIR/conf/log maintenance domain conf.csv

On your computer, copy the two lines from this file (from the SSH session) into a text
editor or table editor (like Microsoft Excel, or LibreOffice Calc).

Save the file in the CSV format with this name:

log maintenance domain conf.csv

Configure the names of Domains and the required number of days to keep the logs.

Best Practice - Add the row with the Domain nhame "de fault" and configure
the default values. Each new Domain you create automatically uses these
default values.

Example for "Domain1" and "Domain2":
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. other-
firewallandv resourc smarteve
other smartlo
es nt
Jd
Domain | 3650 | 20 15 15 14 14 30
1
Domain | 3650 | 20 30 30 14 14 14
2
default | 3650 | 30 14 14 14 14 14

o Note - If you do not configure a Domain explicitly, then it takes the greatest
values from each column. In the example, if there is a Domain called
"Domain3", but you do not configure it explicitly in this file, then this Domain
uses the values "3650, 20, 30, 30, 14, 14, 14, 30"

8. Copy the modified CSV file from your computer to the Multi-Domain Server to some
directory (for example, /var/log/).

9. Go back to the SSH session on the Multi-Domain Server.

10. If you edited this CSV file on Windows OS, then convert the file from the DOS format
to the UNIX format:

dos2unix /var/log/log maintenance domain conf.csv
11. Replace the current file with the modified file:

cp -f -v /var/log/log maintenance domain conf.csv
SRTDIR/conf/log maintenance domain conf.csv

cat SRTDIR/conf/log maintenance domain conf.csv
12. Restart Check Point services:

mdsstop ; mdsstart

Log Receive Rate

To learn how to monitor the Log Receive Rate on the Management Server / Log Server, see
sk120341.
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Deploying Logging

You can enable logging on the Security Management Server (enabled by default), or deploy a
dedicated Log Server.

After you deploy the Log Server, you must configure the Security Gateways for logging.

You must execute the Install Database function on the remote Log Server when you:

® Enable or disable a logging related blade or function, including Log Indexing in a server
object.

Add a new Log Server to the system.

Change a Security Gateway's Log Server.

Change a Log Server's log settings or make any other Log Server object change.

Change anything in the Global Properties that might affect the Log Server.

Enabling Logging on the Security Management Server

1. Open SmartConsole.
2. Edit the network object of the Security Management Server.

3. Inthe General Properties page, on the Management tab, enable Logging & Status.
4. Click OK
5

. Publish the SmartConsole session.

Deploying a Dedicated Log Server

To deploy a dedicated Log Server, you must install it, and then connect it to the Security
Management Server.

Notes:

® |f you configure the Global SmartEvent Server and the dedicated Log Server to read logs
from the same domain, you receive duplicate logs.

® When you delete a Log Server object, and create it again with the same object name and
the same IP address, the Log Server does not show logs that it received before the
deletion.

For details, see the R82 Installation and Upgrade Guide.
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Configuring the Security Gateways for Logging

To configure a Security Gateway for logging:

1.

6.
7.

Open SmartConsole.

. Inthe Gateways & Servers view, double-click the Security Gateway object.

2
3.
4

From the navigation tree, click Logs.

. Configure where to send logs:

® To save logs to the Security Management Server - Select Send gateway logs to
server.

® To save logs to a dedicated Log Server - Select the Log Server from the list.
® To save logs locally - Select Save logs locally, on this server.

Click OK.

Publish the SmartConsole session.

Install a policy on the Security Gateway.

Enabling Log Indexing

Log indexing on the Security Management Server or Log Server reduces the time it takes to
run a query on the logs. Log indexing is enabled by default.

In a standalone deployment, log indexing is disabled by default. Enable log indexing only if the
standalone server CPU has 4 or more cores.

To manually enable Log Indexing:

1.
2.

©® N o g bk~ W

Open SmartConsole.

From the Gateways & Servers view, double-click the Security Management Server or
Log Server object.

The General Properties window opens.

In the Management tab, select Logging & Status.
From the navigation tree, click Logs.

Select Enable Log Indexing.

Click OK.

Publish the SmartConsole session.

From Menu, select Install Database > select all objects > click Install.
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Disabling Log Indexing

To save disk storage space, a Log Server can be configured to work in non-index mode. If you
disable log indexing, queries will take longer.

When log indexing is disabled, you must connect with SmartConsole to each Log Server
separately to query its logs. When you connect to the Management Server you do not get a
unified view of all logs, as in index mode. On each Log Server, the search is done on one log
file at a time.

To disable Log Indexing:

1.

N o o & »w

Open SmartConsole.

From the Gateways & Servers view, double-click the Security Management Server or
Log Server object.

From the navigation tree, click Logs.
Clear the Enable Log Indexing option.
Click OK.

Publish the SmartConsole session.

From Menu, select Install Database > select all objects > click Install.

To select a log file to search:

1.
2.
3.

Open Logs & Events > Logs view.
Click the Options menu button to the right of the search bar.

Select File > Open Log File.
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Deploying SmartEvent

SmartEvent Server is integrated with the Security Management Server architecture. It
communicates with Log Servers to read and analyze logs. You can enable SmartEvent on the
Security Management Server or deploy it as a dedicated server.

Only a Security Management Server can also work as a SmartEvent Server. In a Multi-Domain
environment, you must install SmartEvent on a dedicated server.

You must execute the Install Database function on the remote SmartEvent Server when you:
® Enable or disable a SmartEvent Server blade, including Log Indexing in a server object.
® Add a new SmartEvent Server to the system.

® Change a SmartEvent Server log settings or make any other SmartEvent Server object
change.

® Change anything in the Global Properties that might affect the SmartEvent Server.

SmartEvent Licensing

You can deploy SmartEvent in these ways:

® As part of the SmartEvent - A renewable one year license is included with the
SmartEvent package.

® As a dedicated server - You can purchase a perpetual license for a SmartEvent Server.

Enabling SmartEvent on the Security Management Server

1. Open SmartConsole.
2. From the left navigation panel, click Gateways & Servers.
3. Open the Security Management Server object.
4. Onthe Management tab, enable these Software Blades:
® | ogging & Status
® SmartEvent Server
® SmartEvent Correlation Unit
5. Click OK.
6. Publish the SmartConsole session.

Note - For Security Gateways R77.30 and lower, you must activate the Firewall session for the
network activity report. See "Exporting Views and Reports" on page 65.

R82 Logging and Monitoring Administration Guide | 35



Deploying SmartEvent

o Note - When the trial license of SmartEvent expires, and after adding a new license,
the Security Management Server does not accept any connection.
To resolve this issue: stop and start the Security Management Server (run
cpstop; cpstart) after adding the new license.
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System Requirements

For versions earlier than R81, the SmartEvent Server from one version can be managed by
multiple management versions.

Management Server support for SmartEvent Server

Management Server version

g;":,:rE\‘,':r"stlon R77.30 RS0  R80.10 R80.20 R80.30  R80.40
R77.30 v - - - _ _
R80 v v - _ _ _
R80.10 v v v _ _ _
R80.20.M1 v v v y _ _
R80.30 v v v y 9 _
R80.40 v v v v v v

Starting from R81, SmartEvent server can only be managed by a Security Management Server
of the same version. Managing SmartEvent by a lower version of the Security Management
Server is no longer supported.

To use SmartEvent, see the requirements in the R82 Release Notes.

Installing a Dedicated SmartEvent Server

For information on how to install a SmartEvent Server, see the R82 Installation and Upgrade
Guide.

—

. Download the installation ISO file.

N

Install the ISO on a Smart-1 appliance or an open server.
Allocate partition size:
® Root partition: at least 20 GB

® | ogs partition: more than allocated for Root and backup (set maximum possible) to
let the server keep a long history.

w

. When prompted, reboot.

4. Run the Gaia First Time Configuration Wizard.
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Configuring the SmartEvent Components in the First Time
Configuration Wizard

Configure the components of the dedicated server for SmartEvent on a Smart-1 appliance, or
on an open server.

For information on how to install a SmartEvent Server, see the R82 Installation and Upgrade
Guide.

Connecting R82 SmartEvent to R82 Security Management
Server

This procedure explains how to configure a dedicated server for these cated server for these
SmartEvent components:

® SmartEvent Server
® SmartEvent Correlation Unit

Note - For information on how to install a dedicated SmartEvent Server, see the R82
Installation and Upgrade Guide.

To connect R82 SmartEvent Server and SmartEvent Correlation Unit to R82 Security
Management Server:

1. In SmartConsole, create a new Check Point Host object for the dedicated SmartEvent
Server.

2. Inthe Version field, select R82.
3. Create the SIC trust with the dedicated SmartEvent Server.
4. Onthe Management tab, enable these Software Blades:
® | ogging & Status
® SmartEvent Server
® SmartEvent Correlation Unit
5. On a dedicated SmartEvent Server that is not a Log Server (recommended):
In the Logs page, make sure that Enable Log Indexing is not selected.

This ensures that Firewall connections (which are not relevant for views and reports) are
not indexed.

6. Click OK.
7. Publish the SmartConsole session.

8. Click Menu > Install Database > select all objects > click Install.
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Note - For Security Gateways R77.30 and lower: activate the Firewall session for the network
activity report. See "Exporting Views and Reports" on page 65.

Advanced Configuration for a dedicated SmartEvent Server that is also a Correlation Unit

1. Open the SmartEvent GUI:
a. In SmartConsole > Logs & Events, click + to open a catalog (new tab).
b. Click SmartEvent Settings & Policy.

2. InPolicy tab > Correlation Units, define a Correlation Unit object.

3. Select the production Log Servers and local Log Server on the SmartEvent Server to
read logs from.

4. In Policy tab > Internal Network, define the internal Network.
5. Click Save.
6. Install the Event Policy on the Correlation Unit:

SmartEvent menu > Actions > Install Event Policy.

Connecting R82 SmartEvent to R82 Multi-Domain Server

You can configure a dedicated R82 server for SmartEvent components, and connect them to
one or more Domains in an R82 Multi-Domain Security Management environment.

This procedure explains how to configure a dedicated server for these SmartEvent
components:

® SmartEvent Server
® SmartEvent Correlation Unit
Notes:

® From R81, you can configure the SmartEvent Server and SmartEvent Correlation Unit at
the level of the Global Domain and at the level of a specific Domain.

® Configure SmartEvent to read logs from one Domain or a number of Domains.

Connecting an R82 SmartEvent Server and SmartEvent Correlation Unit to a Global Domain on
an R82 Multi-Domain Server

1. Connect with SmartConsole to the Global Domain:
a. Connect to the Multi-Domain Server.
b. From the list of Domains, select Global.

2. Create a Check Point Host object for the Dedicated SmartEvent Server R82.
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In the Check Point Host object > General Properties page > Management tab, select
these Software Blades:
® | ogging & Status
®= SmartEvent Server
= SmartEvent Correlation Unit
Initialize SIC with the dedicated SmartEvent Server R82 Server.
Click OK.
Publish the SmartConsole session.
Reassign the Global Policy for the Domains that use SmartEvent.
For new Domains, create a new global assignment.
For each Domain Management Server that uses SmartEvent:.
a. Open SmartConsole.
b. Click Menu > Policy > Install Database > select all objects > click Install.

c. Wait until the Domain Management Server synchronizes and loads SmartEvent
process.

Connecting an R82 SmartEvent Server and SmartEvent Correlation Unit to a specific Domain on
an R82 Multi-Domain Server

1.

N o g &

Connect with SmartConsole to the specific Domain:
a. Connect to the Multi-Domain Server.
b. From the list of Domains, select the applicable .specific Domain.
Create a Check Point Host object for the Dedicated SmartEvent Server R82.

In the Check Point Host object > General Properties page > Management tab, select
these Software Blades:

® | ogging & Status

® SmartEvent Server

® SmartEvent Correlation Unit
Initialize SIC with the dedicated SmartEvent Server R82 Server.
Click OK.
Publish the SmartConsole session.

Click Menu > Policy > Install Database > select all objects > click Install.
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8. Wait until the Domain Management Server synchronizes and loads SmartEvent
process.

See also Advanced Configuration for a dedicated SmartEvent Server that is also a Correlation
Unitin "Connecting an R82 SmartEvent to an R82 Security Management Server"” on page 53.

Note - For Security Gateways R77.30 and lower: activate the Firewall session for the network
activity report in "Exporting Views and Reports" on page 65.

Configuring SmartEvent to use a Non-Standard LEA Port

You can get logs from and send logs to a third-party Log Server. The Check Point Log Server
and the third party Log Server use the LEA (Log Export API) protocol to read logs. By default,
the Check Point Log Server uses port 18184 for this connection. If you configure the Log
Server to use a different LEA port, you must manually configure the new port on the
SmartEvent Server and on the SmartEvent Correlation Unit.

Note - This procedure is not relevant if you use "Log Exporter" on page 225

To change the default LEA port:
1. Open $INDEXERDIR/log indexer custom settings.conf ina texteditor.
2. Add this line to the file:
:lea port (<new port number>)
3. Save the changes in the file and exit the editor.
4. Inthe SmartEvent client, configure the new port on the Correlation Unit.

5. In Policy tab > Correlation Units, configure the Correlation Unit to read logs from the
local Log Server (on the SmartEvent Server).

6. Configure the new port on the SmartEvent Server
a. InPolicy tab > Network Objects, double-click the SmartEvent Server object.
b. Change the LEA port No parameter to <new port number>.
7. Install the Event Policy on the Correlation Unit: Actions > Install Event Policy
8. On the SmartEvent Server
a. Run: cpstop
b. Open SFWDIR/conf/fwopsec.conf in a text editor.
c. Change these parameters:

lea server auth port <new port number>
lea server port 0
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d. Save the changes in the file and exit the editor.

e. Run: cpstart

Configuring SmartEvent to read External Logs

To configure SmartEvent to read logs from an externally-managed Log Server or an external
Security Management Server, see sk35288.

An externally managed Log Serveris managed by a different Security Management Server
than the one that manages the SmartEvent Server. An external Security Management Server
is not the one that manages the SmartEvent Server.
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Deploying a Domain Dedicated Log Server

Introduction

In a Multi-Domain Security Management environment, the Security Gateways send logs to the
Domain Management Server and dedicated Domain Log Servers.

The Multi-Domain Server unifies logs, and they can be stored on the Multi-Domain Server or
on a dedicated Multi-Domain Log Server.

Starting in R81, Multi-Domain Server supports a dedicated Log Server (installed on a separate
computer) for a Domain.

You can configure a Domain Dedicated Log Server to receive logs only from a specified
Domain, and no other Domains can access these logs.

This allows you to locate the dedicated Log Server in a separate network from the Multi-
Domain Security Management environment to comply with special regulatory requirements.

Logs reported to the Domain Dedicated Log Server can be viewed from any SmartConsole
that has permissions for this Domain.

The Domain Dedicated Log Server communicates directly only with the associated Domain
Server. No other Domain can access its log data.

Note - Connecting with SmartConsole to the Domain Dedicated Log Server to see
Security Policies is not supported.

Procedure for an R82 Multi-Domain Environment

1. Install an R82 Multi-Domain Server.

See the R82 Installation and Upgrade Guide > Chapter "Installing a Multi-Domain
Server".

2. Install a regular dedicated R82 Log Server.

See the R82 Installation and Upgrade Guide > Chapter "Installing a Dedicated Log
Server or SmartEvent Server".

3. Connect with SmartConsole to the specific Domain.

See the R82 Multi-Domain Security Management Administration Guide.

4. Add aregular Log Server object for the dedicated R82 Log Server you installed in Step 2.

Limitation - An administrator who is connected to a Domain Dedicated Log Server in
the assigned Domain cannot see the Domain's data in Views, Reports, and
Correlated Events that are based on events from the Global SmartEvent Server.

Requirement post upgrade to R82:
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For any environment, which uses SmartEvent Server or a Domain Dedicated Log Server, this
is a required step to complete post upgrade to R82 from any source version:

After you upgrade the SmartEvent Server or Domain Dedicated Log Server, run this command
in the Expert mode on each Multi-Domain Security Management Server:

SMDS FWDIR/scripts/cpm.sh -tm -op reset -d all -sd

Procedure for an R77.x Multi-Domain Environment

Upgrade with CPUSE

1.

Upgrade all servers from R77.x to R80.20 (or R80.30 or R80.40).

This applies to all Multi-Domain Servers, Multi-Domain Log Servers, Domain
Dedicated Log Servers, and SmartEvent Servers.

a. Follow the instructions in the R80.40 Installation and Upgrade Guide.

Important - Stop after the CPUSE Verifier shows the upgrade / installation is
allowed.

® For Multi-Domain Servers:

See the chapter "Upgrade of Multi-Domain Servers and Multi-Domain Log
Servers" > select the applicable section to upgrade "from R80.10 and
lower" > select the applicable section to upgrade "with CPUSE".

® ForLog Servers:

See the chapter "Upgrade of Security Management Servers and Log
Servers" > section "Upgrading a Dedicated Log Server from R80.10 and
lower" > select the applicable section to upgrade "with CPUSE".

® For SmartEvent Servers:

See the chapter "Upgrade of Security Management Servers and Log
Servers" > section "Upgrading a Dedicated SmartEvent Server from
R80.10 and lower" > select the applicable section to upgrade "with
CPUSE".

b. Fix all the errors, except the one specified for Log Servers on a Domain
Management Server:

Log Servers on the Domain Management Server level are
not yet supported in R80.x
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c. On each Multi-Domain Security Management Server, modify the Pre-Upgrade
Verifier to treat the upgrade errors as warnings:
i. Connect to the command line on the Multi-Domain Server.
ii. Login tothe Expert mode.

iii. Enterthese commands as they appear below (after each command, press
the Enter key):

cp -v $CPDIR/tmp/.CPprofile.sh{, BKP}
cat >> $CPDIR/tmp/.CPprofile.sh << EOF
> export PUV_ERRORS AS WARNINGS=1

> EOF

d. Restartthe CPUSE daemon:

DAClient stop ; DAClient start

e. Follow the instructions in the R80.40 Installation and Upgrade Guide to upgrade
all the servers "with CPUSE".

Upgrade all Multi-Domain Servers to R82.

See the R82 Installation and Upgrade Guide > chapter "Upgrade of Multi-Domain
Servers and Multi-Domain Log Servers" > select the applicable section to upgrade
"from R80.20 and higher" > select the applicable section to upgrade "with CPUSE".

On each Multi-Domain Security Management Server, run this script in the Expert
mode:

$MDS FWDIR/scripts/configureCrlDp.sh

Reboot each Multi-Domain Security Management Server:

reboot

Upgrade all Log Servers and SmartEvent Servers to R82.

See the R82 Installation and Upgrade Guide > chapter "Upgrade of Security
Management Servers and Log Servers" > section "Upgrading a Security Management
Servers or Log Server from R80.20 and higher" > section "Upgrading a Security
Management Server or Log Server from R80.20 and higher with CPUSE".

Note - To install an R82 Log Server or an R82 SmartEvent Server, see the
chapter "Installing a Dedicated Log Server or SmartEvent Server".
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6. On each Multi-Domain Security Management Server, run this script in the Expert
mode:

$MDS FWDIR/scripts/cpm.sh -tm -op reset -d all -sd

7. Reboot all the Domain Dedicated Log Servers and the SmartEvent Servers:

reboot

Advanced Upgrade

1. Upgrade all servers from R77.x to R80.20 (or R80.30 or R80.40).

This applies to all Multi-Domain Servers, Multi-Domain Log Servers, Domain
Dedicated Log Servers, and SmartEvent Servers.

a. Run the Pre-Upgrade Verifier, as detailed in the R80.40 Installation and
Upgrade Guide.

® For Multi-Domain Servers:

See the chapter "Upgrade of Multi-Domain Servers and Multi-Domain Log
Servers" > select the applicable section to upgrade "from R80.10 and
lower" > select the applicable section to upgrade "with Advanced
Upgrade".

® ForLog Servers:

See the chapter "Upgrade of Security Management Servers and Log
Servers" > section "Upgrading a Dedicated Log Server from R80.10 and
lower" > select the applicable section to upgrade "with Advanced
Upgrade".

® For SmartEvent Servers:

See the chapter "Upgrade of Security Management Servers and Log
Servers" > section "Upgrading a Dedicated SmartEvent Server from
R80.10 and lower" > select the applicable section to upgrade "with
Advanced Upgrade".

b. Fix all the errors, except the one specified for Log Servers on a Domain
Management Server:

Log Servers on Domain Management Server level are not
yet supported in R80.x

c. Inyour active shell window, run this command in the Expert mode:

export PUV_ERRORS AS WARNINGS=1
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Deploying a Domain Dedicated Log Server

d. Follow the instructions in the R80.40 Installation and Upgrade Guide to upgrade
all the servers "with Advanced Upgrade".

. Upgrade all Multi-Domain Servers to R82.

See the R82 Installation and Upgrade Guide > chapter "Upgrade of Multi-Domain
Servers and Multi-Domain Log Servers" > select the applicable section to upgrade
"from R80.10 and lower" > select the applicable section to upgrade "with Advanced
Upgrade".

. On each Multi-Domain Security Management Server, run this script in the Expert
mode:

S$MDS FWDIR/scripts/configureCrlDp.sh

. Reboot each Multi-Domain Security Management Server:

reboot

. Upgrade all Log Servers and SmartEvent Servers to R82.

See the R82 Installation and Upgrade Guide > chapter "Upgrade of Security
Management Servers and Log Servers" > section "Upgrading a Security Management
Servers or Log Server from R80.20 and higher" > section "Upgrading a Security
Management Server or Log Server from R80.20 and higher with Advanced Upgrade".

Note - To install an R82 Log Server or an R82 SmartEvent Server, see the
chapter "Installing a Dedicated Log Server or SmartEvent Server".

. On each Multi-Domain Security Management Server, run this script in the Expert
mode:

$MDS FWDIR/scripts/cpm.sh -tm -op reset -d all -sd
. Reboot all the Domain Dedicated Log Servers and SmartEvent Servers:

reboot
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Administrator Permission Profiles

Administrator Permission Profiles

You can give an administrator permissions for:
® Monitoring and Logging
® Events and Reports
To define an administrator with these permissions:
1. Define an administrator or an administrator group.

2. Define a Permission Profile with the required permissions in SmartConsole (Manage &
Settings > Permission Profiles).

3. Assign that profile to the administrator or to the administrator group.

Configuring Permissions for Monitoring, Logging, Events, and Reports

In the Profile object, select the features and the Read or Write administrator permissions for
them.

Monitoring and Logging Features
These are some of the available features:
® Monitoring
® Management Logs
® Track Logs
= Application and URL Filtering Logs

Events and Reports Features
These are the permissions for SmartEvent:
® SmartEvent
« Events - views in SmartConsole > Logs & Events
» Policy -SmartEvent Policy and Settings on SmartEvent GUI.
» Reports - in SmartConsole > Logs & Events

®= SmartEvent Application & URL Filtering reports only

Multi-Domain Security Management

In a Multi-Domain Security Management, each Event and Report is related to a Domain.
Administrators can see events for Domains according to their permissions.
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A Multi-Domain Security Management Policy administrator can be:
® | ocally defined administrator on the SmartEvent Server.
® Multi-Domain Server Super User defined on the Multi-Domain Server.

® An administrator with permissions on all Domains. Select the Domains in SmartEvent, in
Policy > General Settings > Objects > Domains. This type of administrator can install a
Policy, and can see events from multiple Domains.

SmartEvent Reports-Only Permission Profile

You can define a special permission profile for administrators that only see and generate
SmartEvent reports. With this permission profile, Administrators can open SmartConsole, but
in the Logs & Events view can see only Reports. They cannot access other security
information in SmartEvent. You can configure this permissions profile to apply to the
Application & URL Filtering blade only, or apply to all blades.

To create a SmartEvent report-only permissions profile:
1. In SmartConsole, click Manage & Settings > Permissions Profiles.

2. Inthe Permission Profiles page, select a permission profile, or click the New button and
create a permission profile.

Select Customized.

On the Events and Reports page, select SmartEvent Reports.

Clear all other options.

On the Access Control, Threat Prevention, and Others pages, clear all options.
On the Monitoring and Logging page, select all features, with Write permissions.

Click OK.

©® N o g bk~ W

The profile shows in the Permission Profiles page.
9. Assign the SmartEvent Reports Only permissions profile to administrators.
10. Publish the SmartConsole session.

11. Install the policy.
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Importing Offline Log Files

The administrator can examine logs from a previously generated log file. This makes it
possible to review security threats and pattern anomalies that occurred in the past, before
SmartEvent was installed. You can investigate threats such as unauthorized scans targeting
vulnerable hosts, unauthorized legions, denial of service attacks, network anomalies, and
other host-based activity.

The administrator can review logs from a specific timeframe in the past and focus on deploying
resources on threats that have been active but may have been missed (for example, new
events which may have been dynamically updated can now be processed over the previous
period).

Importing Log Files from SmartEvent Servers

By default, you can import offline logs from the last 1 day. To import more days of logs, change
the log indexing settings.

To change log indexing settings:

Note - Do this to make it possible to import logs that are older than 1 day before the
SmartEvent Server was installed.

1. Run: # evstop

2. Run: $INDEXERDIR/log indexer -days to index <days> -workingDir
$INDEXERDIR/

<days> is the last number of days of logs to be indexed by the SmartEvent Server. For
example, to import and index logs from the last 30 days of logs, give a value of 30.

Note - To decrease the performance effect while you index the offline logs, import only
the necessary number of days of logs.

3. Inthe Logs > Storage page of the SmartEvent Server, Make sure that Keep indexed
logs for... is not selected, or is selected with an equal or larger number of days than
configured in days_to_index.

4. Run: # evstart

To allow the SmartEvent Server to index offline log files:

1. Copy the log files and related pointer files <1log file name>.log* to SFWDIR/1log.
Copy the files to the Log Server that sends logs to the SmartEvent Server.

2. Optional: Do an Offline Work for Correlated Events procedure for each log file. This
procedure is done to run the log files through the Correlation Unit for correlation analysis
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according to the Event Policy (defined in SmartEvent GUI client).

To run SmartEvent offline jobs for multiple log files, see sk98894.

Offline Work for Correlated Events

To detect suspicious logging activity (suspicious according to the Event Policy on the
SmartEvent GUI > Policy tab), run the offline log file through the Correlation Unit.

The settings to generate of Offline logs are in: SmartEvent GUI client > Policy tab > General
Settings > Initial Settings > Offline Jobs, connected to the Security Management Servers or
Multi-Domain Server.

The settings are:
® Add - Configure an Offline Log File procedure.
» Name - Lets you recognize the specified Offline Line log file for future processing.
» Comment - A description of the Offline Job.
 Offline Job Parameters:

SmartEvent Correlation Unit: The machine that reads and processes the Offline
Logs.

Log Server: The machine that contains the Offline Log files. SmartEvent makes a
query to this Log Server to find out which log files are available.

Log File - A list of available log files found on the selected Log Server. These log
files are processed by the SmartEvent Correlation Unit. In this window, select the
log file from which to retrieve historical information.

® Edit - Change the parameters of an Offline Log File procedure.

® Remove - Delete an Offline Log File procedure. After you start an Offline Log File
procedure you cannot remove it.

® Start - Run the Offline Log File procedure.

® Stop - Stop the Offline Log Files procedure. It does not delete the full procedure, but
stops the procedure at the specified point.
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Importing Syslog Messages

Importing Syslog Messages
Many third-party devices use the syslog format for logging. The Log Server reformats the raw
data to the Check Point log format to process third-party syslog messages.

The Log Server uses a syslog parser to convert syslog messages to the Check Point log
format.

To import syslog messages, define your own syslog parser and install it on the Log Server.

SmartEvent can take the reformatted logs and convert them into security events.

Generating a Syslog Parser and Importing syslog Messages

To import syslog messages from products and vendors that are not supported out-of-the-box,
see sk55020. This shows you how to:

1. Import some sample syslog messages to the Log Parsing Editor.
2. Define the mapping between syslog fields and the Check Point log fields.
3. Install the syslog parser on the Log Server.

After you imported the syslog messages to the Log Server, you can see them in
SmartConsole, in the Logs & Events > Logs tab.

Note - Make sure that Access Control rules allow ELA traffic between the Syslog computer and
the Log Server.

Configuring SmartEvent to Read Imported Syslog Messages

After you imported the syslog messages to the Log Server, you can forward them to
SmartEvent Server (and other OPSEC LEA clients), as other Check Point logs. SmartEvent
converts the syslog messages into security events.

To configure the SmartEvent Server to read logs from this Log Server:
1. Configure SmartEvent to read logs from the Log Server.

2. In SmartEvent or in the SmartConsole event views, make a query to filter by the Product
Name field. This field uniquely identifies the events that are created from the syslog
messages.
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Connecting an R82 SmartEvent to an R82 Security Management Server

Connecting an R82 SmartEvent to an R82
Security Management Server

This procedure explains how to configure a dedicated server for these components:

® SmartEvent Server and SmartEvent Correlation Unit

Note - For information on how to install a dedicated SmartEvent Server, see the R82
Installation and Upgrade Guide.

To connect an R82 SmartEvent Server and SmartEvent Correlation Unit to an R82
Security Management Server:

1.

6.
7.
8.

In SmartConsole, create a new Check Point Host object for the dedicated SmartEvent
Server.

In the Version field, select R82.
Create the SIC trust with the dedicated SmartEvent Server.
On the Management tab, enable these Software Blades:
® | ogging & Status
® SmartEvent Server
® SmartEvent Correlation Unit
On a dedicated SmartEvent Server that is not a Log Server (recommended):
In the Logs page, make sure that Enable Log Indexing is not selected.

This ensures that Firewall connections (which are not relevant for views and reports) are
not indexed.

Click OK.
Publish the SmartConsole session.

Click Menu > Install Database > select all objects > click Install.

Note - For Security Gateways R77.30 and lower: activate the Firewall session for the network
activity report. See "Exporting Views and Reports" on page 65.

Advanced Configuration for a dedicated SmartEvent Server that is also a Correlation Unit

1.

Open the SmartEvent GUI:
a. In SmartConsole > Logs & Events, click + to open a catalog (new tab).

b. Click SmartEvent Settings & Policy.
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Connecting an R82 SmartEvent to an R82 Security Management Server

. In Policy tab > Correlation Units, define a Correlation Unit object.

. Select the production Log Servers and local Log Server on the SmartEvent Server to
read logs from.

. In Policy tab > Internal Network, define the internal Network.

. Click Save.

. Install the Event Policy on the Correlation Unit:

SmartEvent menu > Actions > Install Event Policy.
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Views and Reports

You can create rich and customizable views and reports for log and event monitoring.

The views present queries in a graphical way which can be used for analytical and
presentation purposes.

Use these:

® SmartConsole > From the left navigation panel, click Logs & Events > Logs.

= SmartView Web Application - for generating and editing views in a browser:

https://<Server IP Address>/smartview/

Where <Server IP Address> isthe IP address of the Security Management Server
or SmartEvent Server.
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Enabling Views and Reports

To enable SmartEvent views and reports, you must install and configure a SmartEvent Server.
See "Deploying SmartEvent" on page 35.
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Catalog of Views and Reports

In the Logs & Events view, click the (+) tab to open a catalog of all views and reports,
predefined and customized. Click a view or report to open it. You can create a new view or
report, or export them to PDF. To see other actions, open the Actions menu.

# 407VB =

Item Description

1 Open Log View - See and search through the logs from all Log Servers. In
SmartConsole only, you can also search the logs from a specific Log Server.
Open Audit Logs View - See and search records of actions done by
SmartConsole administrators.

These views come from the Log Servers. All other Views/Reports (except the
Compliance View) come from the SmartEvent Server.

2 Views -The list of predefined and customized views. A view is an interactive
dashboard made up of widgets. The view tells administrators and other
stakeholders about security and network events. Each widget is the output of a
query. Widgets can show the information as a chart, table, or some other format.
To find out more about the events, double-click a widget to drill down to a more
specific view or raw log files.

Compliance View -Optimize your security settings and ensure compliance with
regulatory requirements.
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Item Description

3

Reports -The list of predefined and customized reports. A report consists of
multiple views. There are several predefined reports, and you can create new
reports. A report gives more details because it consists of multiple views. Reports
can be customized, filtered, generated and scheduled. You cannot drill down into
a report.

Favorites - Use this view to collect the views and reports you use the most.
Recent - Shows the most recently opened report or view.

Switch to Table View or Thumbnails View -The Table view is the default for
Views and Reports. The Thumbnails view is the default for the Favorites ,
Recent, and Logs.

Scheduled Tasks - See and edit scheduled tasks.
Archive - Download the exported views and reports.

Catalog (New Tab) - Open a Catalog (new tab) and select Log View, Audit View,
Views, or Reports. In the Logs & Events view, click the (+) tab to open a catalog of
all views and reports, predefined and customized. To open a view, double-click
the view or select the applicable view and click Open from the action bar.
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Views

Views shows an interactive dashboard made up of widgets. Each widget is the output of a
query. A Widget pane can show information in different formats, for example, a chart or a
table.

SmartView and SmartEvent come with several predefined views. You can create new views
that match your needs, or you can customize an existing view.

€ General Overview (: ) = Options

Statistics \ Edit
T Copy

& 50 Sateyays and servers D 14 DEsieaiesens @ 48 freindee W 69 [fecedr >

[sfoware Blades Attack Prevention by Policy Critical Attacks Allowed by Policy T View Filter
Blade Logs - Detect @ Frevens

s ] ( )
284K

Il syslog

1]
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®
o

20K adTe Crica © antiviru

hreat Emulation 227 - L

— Crtica © Antivirus

Timelines Allowed High Risk Applications

ecurity Incicents (by Logs High

Item Description

1 Widget - The output of a query. A Widget can show information in different
formats, for example, a chart or a table. To find out more about the events, you
can double-click most widgets to drill down to a more specific view or raw log files.

2 Options - Customize the view, restore defaults, Hide Identities, copy the view,
export the view.
3 Query search bar - Define custom queries using the GUI tools, or manually

entering query criteria. Shows the query definition for the most recent query. Click
Query Syntax to open the online Help for more information.

4 Time Period - Specify the time periods for the view.
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Reports

A report consists of multiple views and a cover page. There are several predefined reports,
and you can create new reports. A report gives more details than a view. Reports can be
customized, filtered, generated and scheduled. You cannot drill down into a report.

Note - For Security Gateways R77.30 and lower, the ability to generate reports on Firewall and
VPN activity is integrated into SmartConsole. To enable this functionality, activate the Firewall
session event on the SmartEvent Policy tab. Select and enable Consolidated Sessions >
Firewall Session. For more information, see "Connecting an R82 SmartEvent to an R82
Security Management Server" on page 53.
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Automatic View and Report Updates

SmartEvent automatically downloads new predefined views and reports, and downloads
updates to existing predefined ones. To allow this, make sure the management server has
internet connectivity to the Check Point Support Center.
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Opening a View or Report

Opening a View or Report

Use the predefined graphical views and reports for the most frequently seen security issues.
You can also customize the views and reports.

To open a view or report:

—

. In SmartConsole, open the Logs & Events view.

Click the + icon to open a new catalog.

Click Views or Reports.

Select a view or a report, and click Open. You can also double click to open it.
Define the required timeframe, and filter in the search bar.

Click Enter.

o g &~ w b
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MITRE ATT&CK in SmartView

MITRE ATT&CK is a new methodology to investigate security incidents. To use this feature,
you must enable SmartEvent and one of these blades: Threat Emulation, IPS or Anti-Bot.

In SmartView, you can use the MITRE ATT&CK view to:

® Quickly locate the tactics (malicious files) and techniques the attackers use against your
network.

® Use a heat map to locate the top techniques, drill down to understand where damage
occurred from malicious files, and follow the MITRE ATT&CK mitigation
recommendations.

® Extract immediate action items based on the mitigation flow

To access the MITRE ATT&CK view:
1. Open a new catalog in Views and select the MITRE ATT&CK view.

A heat map table opens. The darker the color, the higher the number of attack attempts.

€ Mitre Attack = options
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2. Double click on a technique that is the darkest shade of red. You can now drill down
further.

3. Review the different malicious emails/file downloads and click one of the logs.
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Inside the log, you can review the entire list of MITRE ATT&CK tactics and techniques
used by the attacker for the specific attack.

When locating the technique (for example, Service Execution under Execution) go to
https://attack.mitre.org/
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MITRE ATT&CK in SmartView

Exporting Views and Reports

The Export to PDF and Export to CSV options save the current view or report as a PDF or
CSV file, based on the defined filters and time frame.

To see your exported views and reports:

1. Add a new tab. Click +.

2.

Go to Tasks > Archive.

Generating a Network Activity Report

Note - When you export a view or report to CSV, only tables are exported. You can download a
zip folder which contains a separate CSV file for each table.

To export a view or report to PDF or CSV:

1.

In SmartConsole, open the Logs & Events view.

. Click the + tab to open a new tab.
. Click Views or Reports.

2
3
4.
5

Select a view or report.

. Click Export to PDF.Optionally:

® Configure the Period and filter.

® To automatically send by email to specified recipients each time the view or report
runs, configure the Send by email settings.See "Configuring Email Settings for
Views and Reports"” on page 75.

Alternatively, click Open and from inside the view or report click Options > Export to
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PDF or Export to CSV.
= Options

*, Edit
W Copy
+) Restore Defaults
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The Network Activity report shows important Firewall connections. For example, top sources,
destinations, and services. To create this report, SmartEvent must first index the Firewall logs.
Indexing is on by default in R80 and higher, in all environments except for Standalone.

To enable the Network Activity Report for Security Gateways R80.10 and higher:

In SmartConsole, in the Access Control Policy rule, add per Session to the Track settings.
See "Tracking Options" on page 113.

To enable the Network Activity Report for Security Gateways R77.30 and lower:

—

. In SmartConsole, open the Logs & Events view.
Click the (+) to open a new tab.
In the External Apps section, click SmartEvent Settings & Policy link.

In the SmartEvent GUI client > Policy tab, select and expand Consolidated Sessions.

a & b

Select Firewall Session.

Note - This configuration increases the number of events per day by about five times. To
avoid a performance impact, make sure the hardware can handle the load.

Sharing Reports

You can share a report you created with your team, without export or import. If a regular admin
shares a view or report, it is shared with all the admins on the domain. A super admin for the
Multi-Domain Server can share with all users under all domains.

To share a report:
1. In SmartConsole, open Logs & Events and click + to open a new tab.

2. Click Reports and select a report.
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MITRE ATT&CK in SmartView

3. Click Actions and select Share.

@ Open % New.. _,,E Export to PDF | = Actions «

Favorites = Name Category G* Export Template -
¥ Import Template
* =B pccess Control Access Contral — l
B schedule PDF
W Active Users Access Control
B schedule Excel
2% Application Categories Access Control
4t Share
=% Applications and Sites Access Contral - @
b Clone
* M Audit Overview General M Copy
I Cloud Cyber Data General B ycte
B Content Awareness General % Rename
‘@ Cyber Attack View - Endpoint Threat Prevention ¥ Delete
© Cyber Attack View - Gateway Threat Prevention

4. Click Yes to approve sharing the report.
The report is now marked as shared.

The report owner can undo the action and unshare the report.

To unshare the report:

Click Actions and select Unshare.

© Open  # New... ~ _,,E Export to PDF | = Actions ~

Favorites ~ Name Category &* Export Template Created by C

A, Import Template

* B rccess Control Access Control Check Point
B schedule PDF
=B Active Users Access Control Check Point
B schedule Excel
. Application Categories Access Control Check Point
42 Unshare
=% Applications and Sites Access Control - Check Point
i_,,i Clone
* I sudit Overview General i Copy Check Point
I Cloud Cyber Data General Bacta EE] D
M Content Awareness General %, Rename Check Point
@ Cyber Attack View - Endpaint Threat Prevention W Delete Check Point
B Cyber Attack View - Gateway Threat Prevention Check Point

Note - A Super User can take ownership of reports or views created by other administrators via
the take ownership feature.

Permissions when an owner shares a view/report:
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Visible on Catalog Can Edit Canclone Can Delete

Owner + + + +

Super User + - + -
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Exporting and Importing Templates

You can export the view or report layout and widget definitions to a file. This is called a
template. You can import the template from another server or from another administrator.

To export the view or report layout and widget definitions to a file, use the Export Template
option

To download exported templates, click the link in the notification message. To view historical
reports, views, and templates, go to Tasks > Archive.

To import the file from another server or from another administrator, use the Import Template
option in the Catalog (new tab).

@ Open 4 New. - _,EExp:-'t'_-: PDF | = Actions
&+ Export Template
_Llrr::u". Template

_.ES:“E::IUI-E FOF

Cip Fywr
_,ﬁ_h edule Excel

%, Rename

Delete
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Scheduling a View or Report

Scheduling a View or Report

To schedule a view or report, you need to define and edit it in SmartConsole.

To schedule a report:

—

. In SmartConsole, open the Logs & Events view.
Click the + tab to open a new tab.

Click Views or Reports.

Select a view or a report.

Select Actions > Schedule PDF or Schedule CSV.

a & b

The Schedule page of the Export settings window opens.
6. Define the recurrence pattern.
7. Define the Period and Filter.

8. Optional: Configure email settings to get the scheduled view or report automatically.
Click Send by email.

To edit your scheduled views and reports:
1. In SmartConsole, open the Logs & Events view.
2. Click the + tab to open a new tab.

3. Select Tasks > Scheduled.
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Customizing a View or Report

To customize a view or report:
1. Select a view or a report and click Open.

2. Click Options > Edit.

= Optiens = = Optiens =
*, Edit *, Edit
+)Restore Defaults +)Restore Defaults
M Copy Report M Copy View
2 Hide Identities [EE Hide Identities
_,ﬁE'-:p-:*t to Exce _,ﬁE'-:p-:*t to Exce
_,EE'-:p-:*L o POF _,ﬁE'-:p-:*t o POF

¢s* Export Template ¢* Export Template |
Y, Report Filter . Wiew Filter

¥ Report Settings Ik View Settings

3. Inareport, you can edit the report or the current view in the report.

® To add or remove, click the relevant icon in the edit toolbar (becomes available
when in edit mode):

=+ 4dd Page X Remowve Page
® To add a widget or arrange the "Widgets" on page 77 in the view, use Drag & Drop
or expand..
B Define filters (see "Widgets"” on page 77).

Note - If you change the timeframe, the data changes according to the start and stop times.
The timeframe and search bar are not saved with the view or report definition. Define them as
needed when generating the view or report. See "Opening a View or Report” on page 62.

View Settings

Views can be configured according to these options:
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View Settings x

Name: * General Overview B v
Split table across multiple pages: C

+ When this control has no data: All

Remove the page @

¢ Show default message
Show the following message

Use view as template: @

OK Cancel

1. Enter attitle.

Customizing a View or Report

2. To show more results, this option allows a table to spread across multiple pages when

saved to PDF.

The No page limit option shows all the results for the selected table query, spread

across as many pages as required.

3. Select what you want to display when this control has no data:

® Remove the page

® Show a default or custom message.

4. Selectto use the view as a template and add filter and sort criteria.

Use the view as a basis for generating duplicate views with more granularity.

Use Case:

The Active Users predefined view shows all active users. You want to see a more granular

vView per user:

1. Open the Active Users view and click Options > View settings.

The View Settings window opens.
2. Select Use View as template.

3. ForFilter each view by, select User.
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Select Number of values. For example, 5.
Click OK.
Go to Options > Export > Export to PDF.

© N o g &

Click Download.

The report shows all widgets in the view filtered according to each user.

Copying Views to Other Reports

To copy a view to another report:
1. Right-click the required view.
2. The copy option shows with the name of the view:

€ Application and URL Filtering

High Bandwidth Applications

The view is exported. Wait until a message shows the view was successfully exported.

Top Applications / Sites By Traffic

High Risk Users

High Bandwidth Applications sicncom skamaihdnet Sloomiars gt com Sooge Sewrch

High Bandwidth Categories

ME 13
1.9MB 2
14ME 1

I | [ | [T 1
=" Copy: "High Bandwidih A l

High Bandwidth Users

3. Select Copy: [view name]
4. Go to the report in which you want to past the view.

5. Go to Options and select Edit:
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Customizing a View or Report

Edit Mode =+ Add Page X Remove Page + Add Widget - Undo Redo €) Discard @ Done = Options v
Best Practices with Medium status L bt
TR Copy »
e ——=
D Best Practice Blade Security Best Practice Recommendation Relevant Object ) Restore Defaults
VPN133 IPSec VPN Check the Endpoint Connect 'Re-authenticat..  The 'Re-authenticate user' settings for Endpoint Con jefined in the Global Properties u.. @B Hide Identities
VPN125 IPSec VPN Check that Secure Configuration Verification. Secure Configuration Verification in the Global Properties in the Remote Ac settings must.
- &* Export >
URL139 URL Filtering Check that Uncategorized Sites are being bl.. The URL Filtering blade should have a policy that blo kind of block) uncateg d sit... Branch_Office_Policy, .
Y, Report Filter
Corporate_Policy
Poor Security Y ViewFiter
URL136 URL Filtering Check the W Categorization Mode in t. The Website Categorization Mode in the Engine Settings of the URL Filtering blade should be.
Report Setting
URLI2 URL Filtering Check that sites categorized as P2P File Shar...  The URL Filtering blade should have a policy that blocks sites categorized as P2P Fie Sharing....  Branch Office Policy, . 4 Report Settings
O Corporate. Policy £ View Settings
TP103 Threat Prevention Check the "Low Confidence’ setting in Threa... The "Low Confidence’ setting in the 'Activation Mode' must be set to 'Prevent’, 'Ask’ or 'Detec... Optimized Medium
Strict
TENS Threat Emulation Check the fre ey of scheduled updates The Threat Emulation engine should be updated at least every two hours.
TE109 Threat Emulation Check the Emulation Connection Handling ... The Emulation Connection Handling Mode should be set to ‘Hold'. If ‘Custom’ is selected, bot {;’m zed Medium
Medium Security Strict Medium
1PS131 Ps Check the IPS Protection: DNS - General Set..  The IPS Protection: Sequence Verifier must have its 'Monitor DNS connections over’ setting Default Inspection Medium
e —— 1pS113 1PS Check that each Gateway performs IPS insp..  Each Gateway should have the Protection Scope in the IPS blade set to perform IPS inspectio...  Corporate-GW (198.51.100...  Medium
EuropeBranchGw (192.0.2.... Medium
HQgw (192.0.2.200) Medium
Remote-1-gw (192.0.22.1)
Remote-2-gw (192.0.23.1)
Good Security Remot: 192.0.25.1)
RemoteBranchGw (198.51....
- FW164 Firewall Check that HTTPS Inspection is enabled on ... HTTPS Inspection should be enabled at at lzast one of the fi ing blades... BranchOffice (188.51.100.7)
N
Corporate-GW (198.51.100... Secure
EuropeBranchGw (192.0.2.... Secure
HQgw (192.0.2.200) Secure
Remote-1-gw (192.0.22.1) Paor
Remote-2-gw (192.0.23.1) Poor -
Secure Security
7. From the Paste drop-down menu, select the view you want to paste:
Edit Mode Remove Page €3 Discard @ Done = Options
P iF — L Check Point
i H SEHTAE TECHIOLOBES LT
General Activity
Copy: "General Activity” D
e — I

High Risk Applications
Report

8. Click Done.

Note - When you copy a view to another report, the copied view does not include the
filter of the original report, only the filter of the copied view.

Report Settings

Reports can be configured according to these options:
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Customizing a View or Report

Report Settings x

MNarne: Application and URL Filtering T.
Theme: Default -
Description:
OK Cance

Configuring Email Settings for Views and Reports

You can automatically send views and reports by email to specified recipients each time the
view or report runs.

Configuring Email Server Settings

Mail server settings in SmartConsole and SmartView are shared for all email interactions. For
each SmartConsole administrator, configure them one time.

To configure email server settings:

1.

Select a view or a report in the catalog.

2. Click Export to PDF, or Actions > Schedule PDF or Actions > Schedule CSV.
3.
4

Click Send by email.

. In the Email Server section, click Edit.

Note - In SmartView, you can edit the mail server on the user preferences menu.
Configure the email server options:

® Sender email address. This shows on all report emails.

® Qutgoing mail server (SMTP)

® Port - The default port is 25.

® Use authentication (Optional) - if required by the email server, configure a
Username and Password.
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Customizing a View or Report

®= Connection encryption (Optional) - if required by the email server, choose SSL or
TLS.

6. Click OK.
Configuring Email Recipients

Define the email recipients every time you run the view or report, or one time for scheduled
reports.
To configure email recipients:

1. Select a view or a report from the catalog.

2. Click Export to PDF, or Actions > Schedule PDF or Actions > Schedule CSV.
3. Click Send by email.
4

. In the Email recipients section, click + to enter an email address. You can add multiple
addresses.

5. Click OK.

Adding a Logo to Reports

You can configure reports to show your company logo on report cover pages instead of the
Check Point logo.

To add a logo to your reports:

1. Save your logo image as a PNG file with the name: cover-company-logo.png

2. Copy the image tothe SRTDIR/smartview/conf/ directory on the SmartEvent
Server.Note - This applies when there is local SmartEvent on the Management Server.
Otherwise, you must add the logo image to every machine the users connect to or the
logo only displays when connected to the SmartEvent IP.

Note - The bestimage dimensions are 152 pixels wide by 94 pixels high.
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Widgets
You can customize the widgets to optimize the visual display. To customize widgets, switch to
edit mode. Click Options > Edit. You can copy a widget and use it in another view.

® To save changes, click Done.

® To cancel changes, click Discard.

® To restore the predefined view to the default values, click Options > Restore Defaults.

Note - Restore Defaults option is only available after you modify a predefined view.

Adding and Customizing Widgets

To add a Widget:
1. Double-click a view or report to open it.
2. Click Options > Edit.
3. Click Add Widget and select the widget type.

Chart Settings:
Chart Settings x
zeneral Title: * Attack Prevention by Policy T.
Customize
Description:
Chart Type: il = (€@ 4
Category (X):* Action ~

Limit Categories: | 10

Value (¥): Protection Mame (Count) -
Order values by: | Protection Name (Count) T | Descending -
OK Cance
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c o

a o

Widgets

Enter a title.

Select a chart type: vertical bar, horizontal bar, pie, area or line.

Select a data category for the X axis.

Define how the Top Values are calculated (by number of logs, or by traffic).
Set a limit for how many top values to show.

Optional: click Series - Split the results into colored groups with different values for
the series.

Chart Settings

General Series: |ﬂppicatinn Risk ~ |

Seri i
e Ordered by: |App ication Risk e | |Descen::| ng

Customize

| | Cancel

Optional: click Customize and define axis titles and legend position.

Chart Settings x

General Axis titles:
| Customize |
v s Logs
x
¥ Legend: Top ©
Data labels: Percentages T

Ok Cance
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Timeline Settings:

Timeline Settings x

zeneral Title: *

Customize )
Description:
Chart Type:
Walue (Y):
Stacked by:

c o

o

Order stacked by:

Samples:

Enter a title.

Widgets

Activity Timeline

ll| O M A

Logs -

Action -

Action T | Descending -
30 -

OK Cance

Select a timeline graphical presentation: vertical bar, doughnut, area or line.

Select the data to count.

Y

Advanced - split the results into colored groups, with different values for the Series.

Define the time-granularity. Enter the number of bars or doughnuts to show.
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Table Settings:

Table Settings x

Title: Top Blocked Applications / Sites T.
Description:

Type: tatistical Table M

+- N X v

Application Name Results

Application Risk A~
P Number of values (up to): 50
Application Category

User
Logs Sort values by: Application Risk T  Descending -
+ Add summary row
Show results with empty values
Column Properties
Celumn width: 7 S (31 %)
Custom header name:
Caption for single value:

Caption for multiple values:

OK Cance

a. Enteratitle.
b. Manage columns: add, edit, remove, and change the order.
c. Select a column on the left and define its settings:

® Enter the number of top values to show.

® Select how values are sorted.

d. Select this option to group results with the same value in one row.
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Map Settings:

Widgets

Map Settings x

Title: *

Description:

Display top:

WValue:

Ordered by:

Split by:

Top Source Countries T

10 =

-

* Source Countries
Destination Countries
Source and Destination Countries

Logs M
Logs T | Descending v
MNone M

Ok Cance

a. Enter atitle.

b. Enter the number of Top Countries to mark.

c. Selectto mark Top Source Countries, Top Destination Countries, or both.

d. Define how to find the Top Countries (for example, by number of logs or by traffic).

The infographic widget shows large meaningful values. For example:

26 Gateways and Servers @ "|3 High Risk Attacks @j 21 Prevented Attacks - 6 Infected Hosts
Reported these event Distingt awacks not prevented due 1o policy Distinct aack type: = With bot
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Infographic Settings:
Infographic Settings x
Title: * Total Traffic
Field Name: Traffic Total Bytes -
Aggregate values by: Sum -
Filter: T
lcon: traffic -
Primary Text: Total Traffic

Secondary Text:

Template: Infographics Template 1 v
Horizontal Alignment: Left -
Vertical Alignment: Top -
Style: MNormal v
OK Cance

a. Enter atitle

b. Select a field to count. Selecting None means all the logs that match the filter
criteria are counted.

c. Define filter criteria.
This criteria is in addition to the inherited filters for the report and view layers.

For more, see "Filters"” on page 88.
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Widgets

d. Optional: Enter an icon name in the field.

Select a name from the list below. Pay attention to upper and lower case letters
and the use of hyphens.

Icon Used for

apps
attacks
hosts
gateway
traffic
usercheck
users

new Audit Logs
add Audit Logs
remove Audit logs
modify Audit logs
install-policy
publish

ips

anti-bot
anti-virus

threat-emulation

e. Enter primary text that describes the value counted.
f. Optional: For secondary text, enter a more detailed description.

Use a container to unify multiple widgets into one frame. Add a container, then add, edit,
or remove the widgets inside it.

Note - The container widget cannot be added to a container.
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Container Settings:

Container Settings x

Title: Statistics T
Description:
Layout: Horizontal “

OK Cance

a. Enteratitle.
b. Optional: filter at the container level. The filter applies to all internal widgets.
c. Select the widget order inside the container: Horizontal, Vertical, Grid or Tabs.

After the container is added to the view, you can configure it further.

= —

1 00

100

Allowed X Remove ~ +aAdd~ T £+~ X
Top Sources Top Destinations
1032.211.11 |_ 192.168.32.255
10.143.241.28 labs-proxy-old.c...
10126217103 10.149.68.195
10.158.74.109 - 152.168.13.78
10132582 + 10.135.105.584
192.16832.65 - 10.0.100.3
192.168.32.109 0.0.2.35
19216832225 - 255255255 255
1921684116 - 10.7.210.4
192.168.32.69 [- 192.168.32.211

a. Remove the widget from the container.
b. Add a new widget.

c. Edit the settings for the container, or edit one of the widgets in the list.
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Widgets

Rich Text Settings x

Format - Sze - B I U|A-W. 8 ==

H

= |w 4 P Source

OK Cance

Use this window to add textual explanations to the View text box.

. Click OK.

. Select filters for the widget in addition to the inherited filters from the report and view
layers. See "Filters" on page 88.

. Configure settings for the widget.
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To customize a widget:

1. In the view where the widget is located, click Options > Edit.

€ Access Control

Activity Timeline

@rsiect @Prevent @inform User @Drop () Detect @Block MAskUser @allow @ Accept
. 10K
g
5K
T ' r
Thu1s Fril6 sat 17 sun 1 mon 19 Tue2 wieg 21
Allowed Blocked
Top Sources Top Destinations Top Sources Top Destinations
103221101 192,168.32.255 205-DroRy -Gl
broacbandz. abs-prowy-ol.
222010559 192,166,13.78
1014324128 10.149,68.15
10126217.103
1921663268
192,168.32.225
1045674109
192.168.32.100
10132582
0 200
Top Services Top Applications Top Users
nite web growsing | I Mary Jane
https Google Search Linda H
nbaatagram Google sevi Edoy Roe | contentyieia
nbrame frefox.com [l Joe Roberts |
HTTPS proxy Goagle Chro. Mancy Jacksen
domain-udp 20957211124 || Jay Gariepy |
TCpy4898 Googie ags Joe Micnel |
unknown_pr.. Microsoft Ser.. I Karie Blaker —
10zp_udp amazon-adsy.. | Lous Kenley —
HTTR_proxy Facebook | Mark Decker | Linkedin
0 500 ] 100 c = ax

Top Users by Traffic

Widgets

A\ Edit
M Copy

O

#) Restore Defaults

[I& Hide Identities
&> Export >

Y. View Filter

£ View Settings
T — C

W kitcode.net & 8 more 28.1MB
e Facebook 267MB
Edward Banks (unauthent... T Web Browsing & 121 more 263MB
Marion White Google Search 69MB
John Lopez LogMeln rescue 6.8MB
James Phillips newmail.aol.com 37MB
Lisa Moore Google Search 23M8
Ronald Edwards 212.235.1530 11MB
Kimberty Williams cdnstumble-upon.com 9523K8
g ns T 198.51.100.202 & 7 more 710.7K8
Marion Hager Chartbest 655.468
. Steven Nelson T server.talkahead com/scripts, widgets..  653.3KB
simone martin T Google Services, firefox.com 555.2KB
Elizabeth Miller feeds.delicious.com 171.08
paul johnson 37K8
Alfred Rogers o8
Eddy Roe 02
Femanda Perez [+
James White 08
Jason Taylor adtpix.com o8
1 v Garianue [ farats nat Litcnda nat nr M

2. Go to the required widget and click the wheel icon to edit the image properties:.

Attack Prevention by Policy

. Y.X

Detect @ Prevent

Chart Settings
[18%] —~, General Title:*
Customize o
Description:
Chart Type:

Category (X): *

- [s2%)
Value (Y):

Order Values by:

115

3. Edit the required properties.

Critical Attacks Allowed by Policy

Attack Prevention by Policy

h o= (€ d A

Action

Protection Name (Count)

Protection Mame (Count)

T.

i
T | | Descending = A
OK Cancel
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4. Click Done.

© | Q O last7Days - Fnrer search query (Ctri+F) e

=+ Add Widget € Discard | @ Done = Options

X Remove~ +Add~ T - X

= 21 Gateways and Servers '] Published Sessions @ 29 Critical Attack Types - 32 Infected Hosts
Reported thet cvers D Aopid by admisators Not preented o polcy - win bos
Y, & X  Attack Prevention by Policy @ Y, it X| Critical Attacks Allowed by Policy Yof X
[ - Detect @ Prever Attack Severity ~ Blade Logs
39.9€ e not-a loaderWin32.AdLoad.T.ef — Critical © Anti-Virus 4
31.5€ not-a-virusiWebToolbarWin32.Cr m— Critical © Anti-Virus H
94K i ows RASMAN Service Memory C. m— Critical € s
23K m— Critical @ Anti-Bot
869 m— Critical B3 Threst Emulation 1
369 [82%] — Critical QA 1
22 — i '
X Remove v +Addv Y, §v X  Allowed High Risk Applications ER
High
,,,,,,,,, '©) r)n,.@
PixD4.re
Unkr
o1z
Fr A 9 Tue 3 Le

Copying Widgets to other Locations

You can copy a widget used in one view or report and paste it in another view or report.

To copy a widget to another location:
1. Right-click the required widget.
2. The copy option shows with the name of the widget:
Attack Prevention by Policy

Copy: "Attack Prevention ...

Detect Prevent

- [82%]

3. Select Copy: [widget name].

4. Go to the view or report in which you want to paste the widget.
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5. Go to Options and select Edit:

€ Access Control

Activity Timeline

@Reject @Prevent @ inform User @ Drop

Detect  @Block

Ask User

Accept

E 10K
5K
T
Thu 15
Allowed

Top Sources

10.15674.108
192,168.32.108

10132582

Top Services

nto
https
nbdatagram
nbrame
HTTPS prowy
domain-udp
TCPr4g99
unknown_pr..
1dap_udp
HTTR_proxy

Top Destinations

Top Applicatians

Web Browsing
Google Searcn
Google Sevi..

firefoxcom
Goagle Chro..
20987211144

amazen-adsy.
Facebook.

I
(]

n

1

1

I
00

Blocked

Top Sources

Top Users

Mary Jane
Linds Hi
Eday Roe

Joe Roberts
Nangy Jacksen
Jay Gariepy
Jog Micnaz
Karie Blaker
Louis Kenley
Mark Decker

Wed 21 Thu22

Top Destinations

19851100202
Blocked URLs

Facebook
Facebook So.
Linkedin

6. Right-click an empty space in the view or report.

Widgets

[= optons |

\ Edit i

Copy

4D Restore Defaults

[E8 Hide Identities

&* Export >

Top Users by Traffic Y, View Fiter

= [r—— £ View Settings -
Joe Roberts W kitcodenet & 8 more 281MB

Aciana Hall Facebook 267MB
Edward Banks (unauthent... T Web B & 121 more 26308
Marion White Google Search 69MB

John Lopez LogMeln rescue 6.8MB

James Phillips newmail.aol.com 37MB

Lisa Moore Google Search 23M8

Ronald Edwards 212.235.15.30 1IMB
Kimberty Williams cdn.stumble-upon.com 9523KB

grace collins T 198.51.100.202 & 7 more 710.7KB
Marion Hager Chartbest 655.468
Steven Nelson T server.talkahead com/scripts, widgets...  653.3KB
simone martin W Google Services, firefox.com 555.2KB
Elizabeth Miller feeds.delicious.com 171.0k8

paul johnson 37K8

Alfred Rogers 08

Eddy Roe 08

Femando Perez 08

James White 08

Jason Taylor adtpix.com o8

[ [ forats nat Litcoda nat Nz M

From the Paste drop-down menu, select the widget you want to paste:

Edit Mode

bandwidth

Medium Low

16MB
14MB
12MB
10ME
8MB
GMB
4MB

2MB

@ very Low

Unknown

=+ Add Widget -

I (-

4 Undo

B
Tue 23

T
Wed 24

7. Click Done.

T
Thu 25

T
Fri26

T
1:00 AM

T
1:00 Al

; N
1:00 AM 1:00 AM

Redo €3 Discard @ Done

Copy: "network traffic uyse” l

I Pﬁ‘ste bI A Software Blades (Less tha...

J

Wl Attack Prevention by Polic...
[ Traffic (20 hours ago)
A Top Users by Traffic (21 h...
[ Traffic (21 hours ago)

Note - When you copy a widget to another view or report, the copied widget does not
include the filter of the original view or report, only the filter defined for the copied

widget.

Filters

The search bar is used to apply on-demand filters, but you can also save filters with the view /

report definition.
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Edit Mode

+ AddPage X Remove Page =+ Add Widget ~ edo € Discard @ Done

Top Applications =. Y. X  TopCategories = Y X TopUsers

APPLICATION and URL FILTERING

" James Philip
i vzanih . —
10 0 10 0 0
General Ativity
Activity Timeline e T X
—_—— I @ Appication Contro URLFittering @ Content Awareness
: EY
High Risk Applications
0
I
T
Thu'y 12:00 P Frito 12:00 P sat11 1200 P Sun 12 1200PM Mon 13 1200PM Tue 14 1200PM Wed 15 1200PM Thu 16 12:00 1

There are different layers of filters:

1. Filters to apply to the full report.

2. Filters to apply to a view (specified page in a report) and all widgets that this page

includes.

3. Filters to apply to the selected widget.

To edit the view filter:

Edit View Filter x
Blade T | Equals v

Application Control,Mobile Ap...~ =+ X
Hide Inherited Filter

Report (Application and URL Filtering) Filter

Pre-defined Filter Default Report Filter

Elade Equals Application Control, URL Filtering

Use comma to filter for multiple values OK Cance

1. Click the + (plus) button to add a filter.
To delete afilter, click the X button.
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Select a field.
To enable free text search, select Custom Filter.
Select a comparison method.

Select or enter the value.
You can define multiple values.

Filtering for Active Directory User Groups

You can filter logs, reports, and views for one or more Active Directory groups.

1.

In your Access Control Policy, create an Access Role that includes all the Active
Directory groups you want to have in the query.

Install the Access Control Policy on the Security Gateways.

Look at the Identity Awareness login logs, and copy the names of the relevant groups.
They usually have the prefix "ad_".

Add a filter for the field User Group and type or paste the name of the group that you
want to include in the filter. For multiple groups, use a comma-separated list.
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SmartConsole lets you transform log data into security intelligence. Search results are fast and
immediately show the log records you need. The Security Gateways send logs to the Log
Servers on the Security Management Server or on a dedicated server. Logs show on the
SmartConsole Logs & Events view > Logs tab. You can:

® Quickly search through logs with simple Google-like searches.

® Select from many predefined search queries to find the applicable logs.
® Create your own queries using a powerful query language.

® Monitor logs from administrator activity and connections in real-time.

For more information, see "Working with Logs" on page 95.
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Sample Log Analysis

This is a sample procedure that shows how to do an analysis of a log of a dropped connection.

To show a log of a dropped connection:

—

. Log into SmartConsole.

Connect to the IP address of the Security Management Server, not to a Log Server.

In the Security Policies > Access Control > Policy view, select a rule with the Drop
action.

In the bottom pane, click Logs.
This shows the logs for connections that were dropped by the specific rule.
Double-click a log.

The Log Details window opens.

R82 Logging and Monitoring Administration Guide | 92



The Logs View

The Logs View

J Queries | £ Q| G | Q O Last24 Hours * [t

Showing first 50 results (251 ms) out of at least 126,284 results

[T
=]
B

Source User... i Description Tops ©

Today, 18:16:13 t @cw 10.13.88.2 1013.192 CPD_amon (TCP/18192) 2 Cleanup rule New-Se... CPD_amon Traffic Accepted from 10.13.88.2 to 10.13.19.2

Today, 18:16:13 3 @cw 10.13.19.254 amir (amir) 21194.29.3643  HTTPS_proxy (TCP/80... New-Se... HTTPS_proxy Traffic Dropped from amir (amir)(10.13.19.254) to 194... » Top Sources

Today, 18:16:13 3+ @cw 10.13.1045 1013104255 nbname (UDP/137) New-Se... nbname Traffic Dropped from 10.13.104.5 to 10.13.104.255 » Top Destinations

Today, 18:16:13 3 @ew 10.13.19.254 amir (amir) 1194293643  HTTPS_proxy (TCP/80... New-Se... HTTPS_proxy Traffic Dropped from amir (amir)(10.13.19.254) to 194.... | > Top Services
LOGS & Today, 18:16:13 3 ®cw 10.13.19.254 amir (amir) 231194293643 HTTPS_proxy (TCP/80... New-Se... HTTPS_proxy Traffic Dropped from amir (amir)(10.13.19.254) to 194.... * Top Actions
MONITOR - TR e 3 @cw 10.13.1045 1013104255 nbname (UDP/137) New-Se... nbname Traffic Dropped from 10.13.104.5 to 10.13.104.255 > Top Blades

Today, 18:16:13 3 @ow 10.13.88.1 1013.19.1 CPD_amon (TCP/18192) 2 Cleanup rule New-Se... CPD_amon Traffic Accepted from 10.13.88.1 t0 10.13.19.1 > Top Origins

Today, 18:16:13 ¥+ ®@cw 10.13.1045 10.13.104.255 nbname (UDP/137) New-Se... nbname Traffic Dropped from 10.13.104.5 to 10.13.104.255 * Top Users

Today, 18:16:13 3 ®@6w 10.13.88.1 1013.19.1 CPD_amon (TCP/18192) 2 Cleanup rule New-Se... CPD_amon Traffic Accepted from 10.13.88.1 t 10.13.19.1 > Top Applications

Today, 18:16:13 3 @cw 192.168.13.88 1921681319 CPD_amon (ICP/18192) 2 Cleanup rule New-Se... CPD_amon Traffic Accepted from 192.168.13.88 to 192.168.13.19

Today, 18:16:13 3 @cw UDP/8116 (UDP/8116) New-Se... UDP/8116 Traffic Dropped

Today, 18:16:13 3 @cw 10.13.19.254 amir (amir) 192.168.13.178  http (TCP/80) New-Se... http Traffic Dropped from amir (amir)(10.13.19.254) to 192.168.13.1...

Today, 18:16:13 + @cw UDP/3116 (UDP/8116) New-Se... UDP/8116 Traffic Dropped

Today, 18:16:13 3 @cw UDP/3116 (UDP/8116) New-Se... UDP/8116 Traffic Dropped

Today, 18:16:13 i @cw UDP/8116 (UDP/3116) New-Se... UDP/8116 Traffic Dropped

Today, 18:16:13 ¥ &cw UDP/8116 (UDP/8116) New-Se... UDP/3116 Traffic Dropped

Today, 18:16:13 * ®cw UDP/8116 (UDP/8116) New-Se... UDP/8116 Traffic Dropped

Today, 18:16:13 * ®e6w 10.13.88.1 10.13.19.1 CPD_amon (TCP/18192) 2 Cleanup rule New-Se... CPD_amon Traffic Accepted from 10.13.88.1 to 10.13.19.1

Today, 18:16:13 $ @cw 192.168.13.88 1921681319 CPMI (TCP/18190) 2 Cleanup rule New-Se... CPMITraffic Accepted from 192.168.13.88 to 192.168.13.19

Today, 18:16:13 * ®cw 192.168.13.88 192.168.13.19 CPD_amon (TCP/18192) 2 Cleanup rule New-Se... CPD_amon Traffic Accepted from 192.168.13.88 to 192.168.13.19

Today, 18:16:13 3 @cw 10.13.88.1 10.13.19.1 CPD_amon (TCP/18192) 2 Cleanup rule New-Se... CPD_amon Traffic Accepted from 10.13.88.1t0 10.13.19.1

Today, 18:16:13 € 192.168.13.19

Today, 18:16:13 2 t @cw 1013.88.3 10.13.19.3 CPD_amon (TCP/18192) 2 Cleanup rule New-Se... CPD_amon Traffic Accepted from 10.13.88.3 to 10.13.19.3

Today, 18:16:13 3 @cw 192.168.13.88 1921681319 CPD_amon (TICP/18192) 2 Cleanup rule New-Se... CPD_amon Traffic Accepted from 192.168.13.88 to 192.168.13.19

Today, 18:16:13 t @cw 192.168.13.19 10.13.88.3 dest-unreach (ICMP) New-Se... dest-unreach Traffic Dropped from 192.168.13.19 to 10.13.88.3

Today, 18:16:13 €2 192.168.13.19

Today, 18:16:13 © 192.168.13.19

Description

1 Queries - Predefined and favorite search queries.
2 Time Period - Search with predefined custom time periods.

3 Query search bar - Define custom queries in this field. You can use the GUI tools
or manually enter query criteria. Shows the query definition for the most recent

query.
4 Log statistics pane - Shows top results of the most recent query.

5 Results pane - Shows log entries for the most recent query.

o Note - On a Security Management Server with the "Enable Log Indexing" option not
selected, and a dedicated Log Server with "Enable Log Indexing" option selected:
When you connect with SmartConsole to the Security Management Server, the Logs
view shows the logs of individual log files. It is not possible to get a unified view of all
the logs.
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o Notes:

® The selected "Default Time Frame" values are not synchronized between
SmartConsole and SmartView. In SmartConsole, the export time of log records
is based on the "Default time frame" that a user selected in SmartView > in the
top right corner, click the user icon > click "User Preferences".
® The "Default Time Frame" configuration is not synchronized between the
Primary / Secondary Management Server or Dedicated Log Server / Dedicated
SmartEvent Servers.
® On a Multi-Domain Security Management Server, the "Default Time Frame"
configuration is saved for each Domain for each user.
Example:
1. In SmartView "User Preferences", you selected "Last 7 Days".
2. In SmartConsole "Logs" tab, you selected "Today".
3. In SmartConsole you export the log records.
These records are exported for the last 7 days.
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Choosing Rules to Track

Logs are useful if they show the traffic patterns you are interested in. Make sure your Security
Policy tracks all necessary rules. When you track multiple rules, the log file is large and
requires more disk space and management operations.

To balance these requirements, track rules that can help you improve your cyber security, help
you understand of user behavior, and are useful in reports.

Configuring Tracking in a Policy Rule

To configure tracking in a rule:
1. Right-click in the Track column.
2. Select a tracking option.

3. Install the policy.

Tracking Options
Select these options in the Track column of a rule:
® None - Do not generate a log.

® | og -This is the default Track option. It shows all the information that the Security
Gateway used to match the connection. At a minimum, this is the Source, Destination,
Source Port, and Destination Port. If there is a match on a rule that specifies an
application, a session log shows the application name (for example, Dropbox). If there is
a match on a rule that specifies a Data Type, the session log shows information about
the files, and the contents of the files.

® Accounting - Select this to update the log at 10 minutes intervals, to show how much
data has passed in the connection: Upload bytes, Download bytes, and browse time.

Note - When upgrading from R77.X or from R80 versions to R82, there are changes to the
behavior of the options in the Track column. To learn more see sk116580.

Advanced Track options

Detailed Log and Extended Log are only available if one or more of these Blades are enabled
on the Layer: Application & URL Filtering, Content Awareness, or Mobile Access.
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Detailed Log -Equivalent to the Log option, but also shows the application that matched
the connections, even if the rule does not specify an application. Best Practice - Use for
a cleanup rule (Any/Internet/Accept) of an Applications and URL Filtering Policy Layer
that was upgraded from an R77 Application Control Rule Base.

Extended Log -Equivalent to the Detailed option, but also shows a full list of URLs and
files in the connection or the session. The URLs and files show in the lower pane of the
Logs view.

Log Generation

Alert:

per Connection - Select this to show a different log for each connection in the session.
This is the default for rules in a Layer with only Firewall enabled. These are basic
Firewall logs.

o Important - SmartEvent does not index these logs.

per Session - Select this to generate one log for all the connections in the same session
(see "Log Sessions" on page 112). This is the default for rules in a Layer with Application
& URL Filtering or Content Awareness enabled. These are basic Application Control
logs.

For each alert option, you can define a script in Menu > Global properties > Log and Alert >
Alerts.

None - Do not generate an alert.

Alert - Generate a log of type Alert and run a command, such as: Show a popup window,
send an email alert or an SNMP trap alert, or run a user-defined script as defined in the
Global Properties.

SNMP - Generate a log of type Alert and send an SNMP alert to the SNMP GUI, as
defined in the Global Properties.

Mail - Generate a log of type Alert and send an email to the administrator, as defined in
the Global Properties.

User Defined Alert - Generate a log of type Alert and send one of three possible
customized alerts. The alerts are defined by the scripts specified in the Global
Properties.

Log Sessions

A session is a user's activity at a specified site or with a specified application. The session
starts when a user connects to an application or to a site. The Security Gateway includes all
the activity that the user does in the session in one session log (in contrast to the Security
Gateway log, which shows top sources, destinations, and services).
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To search for log sessions:
In the Logs tab of the Logs & Events view, enter:

type:Session

To see details of the log session:
In the Logs tab of the Logs & Events view, select a session log.
In the bottom pane of the Logs tab, click the tabs to see details of the session log:

B Connections - Shows all the connections in the session. These show if Per connection
is selected in the Track option of the rule.

® URLs - Shows all the URLs in the session. These show if Extended Log is selected in
the Track option of the rule.

® Files - Shows all the files uploaded or downloaded in the session. These show if
Extended Log is selected in the Track option of the rule, or if a Data Type was matched
on the connection.

To see the session log for a connection that is part of a session:

1. Inthe Logs tab of the Logs & Events view, double-click on the log record of a connection
that is part of a session.

2. Inthe Log Details, click the session icon & (in the top-right corner) to search for the
session log in a new tab.

To configure the session timeout:

By default, after a session continues for three hours, the Security Gateway starts a new
session log. You can change this in SmartConsole from the Manage & Settings view, in
Blades > Application & URL Filtering > Advanced Settings > General > Connection
unification.

Viewing Rule Logs

You can search for the logs that are generated by a specific rule, from the Security Policy or
from the Logs & Events > Logs tab.

To see logs generated by a rule (from the Security Policy):
1. In SmartConsole, From the left navigation panel, click Security Policies.
2. Inthe Access Control Policy or Threat Prevention Policy, select a rule.

3. Inthe bottom pane, click one of these tabs to see:
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® | ogs - By default, shows the logs for the Current Rule. You can filter them by
Source, Destination, Blade, Action, Service, Port, Source Port, Rule (Current
rule is the default), Origin, User, or Other Fields.

® History (Access Control Policy only) - List of rule operations (Audit logs) related to
the rule in chronological order, with the information about the rule type and the
administrator that made the change.

To see logs generated by a rule (by Searching the Logs):

—

> WD

. In SmartConsole, go to the Security Policies view.

In the Access ControlPolicy or Threat Prevention Policy, select a rule.
Right-click the rule number and select Copy Rule UID.
In the Logs & Events > Logs tab, search for the logs in one of these ways:
® Paste the Rule UID into the query search bar and click Enter.
® For faster results, use this syntax in the query search bar:
layer uuid rule uuid:* <UID>
For example, paste this into the query search bar and click Enter:

layer uuid rule uuid:* 46f0ee3b-026d-45b0-b7£0-5d471£6d8ebl0

To exclude logs generated by rules in a specific a layer from the SmartConsole Logs view:

1.
2.

In SmartConsole, From the left navigation panel, click Security Policies.

Go to Access Control > Policy, right-click the Policy Layer whose logs you want to
exclude and click Edit Policy.

In the window that opens, go to the applicable layer, right-click the drop-down menu, and
select Edit Layer.

Add a downward arrow | to the layer's name. You can add the downward arrow in two
ways:

® Copy itfrom here: |
Or
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® Enter the corresponding ASCII code:
a. Press and hold the Alt key.
b. Enter the digit 2.
c. Enterthe digit 5.
d. Release the Alt key.
Example:
- Access Contrc
- |AR Policy
€., IoT Protect

€ excluded_layer!

o Notes:

® The excluded layers are not displayed in the Logs view when the action is not
blocked or dropped.

® When a Layer is excluded, the Logs tab shows logs from rules in the next Layer
below the excluded Layer.

® |f all the Layers in a policy are excluded, the Logs tab shows logs from rules that
belong to the first (top) Layer in the policy.

Packet Capture

You can capture network traffic. The content of the packet capture provides a greater insight
into the traffic which generated the log. With this feature activated, the Security Gateway
sends a packet capture file with the log to the Log Server. You can open the file, or save itto a
file location to retrieve the information a later time.

For some blades, the packet capture option is activated by default in the Custom Threat
Prevention Policy.

To deactivate packet capture (in the Custom Threat Prevention Policy only):

1. In SmartConsole, go to the Security Policies view > Threat Prevention > Custom
Threat Prevention.

2. Inthe Track column of the rule, right-click and clear Packet Capture.

To see a packet capture:
1. In SmartConsole, go to the Logs & Events view.

2. Open thelog.
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3. Click the link in the Packet Capture field.
The Packet Capture opens in a program associated with the file type.

4. Optional: Click Save to save the packet capture data on your computer.

Searching the Logs

SmartConsole lets you quickly and easily search the logs with many predefined log queries or
customized log queries. Queries can include one or more criteria. You can modify an existing
predefined query or create a new one in the query search box.

To see the predefined queries:
1. Open SmartConsole > Logs & Events view.
2. Click Queries.

3. Select the applicable pre-defined query.

To modify a predefined query:

Click inside the query box to add search filters.

To manually enter query text:
1. Inthe query search bar, click Enter Search Query (Ctrl+F).
2. Enter the search query in the search box.

3. As you enter text, the query search box shows recently used query criteria or full queries.
To use these search suggestions, select them from the drop-down list.

To manually refresh your query:

' Click Refresh (F5).

To continuously refresh your query (Auto-Refresh):
Ca Click Auto - Refresh (F6). The icon is highlighted when Auto-Refresh is enabled.

The query continues to update every five seconds while Auto-Refresh is enabled. If the
number of logs exceeds 100 in a five-second period, the logs are aggregated, and the
summary view shows.

Selecting Query Fields

You can enter query criteria directly from the query search bar.
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To select field criteria:

1. If you start a new query, click Clear X to remove query definitions.
2. Putthe cursorin the query search bar.

3. Click Add a search filter.

4. Select afilter from the drop-down list.

5

. Enter the applicable criteria in the query search bar.
Using the Action Filter

One of the search filters is Action. When you select the Action filter, a list shows with all the log
actions available for searching. This table lists and explains these log actions.

Action Description

Accept The Security Gateway allowed traffic based on the Access Control
Security Policy.

Allow The Security Gateway allowed traffic after Firewall or a VPN alert (for
example: Protocol Violation) or DLP match on an exception to a rule.

Ask User ® The user was prompted to decide if the Security Gateway must block
or allow specific traffic, based on Access Control or Custom Threat
Prevention Security Policies.

Or

® A DLP incident was captured and put in quarantine. The user was

asked to decide what to do.

Block The Security Gateway blocked traffic based on a URL Filtering or
Application Control rule, after a user opted a UserCheck block Action.

Bypass Threat Emulation, Threat Extraction or Anti-Virus did not inspect a file.

Decrypt The Security Gateway decrypted a VPN packet to reveal its content and

allow further inspection.

Detect A Threat Prevention blade detected malicious traffic but did not block it
because it worked in the Detect mode.

Do not send User decided to drop transmission that was captured by DLP. An
administrator with full permissions or with the View, Release or Discard
DLP messages permission can also drop these transmissions. Email
notification was sent to the user.
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Action Description

Drop

Encrypt

Extract

Forgot
Passcode

HTTPS
Bypass

HTTPS
Inspect

Inform User

Inline

Inspect

IP Changed

Key Install
Open Shell

Packet
Tagging

Prevent

Quarantine

The Security Gateway blocked traffic based on the Access Control
Security Policy and did not notify the source.

The Security Gateway encrypted a VPN packet to secure its contents and
prevent unauthorized access.

Threat Extraction extracted potentially malicious content from a file before
the file entered the network.

User tapped Forgot Passcode in the Capsule Workspace application.

The Security Gateway allowed network traffic to bypass HTTPS
Inspection.

The Security Gateway inspected HTTPS traffic.

® The user was informed what the organization's policy was, based on
the Access Control or Custom Threat Prevention Security Policies.
Or

® DLP transmission was detected and allowed, and the user was
notified.

Traffic was sent for emulation before it was allowed to enter the internal
network.

Threat Emulation or Anti-Virus inspected a fie.

An association between a specific IP address and a user changed,
because the IP address on the associated host changed (DHCP).

The Security Gateway created encryption keys for VPN.
An administrator opened a command shell to a Gaia server.

The Security Gateway shared a packet tagging key with an Identity Agent.

The Security Gateway blocked traffic based on the DLP or Threat
Prevention policy.

The Security Gateway isolated an email that was identified as a potential
security threat, until further investigation is made.
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Action Description

Reject

Remote Wipe

Reset
Passcode

Run Script

Send

System
Backup

System
Restore

Update

VPN Routing

The Security Gateway rejected the packet and notified the source with the
TCP [RST] packet.

The Security Gateway removed offline data cached on a user mobile
device with Capsule Workspace Application.

User tapped Reset Passcode in the Capsule Workspace application.

An administrator executed a script on a Gaia server from SmartConsole.

User decided to continue transmission after DLP capture.

An administrator with full permissions or with the View/Release/Discard
DLP messages permission can also decide to continue transmission.
Email notification is sent to the user.

An administrator backed up the configuration of the Gaia Operating
System of the Security Gateway.

An administrator retrieved a backup file and restored configuration of the
Gaia Operating System of the Security Gateway.

The Security Gateway downloaded and installed the latest version or
Hotfix.

The Security Gateway directed the VPN traffic through the appropriate
specific VPN tunnel or Security Gateway.

Selecting Criteria from Table Columns

You can use the column headings in the logs table to select query criteria.

To select query criteria from the table columns:

1. In the Results pane, right-click a column heading.

2. Select Add Filter.

3. Select or enter the filter criteria.
The criteria show in the query search box and the query runs automatically.
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Saving a New Query

To save a new query in the Favorites list:
1. Click Queries > Add to Favorites.
The Add to Favorites window opens.
2. Enter a name for the query.
3. Select or create a new folder to store the query

4. Click Add.

Viewing Search Results

Query results can include tens of thousands of log records. To prevent performance
degradation, SmartConsole only shows the first set of results in the Results pane. Typically,
this is a set of 50 results.

Scroll down to show more results. As you scroll down, SmartConsole extracts more records
from the log index on the Security Management Server or Log Server, and adds them to the
results set. See the number of results above the Results pane.

For example, on the first run of a query, you can see the first 50 results out of over 150,000
results. When you scroll down, you can see the first 100 results out of over 150,000.

The Tops pane, on the right side of the Results pane, shows the top statistics such as top
sources, top actions, etc.

o Notes:

® Top statistics are estimated according to the partial log results already shown
on the screen. They are not calculated for the entire query timeframe.
® A query that refers to these log fields is not resolved:
e Scan result
e Destination DNS Hostname

Customizing the Results Pane

By default, SmartConsole shows a predefined set of columns and information based on the
selected blade in your query. This is known as the Column Profile. For example:

® The DLP column profile includes columns for: Blade, Type, DLP Incident UID, and
severity.

® The Threat Prevention column profile includes columns for: Origin, Action, Severity, and
Source User.

A column profile is assigned based on the blade that occurs most frequently in the query
results. This is called Automatic Profile Selection, and is enabled by default.
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The Column Profile defines which columns show in the Results Pane and in which sequence.
You can change the Column Profile as necessary for your environment.

To use the default Column Profile assignments:

® Right-click a column heading and select Columns Profile > Automatic Profile Selection.

To manually assign Column Profile assignments by default:

® Right-click a column heading and select Columns Profile > Manual Profile Selection.

To manually assign a different Column Profile:
1. Right-click a column heading and select Columns Profile.

2. Select a Column Profile from the options menu.

To change a Column Profile:
1. Right-click a column heading and select Columns Profile > Edit Profile.
In the Show Fields window, select a Column Profile to change.
Select fields to add from the Available Fields column.
Click Add.
Select fields to remove from the Selected Fields column.
Click Remove.
Select a field in the Selected Fields.

Click Move Up or Move Down to change its position in the Results Pane.

© ® N o g &~ 0w D

Double-click the Width column to change the default column width for the selected field.

To change the column width:
1. Drag the right column border in the Results Pane.
2. Right-click and select Save Profile.

Changes made to the column are saved for future sessions.

Creating Custom Queries

Queries can include one or more criteria. You can modify an existing predefined query or
create a new one in the query box.
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To modify a predefined query:

Click inside the query box to add search filters.

To save the new query in the Favorites list:
1. Click Queries > Add to Favorites.
The Add to Favorites window opens.
2. Enter a name for the query.
3. Select or create a new folder to store the query

4. Click Add.
Selecting Query Fields

You can enter query criteria directly from the Query search bar.
To select field criteria:

1. If you start a new query, click Clear to remove query definitions.
2. Putthe cursor in the Query search bar.

3. Select a criterion from the drop-down list or enter the criteria in the Query search bar.
Selecting Criteria from Grid Columns

You can use the column headings in the Grid view to select query criteria. This option is not
available in the Table view.

To select query criteria from grid columns:
1. In the Results pane, right-click on a column heading.
2. Select Add Filter.

3. Select or enter the filter criteria.
The criteria show in the Query search bar and the query runs automatically.

Manually Entering Query Criteria

You can enter query criteria directly in the Query search bar. You can manually create a new
query or make changes to an existing query that shows in the Query search bar.

As you enter text, the Search shows recently used query criteria or full queries. To use these
search suggestions, select them from the drop-down list.
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Query Language Overview

A powerful query language lets you show only selected records from the log files, according to
your criteria. To create complex queries, use Boolean operators, wildcards, fields, and ranges.
This section refers in detail to the query language.

When you use SmartConsole to create a query, the applicable criteria show in the Query
search bar.

The basic query syntaxis [<Field>:] <Filter Criterion>.
To put together many criteria in one query, use Boolean operators:

[<Field>:] <Filter Criterion> {AND|OR|NOT} [<Field>:] <Filter
Criterion>

Most query keywords and filter criteria are not case sensitive, but there are some exceptions.
Forexample, "source: <x>"is case sensitive ("Source : <xX>" does not match). If your query
results do not show the expected results, change the case of your query criteria, or try upper
and lower case.

When you use queries with more than one criteria value, an AND is implied automatically, so
there is no need to add it. Enter OR or other boolean operators if needed.

Criteria Values

Criteria values are written as one or more text strings. You can enter one text string, such as a
word, IP address, or URL, without delimiters. Phrases or text strings that contain more than
one word must be surrounded by quotation marks.

One word string examples:
® John
® inbound
= 192.168.2.1
® mabhler.ts.example.com

® dns_udp

Phrase examples
B "John Doe"
® "Tog Out"

B "VPN-1 Embedded Connector"
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IP Addresses

IPv4 and IPv6 addresses used in log queries are counted as one word. Enter IPv4 address
with dotted decimal notation and IPv6 addresses with colons.

Example:
= 192.0.2.1
® 2001:db8::f00:d

You can also use the wildcard'*' character and the standard network suffix to search for logs
that match |IP addresses within a range.

Examples:

® 5rc:192.168.0.0/16 (shows all records for the source IP 192.168.0.0 to 192.168.255.255
inclusive)

® src:192.168.1.0/24 (shows all records for the source IP 192.168.1.0 to 192.168.1.255
inclusive)

B src:192.168.2.* shows all records for the source IP 192.168.2.0 to 192.168.2.255
inclusive

® 192.168.* shows all records for 192.168.0.0 to 192.168.255.255 inclusive
NOT Values

You can use NOT <field> values with Field Keywords in log queries to find logs for which the
value of the field is not the value in the query.

Syntax

NOT <field>: <value>

Example

NOT src:10.0.4.10

Wildcards

You can use the standard wildcard characters (* and ?) in queries to match variable characters
or strings in log records. You can use more than the wildcard character.

Wildcard syntax:
® The ? (question mark) matches one character.
® The * (asterisk) matches a character string.

Examples:
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® Jo? shows Joe and Jon, but not Joseph.

® Jo* shows Jon, Joseph, and John Paul.

If your criteria value contains more than one word, you can use the wildcard in each word. For
example, 'Jo* N*' shows Joe North, John Natt, Joshua Named, and so on.

Note - Using a single ‘*’ creates a search for a non-empty value string. For example

assetname:*

Field Keywords

You can use predefined field names as keywords in filter criteria. The query result only shows
log records that match the criteria in the specified field. If you do not use field names, the query
result shows records that match the criteria in all fields.

This table shows the predefined field keywords. Some fields also support keyword aliases that
you can type as alternatives to the primary keyword.

Description

severity
app risk
protection

protection
type

confidence
level

action
blade

destination

origin
service

source

user

product

dst

orig

sSrcC

Severity of the event
Potential risk from the application, of the event
Name of the protection

Type of protection

Level of confidence that an event is malicious

Action taken by a security rule
Software Blade

Traffic destination IP address, DNS name or Check
Point network object name

Name of originating Security Gateway
Service that generated the log entry

Traffic source IP address, DNS name or Check Point
network object name

User name
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Syntax for a field name query:
<field name>:<values>
® <field name> - One of the predefined field names
® <values> - One or more filters
To search for rule number, use the Rule field name. For example:
rule:7.1
If you use the rule number as a filter, rules in all the Layers with that number are matched.
To search for a rule name, you must not use the Rule field. Use free text. For example:

"Block Credit Cards"

Best Practice - Do a free text search for the rule name. Make sure rule names are unique and
not reused in different Layers.

Examples:
B source:192.168.2.1
B action: (Reject OR Block)
You can use the OR Boolean operator in parentheses to include multiple criteria values.
Important - When you use fields with multiple values, you must:
® Write the Boolean operator, for example AND.

® Use parentheses.
Boolean Operators

You can use the Boolean operators AND , OR , and NOT to create filters with many different
criteria. You can put multiple Boolean expressions in parentheses.

If you enter more than one criteria without a Boolean operator, the AND operator is implied.
When you use multiple criteria without parentheses, the OR operator is applied before the
AND operator.

Examples:

B blade:"application control" AND action:block

Shows log records from the Application and URL Filtering Software Blade where traffic
was blocked.

m 192.168.2.133 10.19.136.101
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Shows log entries that match the two IP addresses. The AND operator is presumed.
192.168.2.133 OR 10.19.136.101
Shows log entries that match one of the IP addresses.

(blade: Firewall OR blade: IPS OR blade:VPN) AND NOT action:drop

Shows all log entries from the Firewall, IPS or VPN blades that are not dropped. The
criteria in the parentheses are applied before the AND NOT criterion.

source: (192.168.2.1 OR 192.168.2.2) AND destination:17.168.8.2

Shows log entries from the two source IP addresses if the destination IP address is

17.168.8.2. This example also shows how you can use Boolean operators with field
criteria.
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Log Sessions

A session is a user's activity at a specified site or with a specified application. The session
starts when a user connects to an application or to a site. The Security Gateway includes all
the activity that the user does in the session in one session log (in contrast to the Security
Gateway log, which shows top sources, destinations, and services).

To search for log sessions:
In the Logs tab of the Logs & Events view, enter:

type:Session

To see details of the log session:
In the Logs tab of the Logs & Events view, select a session log.
In the bottom pane of the Logs tab, click the tabs to see details of the session log:

B Connections - Shows all the connections in the session. These show if Per connection
is selected in the Track option of the rule.

® URLs - Shows all the URLs in the session. These show if Extended Log is selected in
the Track option of the rule.

® Files - Shows all the files uploaded or downloaded in the session. These show if
Extended Log is selected in the Track option of the rule, or if a Data Type was matched
on the connection.

To see the session log for a connection that is part of a session:

1. Inthe Logs tab of the Logs & Events view, double-click on the log record of a connection
that is part of a session.

2. In the Log Details, click the session icon € (in the top-right corner) to search for the
session log in a new tab.

To configure the session timeout:

By default, after a session continues for three hours, the Security Gateway starts a new
session log. You can change this in SmartConsole from the Manage & Settings view, in
Blades > Application & URL Filtering > Advanced Settings > General > Connection
unification.
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Tracking Options

Select these options in the Track column of a rule:
® None - Do not generate a log. This is the default option.

® | og - Show all the information that the Security Gateway used to match the connection.
At a minimum, this is the Source, Destination, Source Port, and Destination Port. If there
is @ match on a rule that specifies an application, a session log shows the application
name (for example, Dropbox). If there is a match on a rule that specifies a Data Type, the
session log shows information about the files, and the contents of the files.

® Accounting - Select this to update the log at 10 minutes intervals, to show how much
data has passed in the connection: Upload bytes, Download bytes, and browse time.
Browse time is the total duration of a user session, including both active usage and idle
time. The session will timeout after the defined idle time.ldle time is the period within a
session when there is no user activity, but the connection remains open.

Note - When upgrading from R77.X or from R80 versions to R82, there are changes
to the behavior of the options in the Track column. To learn more, see sk116580.

Advanced Track options

Detailed Log and Extended Log are only available if one or more of these Blades are enabled
on the Layer: Application & URL Filtering, Content Awareness, or Mobile Access.

® Detailed Log -Equivalent to the Log option, but also shows the application that matched
the connections, even if the rule does not specify an application. Best Practice - Use for
a cleanup rule (Any/internet/Accept) of an Applications and URL Filtering Policy Layer
that was upgraded from an R77 Application Control Rule Base.

= Extended Log -Equivalent to the Detailed option, but also shows a full list of URLs and
files in the connection or the session. The URLs and files show in the lower pane of the
Logs view.

o Note - The Detailed Log and Extended Log options have a higher performance
impact on the Security Gateway than the Log option, because they inspect the
packets and connections more thoroughly.

Log Generation

® per Connection - Select this to show a different log for each connection in the session.
This is the default for rules in a Layer with only Firewall enabled. These are basic
Firewall logs.
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® per Session - Select this to generate one log for all the connections in the same session
(see "Log Sessions" on page 112). This is the default for rules in a Layer with Application
& URL Filtering or Content Awareness enabled. These are basic Application Control
logs.

Alert:

For each alert option, you can define a script in Menu > Global properties > Log and Alert >
Alerts.

® None - Do not generate an alert.

® Alert - Generate a log of type Alert and run a command, such as: Show a popup window,
send an email alert or an SNMP trap alert, or run a user-defined script as defined in the
Global Properties.

® SNMP - Generate a log of type Alert and send an SNMP alert to the SNMP GUI, as
defined in the Global Properties.

® Mail - Generate a log of type Alert and send an email to the administrator, as defined in
the Global Properties.

= User Defined Alert - Generate a log of type Alert and send one of three possible
customized alerts. The alerts are defined by the scripts specified in the Global
Properties.
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SmartView Web Application

Use Case - You are the system administrator at a small company and are concerned that
some employees spend too much time looking at Facebook. You want a way to monitor the
employee application use.

The SmartView Web Application is one of the SmartEvent clients that you can use to analyze
events that occur in your environment. Use the SmartView Web Application to see an overview
of the security information for your environment. It has the same real-time event monitoring
and analysis views as SmartConsole. The convenience is that you do not have to install a
client.

Note - SmartView graphics do not display properly in Internet Explorer. Accessing
SmartEvent Server from the web (SmartView) is supported only from Google Chrome
and Mozilla Firefox.

To log in to SmartEvent using SmartView Web Application:

Browse to:

https://<IP Address of Management Server>/smartview/

or

https://<Host Name of Management Server>/smartview/

o Notes:

® The /smartview/ part of the URL is case sensitive.
® When you open the SmartView Web Application on a Standalone server (a
server which runs both a Security Management Server and a Security
Gateway), these web portals stop working:
e The Gaia Portal (https://<Server IP Address>and
https://<Server IP Address>:4434)
» The API documentation portal (https://<Server IP
Address>/api_docs)
» Web SmartConsole (https://<Server IP
Address>/smartconsole)
® | ogin to SmartView Web Application is supported only using Check Point
Password authentication configured in the administrator object in
SmartConsole.

SmartView advantages:
B Available for non-admin users

® Export up to 1,000,000 logs
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® |ntegrated top statistics and docked card

® Support for High Contrast theme

In SmartView:

SmartView opens by default in the General Overview tab. This shows the statistics, Software
Blades, timelines, and more. Any open tabs from the previous session are retained.

Note - SmartView Web Application is available even without SmartEvent Software
Blade, but the default page is different.

To open a new tab, click +.
The Audit Logs tab shows audit logs which are changes done in the management.
The Logs > Logs View tab shows blade activities.
In SmartView, you first filter for the application and then by user.
1. Click the + icon to open a new tab.
2. Click Views > Access Control.

3. Right-click the User column and drill down to see the user activity or create a filter for this
user in your current view.

You can schedule for all activities for a user, but cannot set the system to trigger an alert at a
certain threshold.

To select which columns are shown:
1. Right-click on a column heading and select Profile editor.
The Profile editor window opens.
2. Select fields to add to or remove from the selected profile.

3. Click OK.

To set user display preferences:
1. Click the drop-down arrow next to your user name and select User Preferences.
2. ForLocale, select the display language.
3. For First day of the week, select the day of the week for the weekly logs to start.
4. For Theme, select Default or High Contrast.

In High Contrast, the view display is white text on a black background.
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5. In Default time frame, set the default timeframe for all the SmartView Web Application
functionalities.

The default value is Last 24 hours.

Note - The default time frames on the SmartView Web Application and
SmartConsole are not synchronized.

6. For Email server settings, select Edit to enter the email server details.

7. Click OK.

Exporting Logs

Apply a filter to select the logs you want to export. Currently, you can only export logs to CSV.

To export logs:
1. Inthe Logs tab, click Options and select Export > Export to CSV.
The CSV Export window opens.
Select the Logs Amount.
Select the Exported Columns - All columns or Visible columns.

Click OK.

a &> b

A popup window appears when the export process starts.
When you see a message that the exported completed successfully, click Download.

All exported logs also appear in the archive tab.
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Log Server High Availability

In SmartConsole, you can configure a Security Gateway, that when it fails to send its logs to
one Log Server, it will send its logs to a secondary Log Server. To support this configuration,
you can add Log Servers to a single SmartEvent Correlation Unit. In this way, the SmartEvent
Correlation Unit gets an uninterrupted stream of logs from both servers and continues to

correlate all logs.
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Working with Syslog Servers

Introduction

Syslog (System Logging Protocol) is a standard protocol used to send system log or event
messages to a specific server, the syslog server.

The syslog protocol is enabled on most network devices, such as routers and switches.

Syslog is used by many log analysis tools. If you want to use these tools, make sure Check
Point logs are sent to from the Security Gateway to the syslog server in syslog format.

Check Point supports these syslog protocols: RFC 3164 (old) and RFC 5424 (new).

These features are not supported: IPv6 logs and Software Blade logs.

Configuring Security Gateways

By default, Security Gateway logs are sent to the Security Management Server.

You can configure Security Gateways to send logs directly to syslog servers.

Important - Syslog is not an encrypted protocol. Make sure the Security Gateway and the Log
Proxy are located close to each other and that they communicate over a secure network.
Procedure

1. Define syslog server objects in SmartConsole.

Instructions

a. Connect with SmartConsole to the Management Server.
b. From the left navigation panel, click Gateways & Servers.
c. Create the Host object that represents the Syslog server host.
i. Inthe Object Explorer, click New > Host.
ii. Configure these fields:
® Name - Enter a unique name.
® |Pv4 address - Enter the correct IPv4 address of the syslog server.

® |Pv6 address - Optional: Enter the correct IPv6 address of the syslog
server. This requires the IPv6 Support be enabled on the Security
Gateway / each Cluster Member.

jii. Click OK.
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d. Create the Syslog Server object that represents the Syslog server:
i. Inthe Object Explorer, click New > Server > More > Syslog.
ii. Configure these fields:
® Name - Enter a unique name.

® Host - Select an existing host or click New to define a new computer
or appliance.

® Port - Enter the correct port number on the syslog server (default =
514).

® Version - Select BSD Protocol or Syslog Protocol.
iii. Click OK.
e. Close the Object Explorer.

2. Select the configured syslog server objects in the Security Gateway / Cluster object.

Instructions

a. Double-click the Security Gateway object.
b. From the left tree, click Logs.

c. Inthe Send logs and alerts to these log servers table, click the green (+) button
to select the Syslog Server object(s) you configured earlier.

Notes:

® You can configure a Security Gateway / Cluster Member to send logs to
multiple syslog servers.

All syslog servers selected in the Security Gateway / Cluster object must
use the same protocol version: BSD Protocol or Syslog Protocol.

® You cannot configure a Syslog server as a backup server.
d. Click OK.

e. Install policy.

3. Configure the logging properties of the Security Gateways / each Cluster Member.

The kernel parameter fwsyslog enable optimizes logging performance in
environments that require high log rates.

Enable this kernel parameter only if explicitly instructed by Check Point Support.

® fwsyslog enable=0: Firewall logs are sent to the Syslog Server through the
user space Syslog daemon (this is the default).
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® fwsyslog enable=1:Firewall logs are sent to the Syslog Server directly from
the Gaia OS kernel.

o Note - In a Cluster, you must configure each Cluster Member in the same way.

To see the current state of the fwsyslog_enable parameter

a. Connect to the command line on the Security Gateway / each Cluster Member.
b. Log in to the Expert mode.

c. Run:
fw ctl get int fwsyslog enable

Output:

B "fwsyslog enable = 0"means that Firewall logs are sentto the
Syslog Server through the user space Syslog daemon (this is the default).

® "fwsyslog enable = 1"means Firewall logs are sent to the Syslog
Server directly from the Gaia OS kernel.

To set the state of the fwsyslog_enable parameter to (1) temporarily (does not survive
reboot)

a. Connect to the command line on the Security Gateway / each Cluster Member.
b. Log in to the Expert mode.

c. Run:

fw ctl set int fwsyslog enable 1

d. In SmartConsole, install policy on this Security Gateway / Cluster object.
To set the state of the fwsyslog_enable parameter to (1) permanently (survives reboot)

a. Connect to the command line on the Security Gateway / each Cluster Member.
b. Log in to the Expert mode.

c. Editthe $FWDIR/boot/modules/fwkern.conf file:

vi SFWDIR/boot/modules/fwkern.conf

d. Add this line:

fwsyslog enable=1

e. Save the changes in the file and exit the editor.
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f. Reboot the Security Gateway / each Cluster Member.

To set the state of the fwsyslog_enable parameter to (0) temporarily (does not survive
reboot)

a. Connect to the command line on the Security Gateway / each Cluster Member.
b. Log in to the Expert mode.

c. Run:

fw ctl set int fwsyslog enable O

To set the state of the fwsyslog_enable parameter to (0) permanently (survives reboot)

a. Connect to the command line on the Security Gateway / each Cluster Member.
b. Log in to the Expert mode.

c. Editthe $FWDIR/boot/modules/fwkern.conf file:

vi SFWDIR/boot/modules/fwkern.conf

d. Do one of these actions:
® Set the value of the kernel parameter to 0:
fwsyslog enable=0
® Delete the entire line:
fwsyslog enable=1
e. Save the changes in the file and exit the editor.

f. Reboot the Security Gateway / each Cluster Member.

Log Count for CoreXL Firewall Instances

You can see the current number of syslog logs sent by CoreXL Firewall Instances on the
Security Gateway / each Cluster Member.

To see log count for a CoreXL Firewall instance
1. Connect to the command line on the Security Gateway / each Cluster Member.
2. Loginto the Expert mode.
3. Run:
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fw -1 <CoreXL Firewall Instance Number> ctl get fwsyslog
nlogs counter

Sample output:

fwsyslog nlogs counter = 21

To see log count for all CoreXL Firewall instances

1. Make two command line connections to the Security Gateway / each Cluster Member.
2. In each command line connection, log in to the Expert mode.

3. Inthe first shell, run:

fw ctl zdebug | grep logs

4. Inthe second shell, run:

fw ctl set int fwsyslog print counter 1

5. Inthe first shell, see the counter for each CoreXL Firewall instance and the sum of all
CoreXL Firewall instances.

Sample output:

14

;Number of logs sent from instance 0 is 43;

[cpu 2]; [fwd O]

;lcpu 2];[fwd O0];Number of logs sent from instance 1 is 39;
[ 10 ]
[ 10 ]

4

4

fw4 O0];Number of logs sent from instance 2 is 50;
fwd 0O

cpu_2

4

cpu_ 2 ;Total logs sent from kernel (all instances)

132;

.
14

6. Inthe first shell, press CTRL+C to stop the debug.

For more on syslog, see: "Appendix: Manual Syslog Parsing"” on page 289.
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Event Analysis with SmartEvent

The SmartEvent Software Blade is a unified security event management and analysis solution
that delivers real-time, graphical threat management information. SmartConsole, SmartView
Web Application, and the SmartEvent GUI client consolidate billions of logs and show them as
prioritized security events so you can immediately respond to security incidents, and do the
necessary actions to prevent more attacks. You can customize the views to monitor the events
that are most important to you. You can move from a high level view to detailed forensic
analysis in a few clicks. With the free-text search and suggestions, you can quickly run data
analysis and identify critical security events.

o Note - SmartEvent is not supported in a Full High Availability Cluster configuration.

What is an Event?

An eventis a record of a security incident. It is based on one or more logs, and on rules that
are defined in the Event Policy.

An example of an event that is based on one log: A High Severity Anti-Bot event. One Anti-Bot
log with a Severity of High causes the event to be recorded.

An example of an event that is based on more than one log: A Certificate Sharing event. Two
login logs with the same certificate and a different user cause the event to be recorded.

How Are Logs Converted to Events?

SmartEvent automatically defines logs that are not Firewall, VPN, or HTTPS Inspection logs,
as events.

Events that are based on a suspicious pattern of one or more logs, are created by the
SmartEvent Correlation Unit. These correlated events are defined in the SmartEvent client
GUI, in the Policy tab.

Most logs are Firewall, VPN and HTTPS inspection logs. Therefore, SmartEvent does not
define them as events by default to avoid a performance impact on the SmartEvent Server.

For logs from Security Gateways R77.X and lower: To create events for Firewall, in the
SmartEvent Policy tab, enable Consolidated Sessions > Firewall Session.
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The SmartEvent Architecture

SmartEvent has some components that work together to help track down security threats and
make your network more secure.

This is how they work together. The numbers refer to the diagram:

® SmartEvent Correlation Unit (3) analyzes log entries on Log Servers (2) and stores the
event in the same way the log server stores logs.

® SmartEvent Server (4) contains the Events Database (5).

® The SmartEvent and SmartConsole clients (6) manage the SmartEvent Server.

1

Item Description

—»

1 Check Point
Security
Gateway

2 Log Server

3 SmartEvent
Correlation
Unit

T—-m

Purpose
Log data flow
Event data flow

Sends logs to the Log Server.

Stores logs.

Identifies events: Analyzes each log entry from a Log Server,
and looks for patterns according to the installed Event Policy.
The logs contain data from Check Point products and certain
third-party devices. When a threat pattern is identified, the
SmartEvent Correlation Unit forwards the eventto the
SmartEvent Server.
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4 SmartEvent
Server

5 Events
database

6 SmartEvent
client

Event Analysis

Purpose

The SmartEvent Server:

® |ndexes logs for SmartView
® Defines the event policy
® Manages correlation units

o Note - On a Multi-Domain Server, after you define the

Global SmartEvent Server object in the Global
Domain, you must assign a Global Policy to all
Domain Servers, for the Domain Server
administrators to be able to log in to the SmartEvent
Server.

Stores events. Located on the SmartEvent Server.

Shows the received events. Uses the clients to manage events
(for example: to filter and close events), fine-tunes, and installs
the Event Policy. The clients are:

® SmartConsole
® SmartView Web Application

The SmartEvent components can be installed on one computer (that is, a standalone
deployment) or multiple computers and sites (a distributed deployment). To handle higher
volumes of logging activity, we recommend a distributed deployment. Each SmartEvent
Correlation Unit can analyze logs from more than one Log Server or Domain Log Server.

SmartEvent Correlation Unit

The SmartEvent Correlation Unit analyzes the log entries and identifies events from them.
During analysis, the SmartEvent Correlation Unit:

® Marks log entries that are not stand-alone events, but can be part of a larger pattern to be

identified later.

® Takes a log entry that meets one of the criteria set in the Events policy, and generates an

event.

® Takes a new log entry that is part of a group of items. Together, all these items make up
a security event. The SmartEvent Correlation Unit adds it to an ongoing event.

® Discards log entries that do not meet event criteria.
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SmartEvent Correlation Unit High Availability

Multiple correlation units can read logs from the same Log Servers. That way, the units provide
redundancy if one of them fails. The events that the Correlation Units detect are duplicated in
the SmartEvent database. But these events can be disambiguated if you filter them with the
Detected By field in the Event Query definition. The Detected By field specifies which
SmartEvent Correlation Unit detected the event.

The SmartView Web Application

The SmartView Web Application is one of the SmartEvent clients that you can use to analyze
events that occur in your environment. Use the SmartView Web Application to see an overview
of the security information for your environment. It has the same event monitoring and analysis
views as SmartConsole. The convenience is that you do not have to install a client.

To log in to SmartEvent using SmartView Web Application:
Browse to:

https://<IP Address of Security Management Server>/smartview/
or

https://<Host Name of Security Management Server>/smartview/

Note - The URL is case sensitive.
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Configuring SmartEvent Policy and Settings
Opening the SmartEvent GUI Client

Use the Policy tab of the SmartEvent GUI client to configure and customize the events that
define the SmartEvent Policy.

To open the SmartEvent GUI client:
1. In SmartConsole, from the left navigation panel, click the Logs & Monitor view.
2. Atthe top, click + to open a new tab.

3. Inthe bottom section External Apps, click SmartEvent Settings & Policy.

Policy Tab

Define the Event Policy in the Event Policy tab. Most configuration steps occur in the Policy
tab. You define system components, such as SmartEvent Correlation Unit, lists of blocked IP
addresses and other general settings.

The types of events that SmartEvent can detect are listed here, and sorted into a number of
categories. To change each event, change the default thresholds and set Automated
Responses. You can also disable events.

The Policy tab has these sections:
® Selector Tree - The navigation pane.
® Detail pane - The settings of each item in the Selector Tree.
® Description pane - A description of the selected item.
You can edit the event policy in one of these ways:
® Fine-tune the Event Policy.

® Change the existing Event Definition to see the events that interest you in "Modifying
Event Definitions" on page 150.

® Create new Event Definitions to see the events that are not included in the existing
definitions.

Save Event Policy

Modifications to the Event Policy do not take effect until saved on the SmartEvent Server and
installed to the SmartEvent Correlation Unit.
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To enable changes made to the Event Policy:
1. Click Menu > File > Save.

2. Click Actions > Install Event Policy.
Revert Changes

You can undo changes to the Event Policy, if they were not saved.

To undo changes: click File > Revert Changes.

Event Definitions and General Settings

The Selector tree is divided into two branches: Event Policy and General Settings. The
events detectable by SmartEvent are organized by category in the Event Policy branch.
Select an event definition to show its configurable properties in the Detail pane, and a
description of the event in the Description pane. Clear the property to remove this event type
from the Event Policy the next time the Event Policy is installed.

The General Settings branch contains Initial Settings. For example: To define SmartEvent
Correlation Unit, which is typically used for the initial configuration. Click a General Settings
item to show its configurable properties in the Detail pane.

For details on specified attacks or events, refer to the Event Definition Detail pane.

Event Definition Parameters

When an event definition is selected, its configurable elements appear in the Detail pane, and
a description of the event is displayed in the Description pane.

These are the usual types of configurable elements:

® Thresholds, such as Detect the event when more than x connections were detected
over y seconds

® Severity - Informational, Low, Medium, High, or Critical.
® "Automatic Reactions" on page 131 such as Block Source or External Script.
= "Exceptions"” on page 142.

® Time Object, such as to issue an event if the following occurs outside the following
Working Hours (see "Working Hours" on page 141).

Not all of these elements appear for every Event Definition. After you install and run
SmartEvent for a short time, you will discover which of these elements need to be fine-tuned
per Event Definition.

For configuration information regarding most objects in General Settings, see "System
Administration"” on page 166.
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Modifying Event Definitions

SmartEvent constantly takes data from your Log Servers, and searches for patterns in all the
network chatter that enters your system.

Depending on the levels set in each Event Definition, the number of events detected can be
high. But only a portion of those events can be meaningful. You can change the thresholds and
other criteria of an event, to reduce the number of false alarms.

Event Threshold

The Event Threshold allows you to modify the limits that, when exceeded, indicate that an
event occurred. Limits include the number of logs, and the timeframe in which they occurred:

Detect the event when more than Xlogs were detected over a period of Y seconds.

To decrease the number of false alarms based on a particular event, increase the number of
logs and/or the timeframe for them to occur.

Severity

To modify the severity of an event, select a severity level from the drop-down list.

If the event is based on Threat Prevention logs, the event gets the severity from the protection
type, not from the severity configured here.

To overwrite the severity:
1. Go to SmartEvent > Policy.
2. Select an event and right-click > Select Properties.
The Edit Event Definition window opens.

3. Inthe Event Format tab, select Determine event's display nhame and severity from
event logs.

4. Click Menu > File > Save.

5. Click Actions > Install Event Policy.
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Automatic Reactions

When detected, an event can activate an Automatic Reaction. The SmartEvent administrator
can create and configure one Automatic Reaction, or many, according to the needs of the
system.

For example: A Mail Reaction can be defined to tell the administrator of events to which it is
applied. You can create multiple Automatic Mail Reactions to tell a different responsible party
for each type of event.

Automatic Reaction Types

Mail - Send an email when the event occurs. See "Creating an Automatic Reaction
"Mail™ on the next page.

SNMP Trap - Send an SNMP Trap when the event occurs. See "Creating an Automatic
Reaction "SNMP Trap"" on page 133.

Block Source - Instruct the Security Gateway to block the source IP address from which
this event was detected for a configurable timeframe. See "Creating an Automatic
Reaction "Block Source" on page 135.

Block Event activity - Instruct the Security Gateway to block a distributed attack that
emanates from multiple sources, or attacks multiple destinations for a configurable
timeframe. See "Creating an Automatic Reaction "Block Event Activity" on page 136.

External Script - Run a user-cretated script when the event occurs. See "Creating an
Automatic Reaction "External Script™ on page 137.
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Creating an Automatic Reaction "Mail"

The Automatic Reaction "Mail" sends an email when the event occurs.

—

10.
11.
12.
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. In SmartConsole, from the left navigation panel, click the Logs & Events view.

At the top, click + to open a new tab.
In the bottom section External Apps, click SmartEvent Settings & Policy.
Click General Settings > Objects > Automatic Reactions.
Click Add > Mail.
In the Name field, enter a significant name.
Optional: In the Comment field, enter a significant text.
In the Mail Parameters section:
a. Inthe From field, enter the applicable email address.
b. Inthe To field, enter the applicable email addresses.
To add multiple recipients, separate each email address with a semi-colon.
c. Inthe Cc field, enter the applicable email addresses.
To add multiple recipients, separate each email address with a semi-colon.
d. Inthe Subject field, enter the applicable email subject.

Note - The Subject field has the default variables of [EventNumber] - [Severity] -
[Name]. These variables automatically add to the mail subject the event number,
severity, and name of the event that triggered this reaction.

In the Mail Server section, in the Outgoing mail server (SMTP) field, enter the IP
address or FQDN of your SMTP server.

Important - The SmartEvent Server must be able to reach your SMTP server. If
you configure an FQDN, the DNS servers you configured on the SmartEvent
Server must be able to resolve this FQDN.

Click Save.
Click Menu > File > Save.

Click Menu > Actions > Install Event Policy.
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Creating an Automatic Reaction "SNMP Trap"

The Automatic Reaction "SNMP Trap" sends an SNMP Trap when the event occurs.

—

. In SmartConsole, from the left navigation panel, click the Logs & Events view.
. Atthe top, click + to open a new tab.

In the bottom section External Apps, click SmartEvent Settings & Policy.
Click General Settings > Objects > Automatic Reactions.

Click Add > SNMP Trap.

In the Name field, enter a significant name.

Optional: In the Comment field, enter a significant text.

©® N oo g~ W D

In the SNMP Trap Parameters section:
a. Inthe Host field, enter the IP address or FQDN of your SMTP server.

Important - The SmartEvent Server must be able to reach your SMTP
server. If you configure an FQDN, the DNS servers you configured on the
SmartEvent Server must be able to resolve this FQDN.

b. Inthe Message field, enter the applicable text. If this field is empty, then the
SmartEvent Server sends the text of the event.

c. Inthe OID field, enter the applicable SNMP OID.

This OID must be defined in the SCPDIR/1ib/snmp/chkpnt.mib file orin the
SCPDIR/1ib/snmp/chkpnt-trap.mib file thatis located on the SmartEvent
Server.

If this field is empty, then the SmartEvent Server uses the OID
1.3.6.1.4.1.2620.1.1.11 (
iso.org.dod.internet.private.enterprises.checkpoint.products
.fw.fwEvent)

d. Inthe Community name field, enter the applicable SNMP Community name.
9. Click Save.
10. Click Menu > File > Save.
11. Click Menu > Actions > Install Event Policy.

Notes:
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® The built-in command send_snmp on the SmartEvent Server send the SNMP Trap.

® When the automatic reaction occurs, the SNMP Trap is sent as a 256 byte
DisplayString text.

If the OID type is not text, the message is not sent.
® You can send event fields in the SNMP Trap message.

Possible fields for the "seam_event" table

Additionallnfo varchar(1024)
AutoReactionStatus varchar(1024)
Category varchar(1024)
DetectedBy integer

DetectionTime integer

Direction integer

DueDate integer

EndTime integer

EventNumber integer

FollowUp integer

IsLast integer

LastUpdateTime integer
MaxNumOfConnections integer
Name varchar(1024), NumOfAcceptedConnections integer
NumOfRejectedConnections integer
NumOfUpdates integer
ProductCategory varchar(1024)
ProductName varchar(1024)
Remarks varchar(1024)

RulelD varchar(48)

Severity integer

StartTime integer

State integer
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Timelnterval integer
TotalNumOfConnections varchar(20)
User varchar(1024)

Uuid varchar(48)

aba_customer varchar(1024)

joblD varchar(48)

policyRulelD varchar(48)

Creating an Automatic Reaction "Block Source"

The Automatic Reaction "Block Source" instructs the Security Gateway to block the source IP
address from which this event was detected for a configurable timeframe.

1.
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9.
10.
11.

In SmartConsole, from the left navigation panel, click the Logs & Events view.
At the top, click + to open a new tab.
In the bottom section External Apps, click SmartEvent Settings & Policy.
Click General Settings > Objects > Automatic Reactions.
Click Add > Block Source.
In the Name field, enter a significant name.
Optional: In the Comment field, enter a significant text.
In the Blocking Timeout section, select for how long to block the source:
®= Next 10 Minutes
® Next Hour
® Next Day
" Next Week
® Enter a number from 1 to 32767.
Click Save.
Click Menu > File > Save.

Click Menu > Actions > Install Event Policy.
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Creating an Automatic Reaction "Block Event Activity"

The Automatic Reaction "Block Event activity" instructs the Security Gateway to block a
distributed attack that emanates from multiple sources, or attacks multiple destinations for a
configurable timeframe.

—
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. In SmartConsole, from the left navigation panel, click the Logs & Events view.
. Atthe top, click + to open a new tab.

In the bottom section External Apps, click SmartEvent Settings & Policy.
Click General Settings > Objects > Automatic Reactions.

Click Add > Block Event Activity.

In the Name field, enter a significant name.

Optional: In the Comment field, enter a significant text.

In the Blocking Timeout section, select for how long to block the source:

Next 10 Minutes
Next Hour

Next Day

Next Week

Enter a number from 1 to 32767.

9. From the drop-down list, select the number of minutes to block this source.

10. Click Save.

11. Click Menu > File > Save.

12. Click Menu > Actions > Install Event Policy.
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Creating an Automatic Reaction "External Script"

The Automatic Reaction "External Script" runs a script that you provide.
1. Create the required shell script for Bash or C-Shell.

Guidelines for creating the shell script

® Run the script manually on the SmartEvent Server and make sure it works as
expected.

® Make sure the script runs for no longer than 10 minutes.

Otherwise, the SmartEvent Server will terminate this script.
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® Use the event fields in the script:
To refer to the event in the script, define this environment variable:
EVENT=S (cat)
and use SEVENT

Use line editor commands like awk or sed to parse the event and refer to
specific fields. You can print the SEVENT one time to see its format.

The format of the event content is a name-value set - a structured set of fields
that have the form:

(name: wvalue ;* );

where name is a string and value is either free text until a semicolon, or a nested
name-value set.

This is a sample event:

(Name: Check Point administrator credential guessing;
RulelID:

{F182D6BC-AQ0AA-444a-9F31-COC22ACA2114}; Uuid:
<42135¢9¢, 00000000, 2e1510ac,131c07b6>; NumOfUpdates: O;

IsLast: 0;

StartTime: 16Feb2015 16:45:45; EndTime: Not Completed;
DetectionTime:

16Feb2015 16:45:48; LastUpdateTime: 0; Timelnterval:
600;

MaxNumOfConnections: 3; TotalNumOfConnections: 3;
DetectedBy: 2886735150;

Origin: (IP: 192.0.2.4; repetitions: 3; countryname:
United States;

hostname: theHost) ; ProductName: SmartDashboard; User:
XYZ; Source:

(hostname: theHost; repetitions: 3; IP: 192.0.2.4;
countryname: United

States) ; Severity: Critical; EventNumber: EN00000184;

State: 0;
NumOfRejectedConnections: 0; NumOfAcceptedConnections:
0) 7

2. Put the script on the SmartEvent Server:
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10.
11.
12.
13.

Automatic Reactions

a. Connect to the command line on the SmartEvent Server.
b. Log in to the Expert mode.
c. Inthedirectory SRTDIR/bin, create the directory "ext commands"

mkdir -v S$RTDIR/bin/ext commands

d. Uplod the shell script file to the SmartEvent Server to the directory
SRTDIR/bin/ext commands/ (orto a nested directory in that directory).

The path and script name must not contain any spaces.
e. Assign the "execute" permissions to this script:
chmod -v +x SRTDIR/bin/ext commands/<script filename>
f. Make sure to save the script in the UNIX format.
dos2unix SRTDIR/bin/ext commands/<script filename>
In SmartConsole, from the left navigation panel, click the Logs & Events view.
At the top, click + to open a new tab.
In the bottom section External Apps, click SmartEvent Settings & Policy.
Click General Settings > Objects > Automatic Reactions.
Click Add > External Script.
In the Name field, enter a significant name.

In the Command line field, enter the relative path (relative to the directory
$SRTDIR/bin/ext commands/)and the name of the script.

Examples:
® |f the scriptis located in the directory SRTDIR/bin/ext commands/:
MyExternalScript.sh

® |f the script is located in the directory SRTDIR/bin/ext commands/ in a nested
directory MyScripts:

MyScripts/MyExternalScript.sh
Optional: In the Comment field, enter a significant text.
Click Save.

Click Menu > File > Save.

Click Menu > Actions > Install Event Policy.

R82 Logging and Monitoring Administration Guide | 139



Automatic Reactions

Assigning an Automatic Reaction to an Event

You can add an Automatic Reaction for SmartEvent to run when this type of event is detected.

—

. In SmartConsole, from the left navigation panel, click the Logs & Events view.
. Atthe top, click + to open a new tab.

In the bottom section External Apps, click SmartEvent Settings & Policy.
Click Event Policy > click the relevant event object.

In the Automatic Reactions field, click the icon [...].

o o A W N

Select the relevant Automatic Reactions and click OK.

If the relevant Automatic Reaction is not in this list, then click Add new?. See "Automatic
Reaction Types" on page 131.

7. Click OK.
8. Click Menu > File > Save.

9. Click Menu > Actions > Install Event Policy.

Adding more fields to an Event

—

. Inthe SmartEvent GUI client, in the Policy tab, right-click the event, click Properties.

. Atthe top, click the Event Format tab.

2
3. Inthe Display column, select the Event fields to have in the Event.
4. Click Menu > File > Save.

5

. Click Menu > Actions > Install Event Policy.
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Working Hours

Working Hours are used to detect unauthorized attempts to access protected systems and
other forbidden operations after-hours. To set the Regular Working Hours for an event, select
a Time Object that you have configured from the drop-down list.

Part 1 - Create a Time Object:

—
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. In SmartConsole, from the left navigation panel, click the Logs & Monitor view.

At the top, click + to open a new tab.

In the bottom section External Apps, click SmartEvent Settings & Policy.
Click General Settings Objects > Time Objects.

Click Add.

In the Name field, enter a significant name.

Optional: In the Description field, enter a significant text.

Select the required days and times.

Click Save.

Part 2 - Assign a Time Object to an event:

1.

2.

In the Event Policy folder, select and click the relevant event object that supports the
Regular Working Hours field.

For example, in the Unauthorized Entry event category, click the event User Login at
irregular hours.

In the Regular Working Hours field, select the applicable Time object.

Part 3 - Install Event Policy

1.
2.

Click Menu > File > Save.

Click Menu > Actions > Install Event Policy.
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Exceptions

Exceptions allow an event to be independently configured for the sources, destination, service
and other parameters depending on the event type.

For example, if the event Scans > Port Scan from Internal Network is set to detect an event
when 30 port scans occur within 60 seconds, you can also define that two port scans detected
from host A within 10 seconds of each other is also an event.

To add an exception:

1. In SmartConsole, from the left navigation panel, click the Logs & Monitor view.

. At the top, click + to open a new tab.

2
3. Inthe bottom section External Apps, click SmartEvent Settings & Policy.
4

. In the section Apply the following exceptions to the event definition, click Add (on the
right side, move the scrollbar down to see this section).

5. Inthe section Exception match:

a. Inthe Source field:

iv.

Select the checkbox.
On the right side, click [...].
Select the required object.

Note - If you do not see the host object listed, you may need to create it in
SmartEvent (see "System Administration" on page 166).

Click OK.

b. Inthe Destination field:

iv.

Select the checkbox.
On the right side, click [...].
Select the required object.

Note - If you do not see the host object listed, you may need to create it in
SmartEvent (see "System Administration" on page 166).

Click OK.

c. Inthe Connection occurred at least field, enter the relevant number of times.

d. Inthetimes over a period of field, enter the relevant number of seconds.

6. Inthe section Severity and Reactions:
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a. Inthe Severity field, select the required level.
b. Inthe Reactions section, select the application option:
= Default.

® Specific > click [...] > select or add the relevant Automatic Reactions > click
OK (see "Automatic Reactions" on page 131).

c. Optional: In the Comment field, enter a significant text.
7. Click OK.
8. Click Menu > File > Save.

9. Click Menu > Actions > Install Event Policy.
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High Level Overview of Event Identification

Events are detected by the SmartEvent Correlation Unit. The SmartEvent Correlation Unit
scans logs for criteria that match an Event Definition.

SmartEvent uses these procedures to identify these events:

Matching a Log Against Global Exclusions

When the SmartEvent Correlation Unit reads a log, it first checks if the log matches all defined
Global Exclusions. Global Exclusions (defined on the Policy tab > EventPolicy > Global
Exclusions) direct SmartEvent to ignore logs that are not expected to contribute to an event.

If the log matches a Global Exclusion, it is discarded by the system. If not, the SmartEvent
Correlation Unit starts to match it against each Event Definition.

Matching a Log Against Each Event Definition

Each Event Definition contains a filter which is comprised of a number of criteria that must be
found in all matching logs. The criteria are divided by product: The Event Definition can
include a number of different products, but each product has its own criterion.

Event Definition “A”

Endpoint Security
Froduct Sacurity Gataway
Action block drog, reject
Type firewall MIA
Port B0 — 84 80— 84
PFrotocol | TCF TCF

To match the Event Definition "A", a log from Endpoint Security must match the Action, Event
Type, Port, and Protocol values listed in the Endpoint Security column. A log from a Security
Gateway must match the values listed in its column.

SmartEvent divides this procedure into two steps. The SmartEvent Correlation Unit first
checks if the Product value in the log matches one of the permitted Product values of an Event
Definition.

Event Definition “A° Log 1

" s [~ .

Product Enl:!p-ci-lnt‘*:l Security Product Endpn:.urn\)
Security )| Gateway L Security

Action | blogk drop, reject Action | —x=%=
Type firewall MNIA Type ~K~X~
Port B0 — B4 Bl — B4 Part o
Protocaol | TCP TCP Protoool | ~x~x~
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If Log 1 did not contain a permitted Product value, the SmartEvent Correlation Unit compares
the log against Event Definition "B", and so on. If the log fails to match against an Event
Definition, it is discarded.

The SmartEvent Correlation Unit checks if the log contains the Product-specific criteria to
match the Event Definition. For example: The product Endpoint Security generates logs that
involve the Firewall, Spyware, Malicious Code Protection, and others. The log contains this
information in the field Event Type. If an event is defined to match on Endpoint Security logs
with the event type Firewall, an Endpoint Security log with Event Type "Spyware" fails against
the Event Definition filter. Other criteria can be specified to the Product.

In our example, Log 1 matched Event Definition "A" with a permitted product value. The
SmartEvent Correlation Unit examines if the log contains the necessary criteria for an
Endpoint Security log to match.

Event Definition “A” Log 1
. | Endpzint Security .| Endpoint
Product 5 i Gateway Praduct § "
Action fblock 7 | drop, reject Action  f block
Type  ffirewall 5 |NIA Type firewall
Port = B — B4 Port
Protocol | TCP TCP Protocol | TCP
Source | ~x~—x~

If the criteria do not match, the SmartEvent Correlation Unit continues to compare the log
criteria to other event definitions.
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Creating an Event Candidate

When a log matches the criteria, it is added to an Event Candidate.

Event candidates let SmartEvent track logs until an event threshold is crossed, at which point
an event is generated.

Event Candidate 10.1.1.5

Product Security Product Enu:lpu::iint
Gatewsy Security
Action | reject Action | black
Ty firewall
Port B3 Port &4
Protocol | TCP Protocol | TCP
Source | 10.1.1.5 Source | 101.1.5
Endpoint Security
Product Security Product Galeway
Action block Action drop
Type fireswall
Port BO Part B3
Protocol | TCP Protocol | TCP
Source | 10.1.1.5 Source | 101.1.5

The logs can come from different log servers and be correlated in the same event.

The Event Candidate tracks logs until the criteria is matched (the criteria is the number of logs
in a declared number of seconds).

Each Event Definition can have multiple event candidates, each of which keeps track of logs
grouped by equivalent properties. In the figure above the logs that create the event candidate
have a common source value. They are dropped, blocked or rejected by a Security Gateway.
They are grouped together because the Event Definition is designed to detect this type of
activity that originates from one source. Depending on the event declaration, if there is a
grouping declaration on the source field, it will create a new event candidate.

When a log matches the event definition, but has properties different than those of the existing
event candidates, a new event candidate is created. This event candidate is added to what can
be thought of as the Event Candidate Pool.
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Event Candidate Pool

Event Candidate 10.1.1.5

Security Endpaoint
Product Gatsway Product Security
Action | reject Action | block

Type firewall

Paort a3 Paort a4
Protocol | TOP Protoeal | TCP
Source | 10.1.1.5 Source | 10115

Endpoint Sacurity
Product Security Product Gateway
Action | block Action | drop .
Type | firewal Log with Source 10.2.1.9
Port &0 Port 83 z
Protocol | TCP Protoel | TCP Product g:;:g
Source | 10.1.15 | | Source |10.1.1.5 Y

Action block

Type firewvall
_ Fort a1
New Event Candidate Pratocal | TGP

Sourca 10219

By default, SmartEvent creates a new event candidate for a log with a different source.
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To customize the default behavior:

—

2 e

. In SmartConsole, from the left navigation panel, click the Logs & Monitor view.

At the top, click + to open a new tab.
In the bottom section External Apps, click SmartEvent Settings & Policy.
Right-click an event > click Properties.
At the top, click the Count logs tab.
In the section The new even is triggered by, select the applicable option:
" asingle log
® multiple logs over a period of time
In the Accumulate additional logs that contain the same filed:
a. Click][...].
b. Inthe Event Definition Wizard window, select the required log fields and click OK.
Click the Advanced button:
a. Inthe Keep event open for field, enter the required number of seconds.
b. Inthe Update event data after field, enter the required number of seconds.

c. Click OK.

. Atthe top, click the Name tab.
10.
11.
12.
13.
14.

In the Name field, enter a different name.

Click Save as.

The modified event is saved in the folder Event policy > User Defined Events.
Click Menu > File > Save.

Click Menu > Actions > Install Event Policy.

R82 Logging and Monitoring Administration Guide | 148



To illustrate more, an event defined detects a high rate of blocked connections. SmartEvent
tracks the number of blocked connections for each Security Gateway, and the logs of the
blocked traffic at each Security Gateway forms an event candidate. When the threshold of

High Level Overview of Event Identification

blocked connection logs from a Security Gateway is surpassed, that Security Gateway event
candidate becomes an event. While this Event Definition creates one event candidate for each

Security Gateway monitored, other Event Definitions can create many more.

Event Candidate Poaol

Event Candidate 10.1.1.5

Event Candidate 10.3.1.5

Log 1
Endpaint

Product Security
Action block
Type firewall
Port 83
Frotocal | TOF
Sourca | =x-x=

The Event Candidate Pool is a dynamic environment, with new logs added and older logs
discarded when they have exceeded an Event Definition time threshold.

| Security Endpoint Endpolint
Product Gateway Product Sacurity Product Security
Action reject Action block Action block
Type firewall Type firewall
Post B3 Paort 84 Port a0
Protocol | TCP Protocal | TCP Protocal | TOP
Sourcea | 10115 Source | 10115 Sowurce | 10319
| Endpoint Sacurity
Product Security Product Gateway
Action block Action drop
Type firgwall
Paut BO Port 83
Protocol | TCP Protocol | TCP
Source [ 10.1.1.5 Source | 10115
|_ T
-

Event Candidate 10.2.1.9

Security Sacurity
Product Gateway Product Gateway
Action block Action | drop
firewsall Type
Port 81 FPort 83
Frotocol | TCP Protocol | TP
Sourca | 10219 Source | 10219
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Matching a Log Against Event Exclusion

Before SmartEvent generates logs for a specific event, it checks to see if this event candidate
attributes are listed in the exclusions table or not. Event Exclusions are defined on the Policy
tab > Event Policy > Event Exclusions according to the attributes selected.

If an attribute matches an Event Exclusion, it is discarded by the system (an event is not
generated). If not, the SmartEvent Correlation Unit starts to match it against each Event
Definition.

Event Generation

When a candidate becomes an event, the SmartEvent Correlation Unit forwards the event to
the Event Database. But to discover an event does not mean that SmartEvent stops to track
logs related to it. The SmartEvent Correlation Unit adds matching logs to the event as long as
they continue to arrive during the event threshold. To keep the event open condenses what
can appear as many instances of the same event to one, and provides accurate, up-to-date
information as to the start and end time of the event.

Modifying Event Definitions

SmartEvent constantly takes data from your Log Servers, and searches for patterns in all the
network chatter that enters your system.

Depending on the levels set in each Event Definition, the number of events detected can be
high. But only a portion of those events can be meaningful. You can change the thresholds and
other criteria of an event, to reduce the number of false alarms.
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Creating a User-Defined Event

To create New Event Definitions, right-click an existing Event Definition, or use the Actions

menu:

Menu
"Actions"

Description

New

Save As

New
Custom
Event

Save Event
As

Launches the Event Definition Wizard, which allows you to select
how to base the event: on an existing Event Definition, or from
scratch.

Creates an Event Definition based on the properties of the
highlighted Event Definition.

When you select Save As, the system prompts you to save the
selected Event Definition with a new name for later editing.
You can also access Save As from the Properties window.

All User Defined Events are saved at Policy tab > Event Policy > User Defined Events. When
an Event Definition exists it can be modified through the Properties window, available by right-
click and from the Actions menu.

Creating a New Event Definition

You can edit all events, not only user-defined events. If you change a predefined event,the
result is saved as a new user defined event.

To create a new event definition:

—

> DN

. In SmartConsole, from the left navigation panel, click the Logs & Monitor view.
At the top, click + to open a new tab.
In the bottom section External Apps, click SmartEvent Settings & Policy.

From the Menu > Actions menu, select New Custom Event.

The Event Definition Wizard opens.

5. Inthe Step 1 of 7 window:

a. Selectthat is based on an existing event.

b. Select an event that has equivalent properties to the event you want to create.

c. Click Next.

6. Inthe Step 2 of 7 window:
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a. Inthe Name field, enter a significant name.
b. Optional: In the Description field, enter a significant text.
c. Inthe Severity field, select the required level.
d. Click Next.
7. Inthe Step 3 of 7 window:
a. Slect the applicable option that generates the event:

® A single log - Frequently depicts an event, such as a log from a virus scanner
that reports that a virus has been found.

® Multiple logs - Required if the event can only be identified as a result of a
combination of multiple logs, such as a High Connection Rate.

b. Click Next.
8. Inthe Step 4 of 7 window:
a. Select the required products. You can add a new product name.
b. Click Next.
9. Inthe Step 5 of 7 window:
a. Select the applicable option:
= Edit all product filters
= Edit only newly selected product filters
b. Click Next.
10. Inthe Step 6.x of 7 windows:
a. Atthe top of this window, pay attention to the Product.
b. Inthe left panel Available Log Field, click the required field to select it.
c. Click Add to edit the filter.

d. Click Add to configure the required value for the selected field > enter the value >
click OK.

e. Inthe top right corner, you can select Not to negate the configured filter.

f. Click OK.

g. Intheright panel Match, select the required option - All Conditions or Any
Conditions.
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12.
13.
14.
15.

Creating a User-Defined Event

h. To edit an added Log field, double-click it.
i. Click Next.
In the Step 7 of 7 window:

a. Inthe fields Detect the event when at least ___ logs occurred over a period of ___
seconds, configure the required values.

b. The option Each event definition may have multiple Event Candidates existing
simultaneously controls whether SmartEvent creates distinct Event Candidates
based on a field (or set of fields) that you select below.

Select the field(s) by which distinct Event Candidates will be created allows you
to set the field (or set of fields) that are used to differentiate between Event
Candidates.

c. The option Use unique values of the __ field when counting logs directs
SmartEvent to count unique values of the specified field when determining whether
the Event Threshold has been surpassed. When this option is not selected,
SmartEvent counts the total number of logs received.

Click Finish.
The modified event is saved in the folder Event policy > User Defined Events.
Click Menu > File > Save.

Click Menu > Actions > Install Event Policy.
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Customizing a User-Defined Event

Customizing a user-defined event:

—

. In SmartConsole, from the left navigation panel, click the Logs & Monitor view.
. Atthe top, click + to open a new tab.

In the bottom section External Apps, click SmartEvent Settings & Policy.

> w0

In the folder Event Policy > User Defined Events, right-click a User-Defined Event and
click Properties.

5. Onthe Name tab:
a. Inthe Name field, enter a significant name.
b. Optional: In the Description field, enter a significant text.
c. Inthe Severity field, select the required level.
6. On the Filter tab:
a. Inthe left panel Event Products, select the required product.
b. Inthe middle panel Log Fields, select the required field.

If the necessary field does not appear, click Show more fields > click the
applicable option Existing field or New field > select the existing field or configure
the new field > click OK.

c. Click Add to configure the required value for the selected field > enter the value >
click OK.

d. Inthe top right corner, you can select Not to negate the configured filter.
e. Click OK.

f. In the right panel Match, select the required option - All Conditions or Any
Conditions.

g. Toeditan added Log field, double-click it.
h. Select if the filter matches on All Conditions or Any Conditions.
7. Onthe Count log tab:

a. Inthe fields Detect the event when at least ___ logs occurred over a period of ___
seconds, configure the required values.
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b. The option Each event definition may have multiple Event Candidates existing
simultaneously controls whether SmartEvent creates distinct Event Candidates
based on a field (or set of fields) that you select below.

Select the field(s) by which distinct Event Candidates will be created allows you
to set the field (or set of fields) that are used to differentiate between Event
Candidates.

c. The option Use unique values of the ___field when counting logs directs
SmartEvent to count unique values of the specified field when determining whether
the Event Threshold has been surpassed. When this option is not selected,
SmartEvent counts the total number of logs received.

d. Click the Advanced button:
i. Inthe Keep event open for field, enter the required number of seconds.
ii. Inthe Update event data after field, enter the required number of seconds.
jii. Click OK.
8. On the Event Format tab:

When an event is generated, information about the event is presented in the Event
Detail pane.

On this page you can specify if the information will be added to the detailed pane and
from which Log Field the information is taken.

You can clear it in the Display column. The Event Field will not be populated.
9. Onthe GUI representation tab:

a. Select the Threshold section option to show the number of logs that must matched
to create the event. This is usually not shown for one log events and shown for
multiple log events.

b. Select the Exclude section option to specify the log fields that appear when you
add an event exclusion.

c. Select the Exception section option to specify the log fields that appear when you
add an event exception.

10. Click OK.
11. Click Menu > File > Save.

12. Click Menu > Actions > Install Event Policy.
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Eliminating False Positives

Services that Generate Events

Some types of services are characterized by a high quantity of traffic that can be misidentified
as events. These are examples of services and protocols that can potentially generate events:

® Software that does a routine scan of the network to make sure that everything runs
correctly. Configuration of SmartEvent to exclude this source from a scan event
eliminates a source of false positive events.

® High connection rate on a web server. Set SmartEvent to allow a higher connection rate
for each minute on a busy web server, or to exclude this source from a scan event.

Common Events by Service

The information in this table provides a list of server types where high activity is frequently
used.

To change the Event Policy, adjust event thresholds and add Exclusions for servers and
services.

You can decrease more the quantity of false positives detected.

Common events by service:

SNMP Scans IP sweep | Any Any SNMP-read Hosts that
from query other
internal hosts
network

DNS Scans IP sweep | DNS - DNS Inter-DNS

Servers from server servers
internal S updates
network

Denial of | High Any DNS DNS DNS

Service connectio server requests

(DoS) n rate on S and inter-
internal DNS
host on servers
service updates
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Category

Service

Eliminating False Positives

Reason

NIS
Servers

Anomalie
S

Anomalie
S

Anomalie
S

Scans

Denial of
Service
(DoS)

Anomalie
S

High
connectio
n rate
from
internal
network

High
connectio
n rate
from
internal
network
on
service

Abnormal
activity on
service

Port scan
from
internal
network

High
connectio
n rate on
internal
host on
service

High
connectio
n rate
from
internal
network

Any

Any

Any

NIS
server

Any

Any

Any

Any

Any

Any

NIS
server

Any

DNS

DNS

DNS

NIS

NIS

DNS
requests
and inter-
DNS
servers
updates

DNS
requests
and inter-
DNS
servers
updates

DNS
requests
and inter-
DNS
servers
updates

Multiple
NIS
queries

NIS
queries

NIS
queries
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LDAP
Servers

Category

Anomalie
S

Anomalie
S

Denial of
Service
(DoS)

Anomalie
S

Anomalie
S

Anomalie
S

High
connectio
n rate
from
internal
network
on
service

Abnormal
activity on
service

High
connectio
n rate on
internal
host on
service

High
connectio
n rate
from
internal
network

High
connectio
n rate
from
internal
network
on
service

Abnormal
activity on
service

Any

Any

Any

Any

Any

Any

Any

Any

LDAP
server

LDAP
server

LDAP
server

LDAP
server

Service

NIS

NIS

LDAP

LDAP

LDAP

LDAP

Reason

NIS
queries

NIS
queries

LDAP
requests

LDAP
requests

LDAP
requests

LDAP
requests

Eliminating False Positives
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Eliminating False Positives

Service

Reason

HTTP
Proxy
Servers
- Hosts
To
Proxy
Server

HTTP
Proxy
Servers
-Outto
the Web

Denial of
Service
(DoS)

Anomalie
S

Anomalie
S

Anomalie
S

Scans

Denial of

Service
(DoS)

High
connectio
n rate on
internal
host on
service

High
connectio
n rate
from
internal
network

High
connectio
n rate
from
internal
hosts on
service

Abnormal
activity on
service

IP sweep
from
internal
network

High
connectio
n rate on
internal
host on
service

Any

Any

Any

Any

Proxy
server

Proxy
server

Proxy
server

Proxy
server

Proxy
server

Proxy
server

Any

Any

HTTP:8080

HTTP:8080

HTTP:8080

HTTP:8080

HTTP/HTTPS

HTTP/ HTTPS

Hosts
connection
s to Proxy
servers

Hosts
connection
s to Proxy
servers

Hosts
connection
s to Proxy
servers

Hosts
connection
s to Proxy
servers

Proxy
servers
connection
soutto
various
sites

Proxy
servers
connection
soutto
various
sites
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Service

Reason

UFP
Servers

Anomalie
S

Anomalie
S

Denial of
Service
(DoS)

Anomalie
S

Anomalie
S

High
connectio
n rate
from
internal
network

High
connectio
n rate
from
internal
hosts on
service

Abnormal
activity on
service

High
connectio
n rate on
internal
host on
service

High
connectio
n rate
from
internal
network

High
connectio
n rate
from
internal
hosts on
service

Proxy
server

Proxy

server

Proxy

server

Any

Any

Any

Any

Any

Any

UFP
server

UFP
server

UFP
server

HTTP/HTTPS

HTTP/HTTPS

HTTP/HTTPS

Any/UFP by vendor

Any/UFP by vendor

Any/UFP by vendor

Proxy
servers
connection
soutto
various
sites

Proxy
servers
connection
soutto
various
sites

Proxy
servers
connection
soutto
various
sites

Firewall
connection
sto UFP
servers

Firewall
connection
sto UFP
servers

Firewall
connection
sto UFP
servers
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Eliminating False Positives

Service

Reason

CVP
Servers
Request

CVP
Servers
Replies

Anomalie
S

Denial of
Service
(DoS)

Anomalie
S

Anomalie
S

Anomalie
S

Scans

Scans

Abnormal
activity on
service

High
connectio
n rate on
internal
host on
service

High
connectio
n rate
from
internal
network

High
connectio
n rate
from
internal
hosts on
service

Abnormal
activity on
service

Port
scans
from
internal
network

IP sweep
from
internal
network

Any

Any

Any

Any

Any

CVvP
server

CVvP
server

UFP
server

CVP
server

CVP
server

CVP
server

CVvP
server

Any

Any/UFP by vendor

Any/CVP by vendor

Any/CVP by vendor

Any/CVP by vendor

Any/CVP by vendor

CVP

Firewall
connection
sto UFP
servers

Firewall
connection
sto CVP
servers

Firewall
connection
sto CVP
servers

Firewall
connection
sto CVP
servers

Firewall
connection
sto CVP
servers

Multiple
CVvP
replies to
same GW

CVP
replies to
multiple
GWs
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Eliminating False Positives

Service

Reason

UA
Server
Request

Denial of
Service
(DoS)

Anomalie
S

Anomalie
S

Anomalie
S

Denial of
Service
(DoS)

Anomalie
S

High
connectio
n rate on
internal
host on
service

High
connectio
n rate
from
internal
network

High
connectio
nrate
from
internal
hosts on
service

Abnormal
activity on
service

High
connectio
n rate on
internal
host on
service

High
connectio
n rate
from
internal
network

CVvP Any

server

S

CVP Any

server

S

CVP Any

server

S

CVP Any

server

S

Any UA
server
S

Any UA
server
S

Any/CVP by vendor

Any/CVP by vendor

Any/CVP by vendor

Any/CVP by vendor

uas-port
(TCP:19191
TCP:19194)

(TCP:19191
TCP:19194)

CVP
replies

CVP
replies

CVP
replies

CVP
replies

Connectio
ns to UA
servers

Connectio
ns to UA
servers
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Eliminating False Positives

Service

Reason

UA
Servers
Replies

Anomalie
S

Anomalie
S

Scans

Scans

Denial of
Service
(DoS)

Anomalie
S

Anomalie
S

High
connectio
n rate
from
internal
hosts on
service

Abnormal
activity on
service

Port
scans
from
internal
network

IP sweep
from
internal
network

High
connectio
n rate on
internal
host on
service

High
connectio
n rate
from
internal
network

High
connectio
nrate
from
internal
hosts on
service

Any UA
server
s

Any UA
server
S

UA Any

server

s

UA Any

server

S

UA Any

server

s

UA Any

server

s

UA Any

server

s

uas-port
(TCP:19191
TCP:19194)

uas-port
(TCP:19191
TCP:19194)

uas-port
(TCP:19191
TCP:19194)

uas-port
(TCP:19191
TCP:19194)

uas-port
(TCP:19191
TCP:19194)

uas-port
(TCP:19191
TCP:19194)

Connectio
ns to UA
servers

Connectio
ns to UA
servers

Multiple
UA replies
to the
same
computer

Multiple

UA replies
to multiple
computers

UA replies

UA replies

UA replies
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Category

Eliminating False Positives

Service

Reason

SMTP
Servers

Anomalie
S

Scans

Denial of
Service
(DoS)

Anomalie
S

Anomalie
S

Anomalie
S

Abnormal
activity on
service

IP sweep
from
internal
network

High
connectio
n rate on
internal
host on
service

High
connectio
n rate
from
internal
network

High
connectio
n rate
from
internal
hosts on
service

Abnormal
activity on
service

UA
server

SMTP
server

SMTP
server

SMTP
server

SMTP
server

SMTP
server

Any

Any

Any

Any

Any

uas-port
(TCP:19191TCP:19
194)

SMTP

SMTP

SMTP

SMTP

SMTP

UA replies

SMTP
servers
connection
soutto
various
SMTP
servers

SMTP
servers
connection
soutto
various
SMTP
servers

SMTP
servers
connection
soutto
various
SMTP
servers

SMTP
servers
connection
soutto
various
SMTP
servers

SMTP
servers
connection
soutto
various
SMTP
servers
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Eliminating False Positives

Service

Reason

Anti-
Virus
Definitio
n
Servers

Scans

Denial of
Service
(DoS)

Anomalie
S

Anomalie
S

Anomalie
S

IP sweep
from
internal
network

High
connectio
n rate on
internal
host on
service

High
connectio
n rate
from
internal
network

High
connectio
n rate
from
internal
hosts on
service

Abnormal
activity on
service

AV _
Defs
server

AV _
Defs
server

AV _
Defs
server

AV _
Defs
server

AV _
Defs
server

Any/AV by vendor

Any/AV by vendor

Any/AV by vendor

Any/AV by vendor

Any/AV by vendor

Anti-Virus
definitions
updates
deploymen
t

Anti-Virus
definitions
updates
deploymen
t

Anti-Virus
definitions
updates
deploymen
t

Anti-Virus
definitions
updates
deploymen
t

Anti-Virus
definitions
updates
deploymen
t
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System Administration

To maintain your SmartEvent system, you can do these tasks from the General Settings
section of the Policy tab:

® Adding a SmartEvent Correlation Unit and Log Servers.

® Create offline jobs analyze historical log files (see "Importing Offline Log Files" on
page 50).

® Adding objects to the Internal Network.

® Creating scripts to run as Automatic Reactions for certain events (see “Creating an
Automatic Reaction "External Script™ on page 137).

® Creating objects for use in filters.

Adding a Host or Network Object to SmartEvent

Network Objects are the objects that are synchronized from the Management Server database
as well as user-defined additional objects. These objects from the Management Server are
added to SmartEvent during the initial sync and updated at set intervals.

Best Practice - Add new Host and Network objects in SmartConsole and not in
SmartEvent GUI.

—

. In SmartConsole, from the left navigation panel, click the Logs & Monitor view.
. Atthe top, click + to open a new tab.

In the bottom section External Apps, click SmartEvent Settings & Policy.
Click the folder General Settings > Objects > the object Network Objects.
Click Add > Host or Network.

o g~ W DN

Configure the object:
® For a Host object:
» Inthe Name field, enter a significant name.

You can enter a hostname if the SmartEvent Server can resolve this
hostname.

» Inthe IP Address field, enter the required host IP address.

If in the Name field, you entered a hostname, and the SmartEvent Server can
resolve this hostname, then you can click Get Address.

» Optional: In the Comment field, enter a significant text.
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® For a Network object:
» Inthe Name field, enter a significant name.
» Inthe Network Address field, enter the required network IP address.
» Inthe Net Mask field, enter the required network mask.
» Optional: In the Comment field, enter a significant text.
7. Click OK.
8. Click Menu > File > Save.

9. Click Menu > Actions > Install Event Policy.

Defining the Internal Network

Note - Some network objects are copied from the Management server to the
SmartEvent Server during the the initial sync and updated afterwards. You cannot
configure the internal network until the initial sync is complete.

To help SmartEvent conclude if events originated internally or externally, you must define the
Internal Network.

The Internal Network defines hosts, networks, or groups that are part of the network behind the
organization's perimeter.

These are the options to calculate the traffic direction:
® |ncoming - All the sources are external to the network and all destinations are internal.
® Qutgoing - All sources are in the network and all destinations are external.
® |nternal - Sources and destinations are all in the network.

® QOther - A mixture of internal and external values makes the result indeterminate.

To define the Internal Network:
1. In SmartConsole, from the left navigation panel, click the Logs & Monitor view.
2. Atthe top, click + to open a new tab.
3. Inthe bottom section External Apps, click SmartEvent Settings & Policy.
4. Click the folder General Settings > Initial Settings > the object Internal Network.
5

. Inthe left panel Not in Internal Network, select one or more relevant objects (press and
hold the CTRL key).

We recommend you add all internal Network objects, and not Host objects.

6. Click Add.
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. Inthe right panel In Internal Network, you can click Add New to add a new Host or
Network object.

See "Adding a Host or Network Object to SmartEvent" on page 166.

. Click Menu > File > Save.

. Click Menu > Actions > Install Event Policy.
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Monitoring Traffic and Connections

SmartView Monitor gives you a complete picture of network and security performance. Use it
to respond quickly and efficiently to changes in Security Gateways, tunnels, remote users and
traffic flow patterns or security activities.

SmartView Monitor is a high-performance network and security analysis system. This system
helps you to establish work habits based on learned system resource patterns. Based on
Check Point Security Management Architecture, SmartView Monitor provides a single, central
interface, to monitor network activity and performance of Check Point Software Blades.

How SmartView Monitor Works

Data for the status of all Security Gateways in the system is collected by the Security
Management Server and viewed in SmartView Monitor.

The data shows status for:
® Check Point Security Gateways
® OPSEC Gateways
® Check Point Software Blades

Gateway Status is the SmartView Monitor view, which shows all component status
information.

A Gateway Status view shows a snapshot of all Software Blades, such as VPN and
ClusterXL, and third party products (for example, OPSEC Gateways).

Gateway Status is similar in operation to the SNMP daemon that provides a mechanism to get
data about Gateways in the system.
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SIC is initialized between Security Gateways (3) (local and remote), and the Security
Management Server (2). The Security Management Server then gets status data from the
Software Blades with the AMON (Application Monitoring) protocol. SmartView Monitor (1) gets
the data from the Security Management Server.

AMON Protocol Support

The Security Management Server acts as an AMON client. It collects data about installed
Software Blades. Each Security Gateway, or any other OPSEC Gateway, which runs an
AMON server, acts as the AMON server itself. The Gateway requests status updates from
other components, such as the Firewall kernel and network servers. Requests are fetched at a
defined interval.

An alternate source for status collection can be any AMON client, such as an OPSEC partner,
which uses the AMON protocol.

The AMON protocol is SIC-based. It can collect data only after SIC is initialized.

Defining Status Fetch Frequency

The Security Management Server collects status data from the Security Gateways on a
defined interval. The default is 60 seconds.

To set the Status Fetching Interval:
1. Open SmartConsole.
2. Open Global Properties > Log and Alert > Time Settings.

3. Enter the number of seconds in Status fetching interval.
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To Start Monitoring

To open the monitoring views in SmartConsole:
1. From the Gateways & Servers view, select a Security Gateway.
2. Click Monitor.
The Device and License information window opens and shows:
® Device Status
® |icense Status
® System Counters

® Traffic

To open SmartView Monitor:
1. Open SmartConsole > Logs & Events.
2. Open the catalog (new tab).
3. Click Tunnel & User Monitoring.

Note - SmartView Monitor may fail to open if there are more than 15,000 objects
configured in the management database on the Management Server.
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SmartView Monitor Features

SmartView Monitor allows administrators to easily configure and monitor different aspects of
network activities. You can see graphical from an integrated, intuitive interface.

Defined views include the most frequently used traffic, counter, tunnel, Security Gateway, and
remote user information. For example, Check Point System Counters collect information on
the status and activities of Check Point products (for example, VPN or NAT). With custom or
defined views, administrators can drill-down the status of a specified Security Gateway and/or
a segment of traffic. That way, administrators identify top bandwidth hosts that can influence
network performance. If suspicious activity is detected, administrators can immediately apply a
Firewall rule to the applicable Security Gateway to block that activity. These Firewall rules can
be created dynamically through the graphical interface and be set to expire in a specified time
period.

You can generate Real-time and historical graphical reports of monitored events. This
provides a comprehensive view of Security Gateways, tunnels, remote users, network,
security, and performance over time.

The monitoring views show real-time and historical graphical views of:
® Gateway status

® Remote users (SmartView Monitor only)

System Counters

VPN tunnel monitoring (SmartView Monitor only)

® Cooperative Enforcement, for Endpoint Security Servers

Traffic

In SmartView Monitor, you can create customized monitoring view.

SmartView Monitor Use Cases

Use SmartView Monitor to:

® Create a Traffic view and report to identify the reasons for slow internet access. The view
can be based on an inspection of: Specific Services, Firewall rules or Network Objects,
that can be known to impede the flow of internet traffic. If the SmartView Monitor Traffic
view indicates that users aggressively use such Services or Network Objects (for
example, Peer to Peer application or HTTP), the cause of the slow internet access is
determined. If aggressive use is not the cause, the network administrator have to look at
other avenues. For instance, performance degradation can be the result of memory
overload.
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® Create a report to determine why employees who work away from the office cannot
connect to the network. The view can be based on CPU Use %, to collect information
about the status, activities hardware and software use of Check Point products in real-
time. The SmartView Monitor Counter view can indicate that there are more failures than
successes. Perhaps the company cannot accommodate the number of employees that
try to log on at the same time?
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Immediate Actions

If the status shows an issue, you can act on that network object.
For example:
® Disconnect client - Disconnect one or more of the connected SmartConsole clients.

® Start/Stop cluster member - You can see all Cluster Members of a Cluster in SmartView
Monitor. You can start or stop a selected Cluster Member.

® Suspicious Action Rules - You can block suspicious network activity while you
investigate the real risk or to quickly block an obvious intruder.
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Monitoring and Handling Alerts

Alerts provide real-time information about possible security threats, and how to avoid,
minimize, or recover from the damage. The administrator can define alerts to be sent for
different Security Gateways and for certain policies or properties.

The Security Gateways send alerts to the Security Management Server. The Security
Management Server forwards these alerts to SmartView Monitor. By default, an alert is sent as
a pop-up message to the administrator desktop when a new alert arrives to SmartView
Monitor.

You can set global alert parameters for all Security Gateways in the system, or specify an
action to send an alert for a particular Security Gateway.

Alerts are sent when:

® Rules or attributes which are set to be tracked as alerts are matched by a passing
connection.

® System events (also called System Alerts) are configured to cause an alert when
different predefined thresholds are surpassed.

System Alerts are sent for predefined system events or for important situation updates. For
example, if free disk space is less than 10%, or if a security policy is changed. System Alerts
can also be defined for each product. For example, you can define other System Alerts for
Check Point QoS.

Viewing Alerts
Alert commands are set in SmartConsole > Global Properties > Log and Alert > Alerts page.
The Alerts in this window apply only to Security Gateways.
To see alerts:

1. Open SmartConsole > Logs & Events view > External Apps.

2. Click Tunnel & User Monitoring.

SmartView Monitor opens.
3. Click the Alerts icon in the toolbar.

The Alerts window opens. Use this window to monitor or delete alerts.

System Alert Monitoring Mechanism

The Check Point Security Management Server System Alert monitoring mechanism uses the
defined System Alert thresholds. If a threshold is reached, it activates the defined action.
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To activate System Alert monitoring:

Go to Tools > Start System Alert Daemon.

To stop the System Alert monitoring:

Go to Tools > Stop System Alert Daemon.
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Monitoring Suspicious Activity Rules

Suspicious Activity Monitoring (SAM) is a utility integrated in SmartView Monitor. It blocks
activities that you see in the SmartView Monitor results and that appear to be suspicious. For
example, you can block a user who tries several times to gain unauthorized access to a
network or internet resource.

A Security Gateway with SAM enabled has Firewall rules to block suspicious connections that
are not restricted by the security policy. These rules are applied immediately (policy
installation is not required).

The Need for Suspicious Activity Rules

Connections between enterprise and public networks are a security challenge as they leave
the network and its applications open to attack. You must be able to inspect and identify all
inbound and outbound network activity and decide if it is suspicious.

Creating a Suspicious Activity Rule

SAM rules use CPU resources. Therefore, set an expiration time so you can inspect traffic but
not negatively affect performance.

If you confirm that an activity is risky, edit the Security Policy, educate users, or handle the risk.

You can block suspicious activity based on source, destination, or service.

To block an activity:
1. In the SmartView Monitor, click the Suspicious Activity Rules icon in the toolbar.
The Enforced Suspicious Activity Rules window opens.
2. Click Add.
The Block Suspicious Activity window opens.
3. In Source and in Destination, select IP or Network:
® To block all sources or destinations that match the other parameters, enter Any.

® To block one suspicious source or destination, enter an IP Address and Network
Mask.

4. In Service:
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6.

Monitoring Suspicious Activity Rules

® To block all connections that fit the other parameters, enter Any.

® To block one suspicious service or protocol, click the button and select a service
from the window that opens.

In Expiration, set a time limit.

Click Enforce.

To create an activity rule based on TCP or UDP use:

1.

a &> b

In the Block Suspicious Activity window , click Service.
The Select Service window opens.

Click Custom Service.

Select TCP or UDP.

Enter the port number.

Click OK.

To define SmartView Monitor actions on rule match:

1.

5.

In the Block Suspicious Activity window, click Advanced.

The Advanced window opens.

In Action, select the Firewall action for SmartView Monitor to do on rule match:
® Notify - Send a message about the activity, but do not block it.
® Drop - Drop packets, but do not send a response. The connection will time out.
® Reject - Send an RST packet to the source and close the connection.

In Track, select No Log, Log or Alert.

If the action is Drop: To close the connection immediately on rule match, select Close
connections.

Click OK.

Creating a Suspicious Activity Rule from Results

If you monitor traffic, and see a suspicious result, you can create an SAM rule immediately
from the results.

Note - You can only create a Suspicious Activity rule for Traffic views with data about the
Source or Destination (Top Sources, Top P2P Users, and so on).
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To create an SAM rule:
1. In SmartView Monitor open a Traffic view.
The Select Gateway / Interface window opens.
2. Select an object.
3. Click OK.

4. Inthe Results, right-click the bar in the chart (or the row in the report), that represents the
source, destination, or other traffic property to block.

5. Select Block Source.
The Block Suspicious Activity window opens.
6. Create the rule.

7. Click Enforce.

For example:

Your corporate policy does not allow to share peer2peer file, and you see it in the Traffic > Top
P2P Users results.

1. Right-click the result bar and select Block Source.

The SAM rule is set up automatically with the user IP address and the P2P_File_
Sharing_Applications service.

2. Click Enforce.

3. Forthe next hour, while this traffic is dropped and logged, contact the user.

Managing Suspicious Activity Rules

The Enforced Suspicious Activity Rules window shows the currently enforced rules. If you
add a rule that conflicts with another rule, the conflicting rule remains hidden. For example, if
you define a rule to drop http traffic, and a rule exists to reject http traffic, only the drop rule
shows.

sam_alert

Description

For SAM v1, this utility executes Suspicious Activity Monitoring (SAM) actions according to the
information received from the standard input.

For SAM v2, this utility executes Suspicious Activity Monitoring (SAM) actions with User
Defined Alerts mechanism.
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For more information, see the R82 CLI Reference Guide - Chapter Security Management
Server Commands - Section sam_alert.
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Configuring Alerts and Thresholds in SmartView
Monitor

System Alerts and Thresholds

You can set thresholds for selected Security Gateways. When a threshold is passed, a system
alertis sent.

To set System Alert thresholds:
1. Open Gateways Status view.
2. Right-click a network object and select Configure Thresholds.
The Threshold Settings window opens.
3. Set the thresholds for the selected object:
= Use global settings - All objects get the same thresholds for system alerts.

® None - The selected Security Gateway object does not have thresholds for system
alerts.

® Custom - Change the thresholds for the selected object to be different than the
global settings.

To change Global Threshold settings:
1. Inthe Threshold Settings window, click Edit Global Settings.

The Global Threshold Settings window opens.
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Global Th

Enabled
v

<9 E (S E e

reshold Settings:

Threshold

CPU usage

Free disk space
Status connection
Firewall Policy
Firewall Policy install time
Firewall Policy name
Synchronization state
QoS Policy

Qo5 Policy install time
QoS Policy name

System Alert Daemon is; Inactive

Operator
more than
less than
not
equal
changed
changed
equal
equal
changed
changed

Value Action
- 50% alert
- | 15% alert
= | connected alert
=~ | not installed alert
- alert
5 alert
= | not synchronized alert
- | not installed alert
= alert
- alert

Product
System
System
System
Firewall
Firewvall
Firewvall
Security Management Ser...
QoS
QoS
QoS

oK

l | Cancel | |

Help

2. Select thresholds.

3.

In Action, select:

® none - No alert.

log - Sends a log entry to the database.

alert - Opens a pop-up window to your desktop.

mail - Sends a mail alert to your Inbox.

snmptrap - Sends an SNMP alert.

useralert - Runs a script. Make sure a user-defined action is available (in
SmartConsole, click Menu > Global properties > Log and Alert > Alert

Commands).

To change custom threshold settings:

1.

In the Threshold Settings window, select Custom.

The global threshold settings show.

Select thresholds to enable for this Security Gateway or Cluster Member.

Set defining values.

R82 Logging and Monitoring Administration Guide

182



Configuring Alerts and Thresholds in SmartView Monitor

Working with SNMP Monitoring Thresholds

You can configure a variety of different SNMP thresholds that generate SNMP traps, or alerts.
You can use these thresholds to monitor many system components automatically without
requesting information from each object or device. The categories of thresholds that you can
configure include:

® Hardware

" High Availability

Networking
® Resources
® | og Server Connectivity
Some categories apply only to some machines or deployments.

In each category there are many individual thresholds that you can set. For example, the
hardware category includes alerts for the state of the RAID disk, the state of the temperature
sensor, the state of the fan speed sensor, and others. For each individual threshold, you can
configure:

® [fitis enabled or disabled
® How frequently alerts are sent

® The severity of the alert

The threshold point (if necessary)

Where the alerts are sent to

You can also configure some settings globally, such as how often alerts are send and where
they are sent to.

Types of Alerts

® Active alerts are sent when a threshold point is passed or the status of a monitored
component is problematic.

® Clear alerts are sent when the problem is resolved and the component has returned to its
normal value. Clear alerts look like active alerts but the severity is set to 0.
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Configuring SNMP Monitoring Thresholds

Configure the SNMP monitoring thresholds in the command line of the Security Management
Server. When you install the policy on the Security Gateways. the SNMP monitoring
thresholds are applied globally to these Security Gateway.

Configuring SNMP thresholds on a Multi-Domain Server

In a Multi-Domain Security Management environment, you can configure thresholds on the
Multi-Domain Server and on each individual Domain Management Server.

Thresholds that you configure on the Multi-Domain Server level are for the Multi-Domain
Server only.

Thresholds that you configure for a Domain Management Server are for that Domain
Management Server and its managed Security Gateways. If a threshold applies to the Multi-
Domain Server and the Security Gateways managed by the Domain Management Server, set
it on the Multi-Domain Server and Domain Management Server. But in this situation you can
only get alerts from the Multi-Domain Server if the threshold passed.

For example, because the Multi-Domain Server and Domain Management Server are on the
same machine, if the CPU threshold is passed, it applies to both of them. But only the Multi-
Domain Server generates alerts.

You can see the Multi-Domain Security Management level for each threshold with the
"threshold config"command.

® |f the Multi-Domain Security Management level for a threshold is Multi-Domain Server:
Alerts are generated for the Multi-Domain Server when the threshold point is passed.

® |f the Multi-Domain Security Management level for a threshold is Multi-Domain Server
and Domain Management Server:

Alerts are generated for the Multi-Domain Server and Domain Management Servers
separately when the threshold point is passed.
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Configuring a SNMP thresholds on Security Gateways

You can configure SNMP thresholds locally on a Security Gateway with the same procedure
that you do on a Security Management Server. But each time you install a policy on the
Security Gateway, the local settings are erased and it reverts to the global SNMP threshold
settings.

You can use the "threshold config" command to save the configuration file and load it
again later.

The configuration file that you can back up is: SFWDIR/conf/thresholds.conf

For more information about the "threshold config"command, see the R82 CLI Reference

Guide.

Configuration Procedures

There is one primary command to configure the thresholds in the command line -
threshold config.

You must be in the Expert mode to run it.

After you runthe threshold configcommand, follow the on-screen instructions to make
selections and configure the global settings and each threshold.

When you run threshold config, you getthese options:
® Show policy name - Shows you the hame configured for the threshold policy.
® Set policy name - Lets you set a name for the threshold policy.
® Save policy - Lets you save the policy.
® Save policy to file - Lets you export the policy to a file.
® | oad policy from file - Lets you import a threshold policy from a file.

® Configure global alert settings - Lets you configure global settings for how frequently
alerts are sent and how many alerts are sent.

= Configure alert destinations - Lets you configure a location or locations where the
SNMP alerts are sent.

® View thresholds overview - Shows a list of all thresholds that you can set including: the
category of the threshold, if it is active or disabled, the threshold point (if relevant), and a
short description of what it monitors.

® Configure thresholds - Opens the list of threshold categories to let you select thresholds
to configure.
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Configure Global Alert Settings

If you select Configure global alert settings, you can configure global settings for how
frequently alerts are sent and how many alerts are sent. You can configure these settings for
each threshold. If a threshold does not have its own alert settings, it uses the global settings by
default.

You can configure these options:

= Enter Alert Repetitions - How many alerts are sent when an active alert is triggered. If
you enter 0, alerts are sent until the problem is fixed.

= Enter Alert Repetitions Delay - How long the system waits between it sends active
alerts.

= Enter Clear Alert Repetitions - How many clear alerts are sent after a threshold returns
to a regular value.

= Enter Clear Alert Repetitions Delay - How long the system waits between it sends clear
alerts.

Configure Alert Destinations

If you select Configure Alert Destinations, you can add and remove destinations for where the
alerts are sent. You can see a list of the configured destinations. A destination is usually an
NMS (Network Management System) or a Check Point Log Server.

After you enter the details for a destination, the CLI asks if the destination applies to all
thresholds.

® |f you enter yes, alerts for all thresholds are sent to that destination, unless you remove
the destination from an individual threshold.

® |f you enter no, no alerts are sent to that destination by default. But for each individual
threshold, you can configure the destinations and you can add destinations that were not
applied to all thresholds.
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For each threshold, you can choose to which of the alert destinations its alerts are sent. If you
do not define alert destination settings for a threshold, it sends alerts to all of the destinations
that you applied to all thresholds.

For each alert destination enter:

® Name - An identifying name.

IP - The IP address of the destination.

® Port - Through which port it is accessed

Ver - The version on SNMP that it uses

Other data - Some versions of SNMP require more data. Enter the data that is supplied
for that SNMP version.

Configure Thresholds

If you select Configure thresholds, you see a list of the categories of thresholds, including:

® Hardware

High Availability

Networking

Resources

® | og Server Connectivity
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Some categories apply only to some machines or deployments. For example, Hardware
applies only to Check Point appliances and High Availability applies only to clusters or High
Availability deployments.

Select a category to see the thresholds in it. Each threshold can have these options:

= Enable/Disable Threshold - If the threshold is enabled, the system sends alerts when
there is a problem. If it is disabled it does not generate alerts.

® Set Severity - You can give each threshold a severity setting. The options are: Low,
Medium, High, and Critical. The severity level shows in the alerts and in SmartView
Monitor. It lets you know quickly how important the alert is.

® Set Repetitions - Set how frequently and how many alerts will be sent when the
threshold is passed. If you do not configure this, it uses the global alert settings.

® Set Threshold Point - Enter the value that will cause active alerts when it is passed.
Enter the number only, without a unit of measurement.

= Configure Alert Destinations - See all of the configured alert destinations. By default,
active alerts and clear alerts are sent to the destinations. You can change this for each
destination. When you select the destination you see these options

+ Remove from destinations - If you select this, alerts for this threshold are not sent
to the selected destination.

» Add a destination - If you configured a destination in the global alert destinations
but did not apply it to all thresholds, you can add it to the threshold.

* Disable clear alerts - Cleared alerts for this threshold are not sent to the selected
destination. Active alerts are sent.

Completing the Configuration

1. On the Security Management Server, install the policy on all Security Gateways.

2. Foralocal Security Gateway threshold policy or a Multi-Domain Server environment,
restart the CPD process:

a. Run:

cpwd admin stop -name CPD -path "SCPDIR/bin/cpd admin" -
command "cpd admin stop"

b. Run:

cpwd admin start -name CPD -path "$CPDIR/bin/cpd" -
command "cpd"
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Monitoring SNMP Thresholds

You can see an overview of the SNMP thresholds that you configure in SmartView Monitor.

To see an overview of the SNMP thresholds:

1.
2.

Open SmartView Monitor and select a Security Gateway.

In the summary of the Security Gateway data that open in the bottom pane, click System
Information.

In the new pane that opens, click Thresholds.

In the pane that opens, you can see these details:

® General Info - A summary of the SNMP Threshold policy.

Policy name - The name that you set for the policy in the CLI.
State - If the policy is enabled or disabled.

Thresholds - How many thresholds are enabled.

Active events - How many thresholds are currently sending alerts.

Generated Events - How many not active thresholds became active since
the policy was installed.

® Active Events - Details for the thresholds that are currently sending alerts.

Name - The name of the alert (given in the CLI).

Category - The category of the alert (given in the CLI), for example,
Hardware or Resources.

MIB object - The name of the object as recorded in the MIB file.

MIB object value - The value of the object when the threshold became
active, as recorded in the MIB file.

State - The status of the object: active or clearing (passed the threshold but
returns to usual value).

Severity - The severity of that threshold, as you configured for it in the CLI.

Activation time - When was the alert first sent.
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= Alert Destinations - A list of the destinations, to which alerts are sent.
 Name - The name of the location.
» Type - The type of location. For example, a Log Server or NMS.

» State - If logs are sent from the Security Gateway or Security Management
Server to the destination machine.

» Alert Count - How many alerts were sent to the destination from when the
policy started.

® Errors - Shows thresholds that cannot be monitored.

For example, the Security Gateway cannot monitor RAID sensors on a machine
that does not have RAID sensors. Therefore, it shows an error for the RAID Sensor
Threshold.

e Threshold Name - The name of the threshold with an error.
» Error - A description of the error.

o Time of Error - When the error first occurred.

Customizing Results

You can create Custom Views, to change the fields that show in the results.

Editing a Custom View

The changes you make to a view are not automatically saved. You can use this procedure to
save a predefined view as a new Custom view.

To save a new view with changes:

1.

N o o &~ 0 b

Right-click the results of the view and select Properties.

Note - For some of the views, this option is View Properties or Query Properties.
Add or remove fields and other options for the view.

Click OK.

For some of the views, select the Security Gateway.

In the Results toolbar, click the Save View to Tree button.

In the window that opens, enter a name for the new view.

Click Save.
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Creating a Custom Gateway Status View

To create a custom Gateway status view:
1. Inthe Tree, right-click Custom and select New Gateways View.
The Gateway Properties window opens.
In Select available fields from, select the source of the data.
In Available fields, double-click the data to add to SmartView Monitor.
Open the Filter Gateways tab to remove Security Gateways from the results of this view.
Click OK.

Right-click the new Custom view and select Rename.

N o oA N

Enter a name for the view.

Creating a Custom Traffic View

To creating a custom traffic view:
1. Inthe Tree, right-click Custom and select New Traffic View.
The Query Properties window opens.
2. Select History or Real Time.

3. Ifyou select Real Time, select what you want to see

® |nterfaces

® Services

®= |Ps/ Network Objects
® QoS Rules

® Security Rules

® Connections

® Tunnels

® Virtual Links

® Packet Size Distribution

4. Select the Target Security Gateway.
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® |f you often need results for on Security Gateway, select it in Specific Gateway.

® |f you have a small number of Security Gateways, you can create a custom view for
each one.

® |f not, select Prompt for Gateway before run.
5. Open the next tabs.
The tabs that show depend on the Query Type you selected.

® |f you select History, the next tab is Traffic History, where you select the Time
Frame and type of report.

® |f you select Real Time, the next tabs let you set services or objects to monitor,
Security Gateways or specified IP addresses to monitor, update interval, result
type, and chart settings.

6. Click Save.
7. Right-click the new Custom view and select Rename.

8. Enter a name for the view.

Creating a Custom Counters View

To create a custom counters view:
1. Inthe Tree, right-click Custom and select New Counters View.
The Query Properties window opens.
2. Select History or Real Time.
3. Select the Target Security Gateway.

® |f results for one Security Gateway are frequently necessary, select it in Specific
Gateway.

® |f you have a small number of Security Gateways, you can create a custom view for
each one.

® |f not, select Prompt for Gateway before run.
4. Open the Counters tab.
5. Select a category and the counters to add.
You can add counters from different categories to one view.

6. Inthe Query Type:
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® |fthe Query Type is History: Select the Time Frame and click Save.
® |fthe Query Type is Real Time:
a. Open the Settings tab.
b. Setthe update interval and chart type.
c. Click Save.
Right-click the new Custom view and select Rename.

Enter a name for the view.

Creating a Custom Tunnel View

To create a custom tunnel view:

1.

© N o g &

©

11.
12.

In the SmartView Monitor client, select File > New > Tunnels View.
The Query Properties window shows.
Select Prompt on to generate a report about a specified Tunnel, Community or Gateway.

Prompt on: When you run the view, you will be asked for the specified Tunnel,
Community or Security Gateway, on which to base your view.

Important - Do not select Prompt on if your view is not about one of these three.
Select Show one record per tunnel or Show two records per tunnel.

Show two records per tunnel shows a more accurate status because the report
provides the status for the tunnels in both directions.

In the Show column, select the filter to be related to this view
In the Filter column, click the corresponding Any(*) link.
Select the related objects to edit the selected filters.

Click the Advanced button.

Set a limit in the Records limitation window for the number of lines that show in the
report.

Enter a record limitation.

. Click OK.

A Tunnels view shows in the Custom branch of the Tree View.
Enter the name of the new Tunnel view.

Click Enter.
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Creating a Custom Users View

To create a custom users view:

1.

o g &~ w

~

9.
10.

In SmartView Monitor, select File > New > Users View.

The Query Properties window shows.

. Select Prompt on to generate a user report about a specified user or Gateway.

Prompt on: When you decide to run the view, you will be asked for the specified User DN
or Security Gateway, on which to base your view.

Important - Do not select Prompt on if your view is not about one of these two.
In the Show column, select the filter to be related with this view.

In the Filter column, click the corresponding Any(*) link.

Select the related objects to edit the selected filters.

Click the Advanced button to set a limit (in the Records limitation window) to the number
of lines that show in the report.

Enter a record limitation.

Click OK.

A Users view shows in the Custom branch of the Tree View.
Enter a name for the new Users view.

Click Enter.

Custom View Example

For example purposes, we create a real-time Traffic view for Services.

To create a real-time traffic view:

1.

Double-click the view to change and select the Security Gateway, for which you create
the view.

. Select the View Properties button on the view toolbar.

The Query Properties window shows.
Select Real-Time.
Real-Time provides information about currently monitored traffic or system counters.

Select History for information that was logged before.
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14.

15.
16.
17.
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Select the topic about which you want to create a Real-Time traffic view in the drop-
down list provided. For example, for purposes select Services.

Note - The remaining tabs in the Query Properties window change according to the type
of view you create and the selection you made in the Real-Time drop-down list.

. Select the Target of this Custom Traffic view.

Target is the Security Gateway, for which you monitor traffic.
Click the Monitor by Services tab.

Select Specific Services and the Services for which you want to create a custom Traffic
view.

. Click the Filter tab.
10.
11.

Make the necessary selections.

Click the Settings tab.

Make the necessary selections.

Click OK when you are done with your selections.
The Select Gateway / Interface window shows.

Select the Security Gateway or interface, for which you want to create or run this new
view.

Click the Save to Tree button on the toolbar.
Enter a name for the new view.
Click OK.

The new view is saved in the Custom branch.

Exporting a Custom View

You can back up a custom view before you install an upgrade. You can share a custom view
with other SmartView Monitor GUI clients and other users.

To export a custom view:

1.
2.
3.

Right-click the view and select Export Properties.
In the window that opens, enter a pathname for the export file.
Click Save.

A file with an svm_setting extension is created.
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Setting Your Default View

You can set which view to see when SmartView Monitor starts.

In the Tree, right-click the view and select Run at Startup.

Refreshing Views

Results are automatically refreshed every 60 seconds.
To refresh the view earlier, right-click the view name in the Tree and select Run.

To refresh data about an object in the current view, right-click the object in the results and
select Refresh.
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Monitoring Device Status

The Gateways & Servers view in SmartConsole contains 6 views of the status of the Security
Management Server and all the devices it manages.

General - Provides general information about all devices.
Health - Provides information about the health or operational status of each device.

Traffic - Provides information about the volume of network traffic which passes through a
specific device

Access Control - Provides information about the Access Control blades and ldentity
Awareness information for each device.

Threat Prevention - Provides information about the Threat Prevention blades and policy
for each device.

Management - Provides information about the management blades for each device.

Licenses - Provides information about the licenses of the device and Software Blades
enabled on the device.

The General view is the default view. To change the view, go to the top-left corner of the
Gateways & Servers view > Columns, and from the drop-down menu, select the required

view.

Device Status

The status updates of a Security Gateway reflect the status of the Software Blades. For
example, if statuses of all the Software Blades are OK, except for the SmartEvent blade,
which has a Problem status, the overall status is Problem.

Status Icon Description

OK The device and all its Software Blades work properly.
< Attention At least one Software Blade has a minor issue, but the device works.
@ Problem At least one Software Blade reported a malfunction, or an enabled

Software Blade is not installed.

EZWaiting SmartView Monitor waits for the Security Management Server to send

data from Security Gateways.

¢ Disconnected | Cannot reach the device.

2 Untrusted Cannot make Secure Internal Communication between the Security

Management Server and the Security Gateway.
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Displaying Gateway Data

You can see detailed information about each Check Point Security Gateway or OPSEC
Gateway.

To see data about a specific gateway:

1.
2.

4.
5.

In SmartConsole, go to the Logs & Events view.

At the bottom section of the view, go to External Apps, and select Tunnel & User
Monitoring.

The Check Point SmartView Monitor opens.

Go to Gateway Status > Firewalls.

The Firewalls view displays general information about each Security Gateway.
For system information, click a specific gateway , and go to System Information.

For more information about a specific Software Blade, click the relevant Software Blade.

System Information

® CPU - The specific CPU parameters (for example, Idle, User, Kernel, and Total) for each

CPU.
Note - In the Gateways Results view the Average CPU indicates the average total CPU
usage of all existing CPOS.

Memory - The total amount of virtual memory, what percentage of this total is used. The
total amount of real memory, what percentage of this total is used, and the amount of real
memory available for use.

Disk - Shows all the disk partitions and their specific details (for example, capacity, used,
and free).

Note - In the Gateways Results view the percentage/total of free space in the hard disk
on which the Firewall is installed. For example, if there are two hard drives C and D and
the Firewall is on C, the Disk Free percentage represents the free space in C and not D.

To view the status of Check Point applications on the local server or another appliance, the
cpstat command. For more information, see the R82 CLI Reference Guide - Chapter
Security Gateway Commands - Section cpstat.

Firewall

= Security Policy Name and Installed On - The name of the Security Policy installed on

the Security Gateway, and the date and time that this policy was installed.

® Packets - The number of packets accepted, rejected, dropped and logged by the

Security Gateway.
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® UFP Cache performance - The hit ratio percentage and the total number of hits handled

by the cache, the number of connections inspected by the UFP Server.

® Hash Kernel Memory (the memory status) and System Kernel Memory (the OS

memory) - The total amount of memory allocated and used. The total amount of memory
blocks used. The number of memory allocations, and those allocation operations which
failed. The number of times that the memory allocation freed up, or failed to free up. The
NAT Cache, including the total amount of hits and misses.

Virtual Private Networks

The Virtual Private Networks (VPN) is divided into these main statuses:

® Current represents the current number of active output.

High Watermark represents the maximum number of current output

Accumulative data represents the total number of the output.

This includes:

Active Tunnels - All types of active VPN peers to which there is currently an open IPsec
tunnel. This is useful to track the activity level of the VPN Security Gateway. High
Watermark includes the maximum number of VPN peers for which there was an open
IPsec tunnel since the Security Gateway was restarted.

Remote Access - All types of Remote Access VPN users with which there is currently an
open IPsec tunnel. This is useful to track the activity level and load patterns of VPN
Security Gateways that serve as a remote access server. High Watermark includes the
maximum number of Remote Access VPN users with which there was an open IPsec
tunnel since the Security Gateway was restarted.

Tunnels Establishment Negotiation - The current rate of successful Phase | IKE
Negotiations (measured in Negotiations per second). This is useful to track the activity
level and load patterns of a VPN Gateway that serve as a remote access server. High
Watermark includes the highest rate of successful Phase | IKE Negotiations since the
Policy was installed (measured in Negotiations per second). Accumulative data includes
the total number of successful Phase | IKE negotiations since the Policy was installed.

Failed - The current failure rate of Phase | IKE Negotiations can be used to troubleshoot
(for instance, denial of service) or for a heavy load of VPN remote access connections.
High Watermark includes the highest rate of failed Phase | IKE negotiations since the
Policy was installed. Accumulative is the total number of failed Phase | IKE negotiations
since the Policy was installed.

Concurrent - The current number of concurrent IKE negotiations. This is useful to track
the behavior of VPN connection initiation, especially in large deployments of remote
access VPN scenarios. High Watermark includes the maximum number of concurrent
IKE negotiations since the Policy was installed.
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® Encrypted and Decrypted throughput - The current rate of encrypted or decrypted traffic
(measured in Mbps). Encrypted or decrypted throughput is useful (in conjunction with
encrypted or decrypted packet rate) to track VPN usage and VPN performance of the
Security Gateway. High Watermark includes the maximum rate of encrypted or
decrypted traffic (measured in Mbps) since the Security Gateway was restarted.
Accumulative includes the total encrypted or decrypted traffic since the Security
Gateway was restarted (measured in Mbps).

®= Encrypted and Decrypted packets - The current rate of encrypted or decrypted packets
(measured in packets per second). Encrypted or decrypted packet rate is useful (in
conjunction with encrypted/decrypted throughput) to track VPN usage and VPN
performance of the Security Gateway. High Watermark includes the maximum rate of
encrypted or decrypted packets since the Security Gateway was restarted, and
Accumulative, the total number of encrypted packets since the Security Gateway was
restarted.

® Encryption and Decryption errors - The current rate at which errors are encountered by
the Security Gateway (measured in errors per second). This is useful to troubleshoot
VPN connectivity issues. High Watermark includes the maximum rate at which errors are
encountered by the Security Gateway (measured in errors per second) since the
Security Gateway was restarted, and the total number of errors encountered by the
Security Gateway since the Security Gateway was restarted.

® Hardware - The name of the VPN Accelerator Vendor, and the status of the Accelerator.
General errors such as the current rate at which VPN Accelerator general errors are
encountered by the Security Gateway (measured in errors per second). The High
Watermark includes the maximum rate at which VPN Accelerator general errors are
encountered by the Security Gateway (measured in errors per second) since the
Security Gateway was restarted. The total number of VPN Accelerator general errors
encountered by the Security Gateway since it was restarted.

= |P Compression - Compressed/Decompressed packets statistics and errors.

QoS

® Policy information - The nhame of the QoS Policy and the date and time that it was
installed.

® Number of interfaces - The number of interfaces on the Check Point QoS Security
Gateway. Information about the interfaces applies to both inbound and outbound traffic.
This includes the maximum and average amount of bytes that pass per second, and the
total number of conversations. Conversations are active connections and connections
that are anticipated as a result of prior inspection. Examples are data connections in
FTP, and the "second half" of UDP connections.

® Packet and Byte information - The number of packets and bytes in Check Point QoS
queues.
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ClusterXL

= Gateway working mode - The Security Gateway works mode as a Cluster Member
(Active or not), and its place in the priority sequence. Working modes are: ClusterXL,
Load Sharing, Sync only. Running modes: Active, Standby, Ready, and Down.

® |nterfaces - Interfaces recognized by the Security Gateway. The interface data includes
the IP Address and status of the specified interface, if the connection that passes
through the interface is verified, trusted or shared.

® Problem Notes - Descriptions of the problem notification device such as its status,
priority and when the status was last verified.

OPSEC

® The version name or number, and build number of the Check Point OPSEC SDK and
OPSEC product. The time it takes (in seconds) since the OPSEC Gateway is up and
running.

® The OPSEC vendor can add fields to their OPSEC Application Gateway details.

Check Point Security Management

® The synchronization status indicates the status of the peer Security Management
Servers in relation to that of the selected Security Management Server. View this status
in the Management High Availability Servers window, if you are connected to the Active
or Standby Security Management Server. The possible synchronization statuses are:

» Never been synchronized - Immediately after the Secondary Security
Management Server was installed, it did not undergo with the first manual
synchronization. This synchronization brings it up to date with the Primary
Management.

» Synchronized - The peer is synchronized correctly and has the same database
information and installed Security Policy.

» Collision - The active Security Management Server and its peer have different
installed policies and databases. The administrator must do manual
synchronization and decide which of the Security Management Servers to
overwrite.

® Clients - The number of connected clients on the Security Management Server, the
name of the SmartConsole, the administrator that manages the SmartConsole, the name
of the SmartConsole host, the name of the locked database, and the type of
SmartConsole application.
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SmartEvent Correlation Unit and the SmartEvent Server

SmartView Monitor reads statuses from the SmartEvent Correlation Unit and SmartEvent
Server.

SmartEvent Correlation Unit status examples:

® |s the SmartEvent Correlation Unit active or inactive

Is the SmartEvent Correlation Unit connected to the SmartEvent Server

Is the SmartEvent Correlation Unit connected to the Log Server

SmartEvent Correlation Unit and Log Server connection status

Offline job status
® | ack of disk space status
SmartEvent Server status examples:
® | ast handle event time
® |s the SmartEvent Server active or inactive
® A list of SmartEvent Correlation Unit the SmartEvent Server is connected to
® How many events arrived in a specified time period

Connect the SmartEvent Correlation Unit to the Log Server to read logs. Connect it to the
SmartEvent Server to send events. If problems occur in the SmartEvent Correlation Unit
connection to other components (for example, SIC problems) the problems are reported in the
SmartEvent Correlation Unit status.

For the same reasons, the SmartEvent Server contains statuses that provide information
about connections to all SmartEvent Correlation Unit.
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Anti-Virus and URL Filtering

SmartView Monitor can now provide statuses and counters for Security Gateways with
enabled Anti-Virus and URL Filtering.

The statuses are divided into these categories:
® Current Status
® Update Status (for example, when was the signature update last checked)

Anti-Virus statuses are associated with signature checks and URL Filtering statuses are
associated with URLs and categories.

In addition, SmartView Monitor can now run Anti-Virus and URL Filtering counters.
For example:

® Top five attacks in the last hour

® Top 10 attacks since last reset

® Top 10 http attacks in the last hour

® HTTP attacks general info

Multi-Domain Security Management

SmartView Monitor can be used to monitor Multi-Domain Servers. This information can be
viewed in the Gateway Status view. In this view you can see Multi-Domain Security
Management counter information (for example, CPU or Overall Status).

The 'cpstat’' Command

Shows the status and statistics information of Check Point applications.

For more information, see the R82 CLI Reference Guide - Chapter Security Gateway
Commands - Section cpstat.

Starting and Stopping Cluster Members

To stop and start one member of a cluster from SmartView Monitor:
1. Open the Gateway Status view.

2. Right-click the Cluster Member and select Cluster Member > Start Member or Stop
Member.
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Monitoring VPN Tunnels
This section describes how to monitor VPN tunnels.

VPN Tunnels Solution

VPN Tunnels are secure links between gateways. These Tunnels ensure secure connections
between gateways of an organization and remote access clients.

When Tunnels are created and put to use, you can keep track of their normal function, so that
possible malfunctions and connectivity problems can be accessed and solved as soon as
possible.

To ensure this security level, SmartView Monitor constantly monitor and analyze the status of
an organization's Tunnels to recognize malfunctions and connectivity problems. With the use
of Tunnel views, you can generate fully detailed reports that include information about the
Tunnels that fulfill the specific Tunnel views conditions. With this information you can monitor
Tunnel status, the Community with which a Tunnel is associated, the gateways, to which the
Tunnel is connected, and so on.

These are the Tunnel types:

= A Regular tunnel refers to the ability to send encrypted data between two peers. The
Regular tunnel is considered up if both peers have Phase 1 and Phase 2 keys.

® Permanent tunnels are constantly kept active. As a result, it is easier to recognize
malfunctions and connectivity problems. With Permanent tunnels administrators can
monitor the two sides of a VPN tunnel and identify problems without delay.

Permanent tunnels are constantly monitored. Therefore, each VPN tunnel in the
community can be set as a Permanent tunnel. A log, alert or user defined action can be
issued when the VPN tunnel is down.

The configuration of Permanent tunnels takes place on the community level and:

» Can be specified for an entire community. This option sets every VPN tunnel in the
community as permanent.

» Can be specified for a specific Security Gateway. Use this option to configure
specific Security Gateways to have Permanent tunnels.

» Can be specified for a single VPN tunnel. This feature allows you to configure
specific tunnels between specific Security Gateways as permanent.

This table shows the possible Tunnel states and their significance to a Permanent or Regular
Tunnel.
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State Permanent Tunnel Regular Tunnel
Up The tunnel works and IDE SA (Phase 1) and IPSEC SA (Phase 2)
the data can flow with exist with a peer gateway.
no problems.
Destroyed The tunnel is The tunnel is destroyed.
destroyed.
Up Phase1 Irrelevant Tunnel initialization is in process and Phase 1 is

complete (that is, IKE SA exists with cookies),
but there is no Phase 2.

Down There is a tunnel Irrelevant.
failure.

You cannot send and
receive data to or from
a remote peer.

Up Init The tunnel is Irrelevant.
initialized.

Gateway not The Security Gateway | The Security Gateway is not responding.
Responding is not responding.

VPN Tunnel View Updates

If a Tunnel is deleted from SmartConsole, the Tunnel Results View shows the deleted Tunnel
for an hour after it was deleted.

If a community is edited, the Results View shows removed tunnels for an hour after they were
removed from the community.

Running VPN Tunnel Views

When a Tunnel view runs the results show in the SmartView Monitor client.
A Tunnel view can run:

® From an existing view

® When you create a new view

® When you change an existing view
A Tunnels view can be created and run for:

® Down Permanent Tunnels

® Permanent Tunnels

R82 Logging and Monitoring Administration Guide | 205



Monitoring VPN Tunnels

® Tunnels on Community

® Tunnels on a Security Gateway

Run a Down Tunnel View

Down Tunnel view results list all the Tunnels that are currently not active.

To run a down tunnel view:
1. Inthe SmartView Monitor, click the Tunnels branch in the Tree View.

2. Inthe Tunnels branch (Custom or Predefined), double-click the Down Permanent
Tunnel view.

A list of all the Down Tunnels associated with the selected view properties shows.

Run a Permanent Tunnel View

Permanent Tunnel view results list all of the existing Permanent Tunnels and their current
status.

A Permanent Tunnel is a Tunnel that is constantly kept active.

To run a permanent tunnel view:
1. Inthe SmartView Monitor client, click the Tunnels branch in the Tree View.

2. Inthe Tunnels branch, double-click the Custom Permanent Tunnel view that you want
to run.

A list of the Permanent Tunnels related to the selected view properties shows.

Run a Tunnels on Community View

Tunnels on Community view results list all the Tunnels related to a selected Community.

To run a tunnels on community view:
1. Inthe SmartView Monitor client, click the Tunnels branch in the Tree View.

2. Inthe Tunnels branch (Custom or Predefined), double-click the Tunnels on Community
view.

A list of all Communities shows.
3. Select the Community whose Tunnels you want to monitor.
4. Click OK.

A list of all the Tunnels related to the selected Community shows.
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Run Tunnels on Gateway View

Tunnels on Gateways view results list all of the Tunnels related to a selected Security
Gateway.

To run tunnels on Gateway view:
1. Inthe SmartView Monitor client, click the Tunnels branch in the Tree View.

2. Inthe Tunnels branch (Custom or Predefined), double-click the Tunnels on Gateway
view.

A list of the Security Gateways shows.
3. Select the Security Gateway, whose Tunnels and their status you want to see.
4. Click OK.

A list of the Tunnels related to the selected Security Gateway shows.
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Monitoring Traffic or System Counters

This sections describes how to monitor traffic or system counters.

Traffic or System Counters Solution

SmartView Monitor provides tools that enable you to monitor traffic related to specified
network activities, and server, as well as the status of activities, hardware and software use of
different Check Point products in real-time. With this knowledge you can:

® Block specified traffic.
® Control traffic flow on a Security Gateway.

® See how many tunnels are currently open, or the rate of new connections that pass
through the VPN Gateway.

SmartView Monitor delivers a comprehensive solution to monitor and analyze network traffic
and network usage. You can generate fully detailed or summarized graphs and charts for all
connections intercepted and logged when you monitor traffic, and for numerous rates and
figures when you count usage throughout the network.

Traffic

Traffic Monitoring provides in-depth details on network traffic and activity. As a network
administrator you can generate traffic information to:

® Analyze network traffic pattern

Network traffic patterns help administrators determine which services demand the most
network resources.

B Audit and estimate costs of network us

Monitoring traffic can provide information on how the use of network resources is divided
among corporate users and departments. Reports that summarize customer use of
services, bandwidth and time can provide a basis to estimate costs for each user or
department.

® |dentify the departments and users that generate the most traffic and the times of peak
activity.

® Detect and monitor suspicious activity. Network administrators can produce graphs and
charts that document blocked traffic, alerts, rejected connections, or failed authentication
attempts to identify possible intrusion attempts.

A Traffic view can be created to monitor the Traffic types listed in the following table.
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Traffic Type Explanation

Services
IPs/Network

Objects

Security Rules

Interfaces

Connections

Shows the current status view about Services used through the selected
Security Gateway.

Shows the current status view about active IPs/Network Objects through
the selected Security Gateway.

Shows the current status view about the most frequently used Access
Control rules.

The Name column in the legend states the rule number as previously
configured in SmartConsole.

Shows the current status view about the Interfaces associated with the
selected Security Gateway.

Shows the current status view about current connections initiated through
the selected Security Gateway.

Tunnels Shows the current status view about the Tunnels associated with the
selected Security Gateway and their usage.

Virtual Link Shows the current traffic status view between two Security Gateways (for
example, Bandwidth, Bandwidth Loss, and Round Trip Time).

Packet Size Shows the current status view about packets according to the size of the

Distribution packets.

QoS Shows the current traffic level for each QoS rule.
Note - "Top QoS Rules" view in SmartView Monitor shows that almost all
traffic matches the "No Match" rule when SecureXL is enabled on the
Security Gateway. Refer to sk118720.

Traffic Legend Output

The values that you see in the legend depend on the Traffic view that you run.

All units in the view results show in configurable Intervals.

System Counters

Monitoring System Counters provides in-depth details about Check Point Software Blade
usage and activities. As a network administrator, you can generate system status information

about:
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® Resource usage for the variety of components associated with the Security Gateway.
For example, the average use of real physical memory, the average percent of CPU time
used by user applications, free disk space, and so on.

® Security Gateway performance statistics for a variety of Firewall components. For
example, the average number of concurrent CVP sessions handled by the HTTP security
server, the number of concurrent IKE negotiations, the number of new sessions handled
by the SMTP security server, and so on.

® Detect and monitor suspicious activity. Network administrators can produce graphs and
charts that document the number of alerts, rejected connections, or failed authentication
attempts to identify possible intrusion attempts.

Select and Run a Traffic or System Counters View

When a Traffic or System Counters view runs, the results show in the SmartView Monitor
client. A Traffic or System Counter view can run:

® From an existing view
® When you create a new view

® When you change an existing view

To run a Traffic or System Counters view:

1. In the SmartView Monitor client, select the Traffic or System Counter branch in the Tree
View.

2. Double-click the Traffic or System Counter view that you want to run.
A list of available Security Gateways shows.

3. Select the Security Gateway, for which you want to run the selected Traffic or System
Counter view.

4. Click OK.

The results of the selected view show in the SmartView Monitor client.

Recording a Traffic or Counter View

You can save a record of the Traffic or System Counter view results.

To record a traffic or counter view:
1. Run the Traffic or System Counters view.
2. Select the Traffic menu.

3. Select Recording > Record.
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A Save As window shows.
4. Name the record.
5. Save itin the related directory.
6. Click Save.

The word Recording shows below the Traffic or Counter toolbar. The appearance of this
word signifies that the view currently running is recorded and saved.

7. To stop recording, open the Traffic menu and select Recording > Stop.

A record of the view results is saved in the directory you selected in step 3 above.
Play the Results of a Recorded Traffic or Counter View

After you record a view, you can play it back. You can select Play or Fast Play, to see results
change faster.

To play the results:
1. In the SmartView Monitor client, select Traffic > Recording > Play.
The Select Recorded File window shows.
2. Access the directory in which the recorded file is kept and select the related record.
3. Click Open.

The results of the selected recorded view start to run. The word Playing shows below the
toolbar.

Pause or Stop the Results of a Recorded View that is Playing

® To pause the record select Traffic > Recording > Pause.

® Click Recording > Play to resume to play the Traffic or Counter view results recorded
before.

® To stop the record select Traffic > Recording > Stop.
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Monitoring Users

This section describes how to monitor users.

Users Solution

The User Monitor is an administrative feature. This feature lets you to keep track of Endpoint
Security VPN users currently logged on to the specific Security Management Servers. The
User Monitor provides you with a comprehensive set of filters which makes the view definition
process user-friendly and highly efficient. It lets you to easily navigate through the obtained
results.

With data on current open sessions, overlapping sessions, route traffic, connection time, and
more, the User Monitor gives detailed information about connectivity experience of remote
users. This SmartView Monitor feature lets you view real-time statistics about open remote
access sessions.

If specific data are irrelevant for a given User, the column shows N/A for the User.

Run a Users View

When you run a Users view, the results show in the SmartView Monitor:
® From an existing view
® When you create a new view
® When you change an existing view

A Users view can be created and run for:

® One user

All users

A specific Security Gateway

Mobile Access user
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Run a User View for a Specified User

To run a user view for a specified user:

1.
2.

In SmartView Monitor > Tree View, click Users.
Click Get User by Name.

The User DN Filter window opens.

Enter the specified User DN in the area provided.
Click OK.

The view results show in the Results View.

Run a User View for all Users or Mobile Access Users

To run a user view for all users or Mobile Access users:

1.
2.

In SmartView Monitor > Tree View, click Users.
Click All Users or Mobile Access Users.

The view results show in the Results View.

Run a User View for a Specified Security Gateway

To run a user view for a specified Security Gateway:

1.
2.

In SmartView Monitor > Tree View, click Users.

Click Users by Gateway.

The Select Gateway window shows.

Select the Security Gateway, for which you want to run the view.
Click OK.

The view results show in the Results View.
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Cooperative Enforcement Solution

Cooperative Enforcement works with Check Point Endpoint Security Management Servers.
This feature utilizes the Endpoint Security Management Server compliance function to make
sure connections that come from different hosts across the internal network.

Endpoint Security Management Server is a centrally managed, multi-layered endpoint security
solution that employs policy based security enforcement for internal and remote PCs. The
Endpoint Security Management Server mitigates the risk of hackers, worms, spyware, and
other security threats.

Features such as policy templates and application privilege controls enable administrators to
easily develop, manage, and enforce Cooperative Enforcement.

With Cooperative Enforcement, a host that initiates a connection through a Security Gateway
is tested for compliance. This increases the integrity of the network because it prevents hosts
with malicious software components to access the network.

Cooperative Enforcement acts as a middle-man between hosts managed by an Endpoint
Security Management Server and the Endpoint Security Management Server itself. It relies on
the Endpoint Security Management Server compliance feature. It defines if a host is secure
and can block connections that do not meet the defined prerequisites of software components.

Unauthorized

Authorized

1. The Endpoint Security client (A) in the internal network (B) opens a connection to the
internet (C) through a Security Gateway (D).

2. Cooperative Enforcement starts to work on the first server's reply to the client.

3. The Security Gateway sees the client's compliance in its tables and queries the Endpoint
Security Management Server (E).

4. When areply is received, a connection from a compliant host to the internet is allowed.

If the client is non-compliant and Cooperative Enforcement is not in Monitor-only mode,
the connection is closed.
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o Note - Scalable Platforms do not support Cooperative Enforcement.

NAT Environments

Cooperative Enforcement is not supported by all the NAT configurations.

For Cooperative Enforcement to work in a NAT environment, the Security Gateway and the
Endpoint Security Management Server must recognize the same IP address of a client. If NAT
causes the IP address received by Security Gateway to be different than the IP address
received by the Endpoint Security Management Server, Cooperative Enforcement will not
work.
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Configuring Cooperative Enforcement

To configure Cooperative Enforcement:

From the Security Gateway's Cooperative Enforcement page, click Authorize clients using
Endpoint Security Server to enable Cooperative Enforcement.

® Monitor Only The Security Gateway requests authorization from the Endpoint Security
Management Server, but connections are not dropped. Hosts can connect while the
Security Gateway grants authorization. The Security Gateway generates logs for
unauthorized hosts. You can add unauthorized hosts to the host's exception list or make
those hosts compliant in other ways.

If Monitor Only is not selected, Cooperative Enforcement works in Enforcement mode.
The Endpoint Security Firewall blocks non-compliant host connections. For HTTP
connections, the client is notified that its host is non-compliant. The user can change the
computer to make compliant. For example, the user can upgrade the version of the
Endpoint Security client.

® Track unauthorized client status. Set a log, or alert option for the hosts that would be
dropped if not in Monitor Only mode.

®= |n the Endpoint Security Server Selection section, select which Endpoint Security
Management Server is used:

» To use this machine, select Use Endpoint Security Server installed on this
machine.

» To use another machine, select a server from Select Endpoint Security Server.
Click New to create a new server.

® |n the Client Authorization. section, define exceptions for client authorization.
» Check authorization of all clients - Get authorization from all clients.

» Bypass authorization of the following clients - Allow clients in the selected groups
to always connect, without authorization inspection. All other clients are inspected.

» Check authorization only of the following clients - Inspect authorization of clients
from the selected groups. All other clients bypass authorization.
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Non-Compliant Hosts by Gateway View

The Non-Compliant Hosts by Gateway view lets you to see Host IP addresses by Endpoint
Security Management Server compliance:

® Authorized - Enables access to the internet. If a Security Gateway has Authorized
status, it does not show in the Non-Compliant Hosts by Gateway view.

® Unauthorized - The Endpoint Security client is not compliant and the host is not
authorized.

* Monitor Only mode - The Endpoint Security client has access to the internet,
authorized or not.

* Blocked mode - Blocks access to the internet.

® No Endpoint Security client - The Security Gateway is not related to an Endpoint
Security client.
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Third-Party Log Formats

You can import these third-party log formats to a Check Point Log Server:
® Syslog messages.
® Windows Events.
® SNMP Traps.

The Log Server converts the third-party log messages to a Check Point log. The log is then
available for further analysis by SmartEvent.

Importing Syslog Messages
Many third-party devices use the syslog format for logging. The Log Server reformats the raw
data to the Check Point log format to process third-party syslog messages.

The Log Server uses a syslog parser to convert syslog messages to the Check Point log
format.

To import syslog messages, define your own syslog parser and install it on the Log Server.

SmartEvent can take the reformatted logs and convert them into security events.

Generating a Syslog Parser and Importing syslog Messages

To import syslog messages from products and vendors that are not supported out-of-the-box,
see sk55020. This shows you how to:

1. Import some sample syslog messages to the Log Parsing Editor.
2. Define the mapping between syslog fields and the Check Point log fields.
3. Install the syslog parser on the Log Server.

After you imported the syslog messages to the Log Server, you can see them in
SmartConsole, in the Logs & Events > Logs tab.

Note - Make sure that Access Control rules allow ELA traffic between the Syslog computer and
the Log Server.
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Configuring SmartEvent to Read Imported Syslog
Messages

After you imported the syslog messages to the Log Server, you can forward them to
SmartEvent Server (and other OPSEC LEA clients), as other Check Point logs. SmartEvent
converts the syslog messages into security events.

To configure the SmartEvent Server to read logs from this Log Server:
1. Configure SmartEvent to read logs from the Log Server.

2. In SmartEvent or in the SmartConsole event views, make a query to filter by the Product
Name field. This field uniquely identifies the events that are created from the syslog
messages.

Importing Windows Events

Check Point Windows Event Service is a Windows service application. It reads events from the
Windows server and other configured Windows computers, converts them to Check Point

logs, and places the data in the Check Point Log Server. The Log Server processes this data.
The process can only be installed on a Windows computer, but it does not have to be the
computer that runs Log Server. Therefore, Windows events can be processed even if the Log
Server is installed on a different platform.

How Windows Event Service Works

To convert Windows events into Check Point logs:

1. Download the Windows Event Service agent WinEventToCPLog from the Check Point
Support Center.

2. Install the service agent on a Windows server.

An administrator user name and password are necessary. The administrator name is
one of these:

® A domain administrator responsible for the endpoint computer
® A local administrator on the endpoint computer
3. Create SIC between the Windows server and the Management Server.

4. Configure the Windows server to collect Windows events from required computers.
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Administrator Support for WinEventToCPLog

WinEventToCPLog uses Microsoft APIs to read events from Windows operating system
event files. To see these files, use the Windows Event Viewer.

WinEventToCPLog can read event files on the local machine, and can read log files from
remote machines with the right privileges. This is useful when you make a central
WinEventToCPLog server that forwards multiple Window hosts events to a Check Point Log
Server.

To set the privileges, invoke the "WinEventToCPLog -s"to specify an administrator login
and password.

These are the ways to access the files on a remote machine:

® To define a local administrator on the remote machine that their name matches the name
registered with WinEventToCPLog.

® To define the administrator registered with WinEventToCPLog as an administrator in
the domain. This administrator can access all of the machines in the domain.

Sending Windows Events to the Log Server

This section describes how to send Windows events to the Log Server. For advanced
Windows event configuration, see sk98861.
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Creating an OPSEC Object for Windows Event Service

In SmartConsole, create an OPSEC object for Windows Event Service.

To create an OPSEC object for windows event service:

1.

10.
11.
12.

©® N oo g~ W D

From the Object Explore, click New > Server > OPSEC Application > Application.
The OPSEC Applications Properties window shows.

Enter the name of the application that sends log files to the Log Server.

Click New to create a Host.

Enter an object name and the IP address of the machine that runs WinEventToCPLog.
Click OK.

Below Client Entities, select ELA.

Select Communication.

Enter an Activation Key, enter it again in the confirmation line, and keep a record of it for
later use.

Click Initialize.

The system must report the trust status as Initialized but trust not established.
Click Close.

Click OK.

Publish the SmartConsole session.

Note - Make sure that Access Control rules allow ELA traffic between the Windows computer
and the Log Server.
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Configuring the Windows service

On the Windows host, configure the Windows service to send logs to the Log Server.

To configure the Windows service:

1. Install the WinEventToCPLog package from the Check Point Support Center.

2. When the installation completes, restart the computer.
3. Open a command prompt window and go to this location:
® On Windows 32-bit:
C:\Program Files\CheckPoint\WinEventToCPLog\R65\bin\
® On Windows 64-bit:
C:\Program Files (x86)\CheckPoint\WinEventToCPLog\R65\bin\
4. Pull the certificate.

Instructions

a. Run:
windowEventToCPLog -pull cert
b. Enterthe IP address of the management server.

c. Enter the name of the corresponding OPSEC Application object that you created
in SmartConsole for the Windows events.

d. Enterthe Activation Key of the OPSEC object.

5. Restart the Check Point Windows Event Service.

Establishing Trust

Establish trust between the Security Management Server and the windows host.

To establish trust:

—

. Editthe OPSEC Application that you created in SmartConsole for the Windows events.
2. Select Communication.

3. Make sure that the trust status is Trust Established.

4

. Publish the SmartConsole session.
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Configuring the Windows Audit Policy

On each machine that sends Windows Events, configure the Windows Audit Policy.

To configure the windows audit:

1.
2.
3.

7.

From the Start menu, click Settings > Control Panel.
Click Administrative Tools > Local Security Policy >Local Policies >Audit Policy.

Make sure that the Security Setting for the Policy Audit Logon Events is set to Failure. If
not, double-click it and select Failure.

Open a command prompt window and go to this path:
® On Windows 32 bit:
C:\Program Files\CheckPoint\WinEventToCPLog\R65\bin\
® On Windows 64 bit:
C:\Program Files (x86)\CheckPoint\WinEventToCPLog\R65\bin\
Run these commands:

windowEventToCPLog -l <ipaddr>, where <ipaddr> is the IP address of the Log Server
that receives the Windows Events.

windowEventToCPLog -a <ipaddr>, where <ipaddr> is the IP address of each machine
that sends Windows Events.

windowEventToCPLog -s, where you are prompted for an administrator name and the
administrator password that to be registered with the windowEventToCPLog service.

The administrator that runs the windowEventToCPLog service must have permissions
to access and read logs from the IP addressed defined in this procedure. This is the IP
address of the computer that sends Windows events.

When you configure windowEventToCPLog to read Windows events from a remote
machine, log in as the administrator. This makes sure that the administrator can access
remote computer events.

Use the Microsoft Event Viewer to read the events from the remote machine.
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Working with SNMP

SNMP (Simple Network Management Protocol) is an internet standard protocol. SNMP is used
to send and receive management data, protocol data units (PDUs), to network devices.
SNMP-compliant devices, called agents, keep data about themselves in Management
Information Bases (MIBs) and resend this data to the SNMP requesters.

For more information, see R82 Gaia Administration Guide > Chapter System Management
> Section SNMP.
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Log Exporter

Overview

Check Point Log Exporter is an easy and secure method to export Check Point logs over the
syslog protocol from a Management Server / Log Server.

You can configure the Log Exporter settings in SmartConsole or with CLI commands.
You can configure advanced settings in various configuration files.
Log Exporter supports:

® Multiple SIEM applications that can run a Syslog agent.

® Syslog over TCP or UDP.

® Multiple formats (Syslog, CEF, LEEF, JSON, and so on).

® Mutual authentication based on TLS 1.2.

® Export of Security logs, Audit logs, or both.

® Export of links to the relevant log card in SmartView and the log attachment (such as
Forensics / Threat Emulation report).

® Filtering of logs.

Log Exporter is constantly updated. For the most up to date information about the supported
versions and applications, see:

m sk122323 - Log Exporter - Check Point Log Export

® sk144192 - Log Fields Description

o Note - The Check Point App for Splunk uses the Log Exporter to seamlessly send
logs from your Check Point Log Server to your Splunk server. This enables you to
collect and analyze millions of logs from all Check Point technologies and platforms.
For more information, see the App for Splunk User Guide.
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How Log Exporter Works

Log Exporter is a multi-threaded daemon service which runs on a log server. The Log Exporter
daemon reads each log, transforms it into the desired format and mapping, and sends it to the
configured target.

On Multi-Domain Server / Multi-Domain Log Server, if Log Exporter is deployed on several
Domains, each Domain Server has its own Log Exporter daemon service. If you export the
logs to several targets, each target has its own Log Exporter daemon.

Log Exporter is implemented as the "E-T-L" procedure:

® Extract - Reads incoming logs from itself, the Log Server / SmartEvent Server of the
Security Gateways.

® Transform - Changes the logs according to the configuration.
® Export - Sends the logs to the configured target server.

Log Exporter stops exporting when disconnected from the 3rd party server and remembers the
last position exported. After the connection is established again, Log Exporter automatically
starts exporting logs from the last known position. Log Exporter is exporting both online and
offline (if any) logs in parallel. In case the 3rd party server is slow, Log Exporter reduces the
offline exporting rate to prioritize the online logs over the offline logs.

Note - From R81.20, you can monitor the rate of exported logs in CPView. For
information, see sk101878.
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Configuring Log Exporter in SmartConsole

Starting in R81, you can configure a Log Exporter directly from SmartConsole and link it to the
relevant Log Servers.

Procedure:

1. Create a new Log Exporter/SIEM object in SmartConsole:

a. From the top, click Objects > More object types > Server > Log Exporter/SIEM.
b. Inthe Object Name field, enter the applicable name for the new Log Exporter.
c. From the left, click the General page:

i. Inthe Export Configuration section, select Enabled.

ii. Inthe Server Configuration section:

® |nthe Target Server field, enter the IPv4 address or the FQDN of the
destination server

® |nthe Target Port field, enter the number of the listening port on the
destination server

® |n the Protocol field, select the applicable protocol - UDP (default) or
TCP
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e.

f.

Configuring Log Exporter in SmartConsole

From the left, click the Data Manipulation page:
i. Inthe Format field, select the applicable format for the exported logs:

® Syslog (default)
= Common Event Format (CEF)
® Log Event Extended Format (LEEF)
= Generic
® Splunk
® LogRhythm
® Json

ii. Optional: Select Aggregate log updates before export to export all logs
with the full data.

By default, update logs contain the data that was changed compared to the
last log for the same event.

From the left, click the Attachments page:

Log Exporter does not include attachments by default.

Optional: Select the applicable options to configure the log attachments:
® Add link to Log Details in SmartView
® Add link to Log Attachment in SmartView
® Add Log Attachment ID

Click OK.

2. Configure the Management Server or Dedicated Log Server / SmartEvent Server object:

a.

b.

C.
d.

e.

From the left navigation panel, click Gateways & Servers.

Open the Management Server or Dedicated Log Server / SmartEvent Server
object.

From the left tree, click Logs > Export.
Click [+] and select the Log Exporter / SIEM object you configured earlier.
Click OK.

3. Install the database:

a.

b.

From the top, click Menu > Install database.

Select all objects.
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c. Click Install.

o Important in a Multi-Domain Server environment - If you configured Log
Exporter object(s) in the Global Domain and assigned Global Policy, you
must install the database in SmartConsole connected to the applicable
Domain Management Server.

After you upgrade a Management Server / Log Server / SmartEvent Server to a new
version, you must:

1. Connect to the command line on the Management Server / Log Server / SmartEvent
Server configured with Log Exporter.

2. Login to the Expert mode.

3. In SmartConsole, click Menu > Install database > select all objects > click Install.

Note - During an upgrade to R81.20 and higher, the Log Exporter configuration is part
of the upgrade.
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Configuring Log Exporter in CLI

This section describes the Expert mode CLI commands to configure the Log Exporter settings.

Log Exporter Basic Configuration in CLI

Common method for creating and modifying Log Exporter targets.

To configure a new target for the exported logs:
1. Connect to the command line on the Management Server / Log Server.
2. Login to the Expert mode.

3. Configure the Log Exporter settings:

cp log export add name <Name of Log Exporter Configuration>
[domain-server {mds | all}] target-server <HostName or IP
address of Target Server> target-port <Port on Target Server>
protocol {tcp | udp} format {cef | generic | json | leef |
logrhythm | rsa | splunk | syslog} [--apply-now] [<Other
Optional Arguments>]

Parameters:
Parameter Description
name <Name of Log Configures the name of the Log Exporter
Exporter Configuration> configuration.

Notes:

® Allowed characters are: Latin letters,
digits ("0-9"), minus ("-"), underscore
(" "), and period (".").

® Must start with a letter.

® The minimum length is two characters.

® This command creates a new target
directory with the specified unique
name in the

SEXPORTERDIR/targets/ directory.
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Parameter Description

domain-server {mds | On a Multi-Domain Server, specifies the
all} applicable Domain Management Server context.
On a Multi-Domain Log Server, specifies the
applicable Domain Log Server context.
This parameter is mandatory.
® "mds" (in small letters) - Exports audit logs
from only the main MDS level.
® "311" (in small letters) - Exports audit logs
from all Domains.

target-server <HostName Configures the target server, to which Log
or IP address of Target Exporter sends the exported logs.
Server> You can enter an IP address or an FQDN.
target-port <Port on Configures the listening port on the target server,
Target Server> to which Log Exporter sends the exported logs.
protocol {tcp | udp} Configures the Layer 4 protocol for Syslog traffic
-TCP or UDP.

format {...} Configures the format of exported logs:

® ccf-CEF

® generic - Generic

® json-JSON

B leef-LEEF

® Jlogrhythm-LogRhythm

® rsa-RSA

® splunk - Splunk

| |

syslog - Syslog (default)

-—apply-now Optional.

Automatically starts the new Log Exporter
instance with the new settings.

If you do not use this parameter, you must start
the new Log Exporter instance manually with this
command:

cp log export restart

<Other Optional Optional.
Arguments> See "Log Exporter Advanced Configuration in
CLI" on page 233.

R82 Logging and Monitoring Administration Guide | 231



Configuring Log Exporterin CLI

Important - By default, Log Exporter sends the exported logs in clear text. To send
the exported logs over an encrypted connection, see "Log Exporter TLS
Configuration” on page 254.
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Log Exporter Advanced Configuration in CLI

Advanced method for creating and modifying Log Exporter targets.

Syntax:

cp log export <Command-Name> [<Command-Arguments>]

To see a built-in help for a specific command:

cp_log export <Command-Name> help
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Log Exporter Advanced Configuration in CLI

Name Description

add

delete

reexport

restart

set

show

start

status

stop

Configures a new Check Point Log Exporter.

cp_log export add name <Name> target-server <Target-
Server> target-port <Target-Server-Port> protocol
{udp | tcp} [Optional Arguments]

Removes an existing Log Exporter.

cp_log export delete name <Name>

Resets the current log position and exports all logs again based on the
configuration.

cp_log export reexport name <Name> --apply-now

cp _log export reexport name <Name> start-position
<Position of Last Exported Log> --apply-now

cp_log export reexport name <Name> start-position
<Position of Gap Start> end-position <Position of
Gap End> --apply-now

Restarts a Log Exporter process.

cp_log export restart name <Name>

Updates an existing Log Exporter configuration.

cp_log export set name <Name> [<Optional Arguments>]

Shows the current Log Exporter configuration.

cp_log export show [<Optional Arguments>]

Starts an existing Log Exporter process.

cp_log export start name <Name>

Shows a Log Exporter overview status.

cp_log export status [<Optional Arguments>]

Stops an existing Log Exporter process.

cp_log export stop name <Name>

Command Arguments
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Requ
ired
for

lladdll

com
mand

Description

--—apply-now Applies immediately | Optio | Optio | Man | N/A | N/A | Man
any change that was nal nal dator dator
done with the "add", y y
"set", "delete", or
"reexport"

command.

ca-cert Specifies the full Optio | Optio | N/A | N/JA | N/A | N/A
<Path> path to the CA nal nal
certificate file

* .pem.

o Important -
Applicable only
when the value
of the
"encrypted"
argument is
"true".
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Requ
ired
for

lladdll

com
mand

Description

client-cert Specifies the full Optio | Optio | N/A | N/A | N/A | N/A
<Path> path to the client nal nal

certificate * . p12.

o Important -

Applicable only
when the value
of the
"encrypted"
argument is
"true".

client- Specifies the Optio | Optio | N/A | N/JA | N/A | N/A
secret challenge phrase nal nal
<Phrase> used to create the
client certificate
*.pl2.

o Important -
Applicable only
when the value
of the
"encrypted"
argument is
"true".
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Requ
ired
for

lladdll

com
mand

Description

domain- On a Multi-Domain Man Man Man | N/A | Opti Man
server {mds Server, specifies the | dator | dator | dator onal | dator
| all}) applicable Domain y y y y
Management Server
context.
On a Multi-Domain
Log Server,
specifies the
applicable Domain
Log Server context.
o Important:
® "mds" (in
small
letters) -
Exports
all logs
from only
the main
MDS
level.
m "311"(in
small
letters) -
Exports
all logs
from all
Domains.
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Requ
ired
for

lladdll

com
mand

enabled Specifies whetherto | Optio | Optio | N/A | N/A | N/A | N/A
{true | allow the Log nal nal
false} Exporter to start

when you run the

"cpstart"or

"mdsstart"

command.

Default: true
encrypted Specifies whetherto | Optio | Optio | N/A | N/A | N/A | N/A
{true | use TSL (SSL) nal nal
false} encryption to send

the logs.

Default: false
end-position | Specifies the end N/A | N/A | N/A | N/JA | N/A | Optio
<Position> position, up to which nal

to export the logs.
export- Specifies whetherto | Optio | Optio | N/A | N/A | N/A | N/A
attachment- add a field to the nal nal
ids {true | exported logs that
false} represents the ID of

log's attachment (if

exists).

Default: false
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Requ
ired
for

lladdll

com
mand

Description

export- Specifies whetherto | Optio | Optio | N/A | N/A | N/A | N/A
attachment- add a field to the nal nal
link {true | | exported logs that
false} represents a link to
SmartView that

shows the log card
and automatically
opens the
attachment.
Default: false

export-1link Specifies whetherto | Optio | Optio | N/A | N/JA | N/A | N/A

{true | add a field to the nal nal
false} exported logs that

represents a link to

SmartView that

shows the log card.
Default: false
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export-link-
ip {true |
false}

export-log-
position
{true |
false}

Description

Specifies whether to

make the links to

SmartView use a

custom IP address

(for example, for a

Log Server behind

NAT).

o Important -
Applicable only
when the value
of the
"export-
link"
argument is
"true", orthe
value of the
"export-
attachment-
link"
argument is
"true".

Default: false

Specifies whether to
export the log's
position.

Default: false

Log Exporter Advanced Configuration in CLI

Requ
ired
for

lladdll

com
mand

Optio
nal

Optio
nal

Optio
nal

Optio
nal

N/A

N/A

N/A

N/A

N/A

N/A

N/A
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Requ
ired
for

lladdll

com
mand

Description

filter- Specifies whetherto | Optio | Optio | N/A | N/A | N/A | N/A
action-in export all logs that nal nal

{"Actionl"," | contain a specific

Action2", ... | valueinthe "Action"

| false} field.

Each value must be
surrounded by
double quotes (").
Multiple values are
supported and must
be separated by a
comma without
spaces.

To see all valid
values:

1. In
SmartConsole
, go to the
Logs &
Events view
and open the
Logs tab.

2. Inthetop
query field,
enter action:
and a letter.

Examples of values:
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Requ
ired
for

lladdll

com
mand

Description

Accept
Block
Bypass
Detect
Drop
HTTPS
Bypass
= HTTPS
Inspect
" Prevent
" Reject

o Important -
This parameter
replaces any
other filter
configuration
that was
declared earlier
on this field
directly in the
filtering XML
file. Other field
filters are not
overwritten.
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Requ
ired
for

lladdll

com
mand

Description

filter- Specifies whetherto | Optio | Optio | N/A | N/A | N/A | N/A
blade-in export all logs that nal nal
{"Bladel", "B | contain a specific
lade2", ... | | valueinthe "Blade"
false} field (the object
name of the

Software Blade that
generated these
logs).

Each value must be
surrounded by
double quotes (").
Multiple values are
supported and must
be separated by a
comma without
spaces.

To see all valid
values:

1. In
SmartConsole
, go to the
Logs &
Events view
and open the
Logs tab.
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Requ
ired
for

lladdll

com
mand

Description

2. Inthetop
query field,
enter blade:
and a letter.

Examples of values:

= Anti-Bot

® Firewall

= HTTPS
Inspection

® |dentity
Awareness

= |PS

Valid Software
Blade families:

" Access
" TP

® Endpoint
" Mobile
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Requ
ired
for

lladdll

com
mand

Description

o Important -
This parameter
replaces any
other filter
configuration
that was
declared earlier
on this field
directly in the
filtering XML
file. Other field
filters are not
overwritten.
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Requ
ired
for

lladdll

com
mand

Description

filter- Specifies whetherto | Optio | Optio | N/A | N/A | N/A | N/A
origin-in export all logs that nal nal

{"Originl"," | contain a specific

Origin2", ... | valueinthe "Origin"

| false} field (the object

name of the Security
Gateway / Cluster
Member that
generated these
logs).

Each origin value
must be surrounded
by double quotes
(™).

Multiple values are
supported and must
be separated by a
comma without
spaces.
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Requ
ired
for

lladdll

com
mand

Description

o Important -
This parameter
replaces any
other filter
configuration
that was
declared earlier
on this field
directly in the
filtering XML
file. Other field
filters are not

overwritten.
format Specifies the format, | Optio | Optio | N/A | N/JA | N/A | N/A
{generic | in which the logs are nal nal
cef | Json | | exported.
leef | Default: syslog
logrhythm |
rsa | splunk
| syslog}
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Requ
ired

for

Description "add"

com
mand

name Specifies the unique | Man | Man | Man | Opti | Opti | Man
"<Name>" name of the Log dator | dator | dator | onal. | onal. | dator
Exporter y y y By By y

configuration. defa | defa

ult, ult,

appli | appli

esto | esto

all. all.
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Description

Notes:

= Allowed
characters
are: Latin
letters, digits
("0-9")
minus ("-"),
underscore
(" "), and
period (".").

® Must start
with a letter.

® The minimum
length is two
characters.

® The "add"
command
creates a new
target
directory with
the specified
unique name
in the
SEXPORTERD
IR/target
s/ directory.
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Requ
ired
for

lladdll

com
mand

Description

protocol Specifies the Layer Man | Optio | N/A | N/A | N/A | N/A
{tcp | udp} 4 Transport protocol | dator nal

to use (TCP or y

UDP).

There is no default

value.
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Requ
ired
for

lladdll

com
mand

Description

read-mode Specifies the mode, | Optio | Optio | N/A | N/A | N/A | N/A
{raw | semi- | inwhich toread the nal nal
unified} log files.

B raw-
Specifies to
export log
records
without any
unification.

B semi-
unified-
Specifies to
export log
records with
step-by-step
unification.
That is, for
each log
record, export
a record that
unifies this
record with all
previously-
encountered
records with
the same ID.
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Requ
ired
for

lladdll

com
mand

Description

Default: semi-
unified
Default: raw

reconnect- Specifies the Optio | Optio | N/A | N/A | N/A | N/A
interval interval (in minutes) nal nal
{<Number> | after which the Log
default} Exporter must
connect again to the
target server after
the connection is
lost

To disable, enter the
value "default".
There is no default

value.
start- Specifies the start N/A | N/A | N/A | N/A | N/A | Optio
position position, from which nal
<Position> to export the logs.
target-port Specifies the Man | Optio | N/A | N/JA | N/A | N/A
<Target- listening portonthe | dator nal
Server—-Port> target server, to y

which you export the

logs.
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Requ
ired
for

lladdll

com
mand

Description

target- Specifies the IP Man | Optio | N/A | N/A | N/A | N/A
server address or FQDN of | dator nal
<Target- the target server, to y
Server> which you export the
logs.
time-in- Specifies whetherto | Optio | Optio | N/A | N/JA | N/A | N/A
milli {true export logs with the nal nal
| false} time resolution in
milliseconds.
Requires Security
Gateways R81 and
higher.
Default: false
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Log Exporter TLS Configuration

Log Exporter can export logs over an encrypted connection using the TLS protocol.

Only mutual authentication is allowed.

For mutual authentication, Log Exporter requires these certificates:

® A Certificate Authority (CA) certificate file in the PEM format (this is the CA that signed
both the client (Log Exporter side) and target server certificates)

® A client certificate in the P12 format on the Management Server / Log Server with Log
Exporter

o Notes:

® The Management Server / Log Server with Log Exporter must be able to
connect to the Certificate Authority.

® |n addition to these two certificates, a third certificate should be installed on the
target server (based on the server requirement).

® |tis possible to use self-signed certificates.

If you do not already have the required certificates, the procedure below is an example of how
to create the required certificates.

The procedure below uses the openss1 commands on a Linux server (non-Check Point).

To create a self signed Certificate Authority (CA)

Run this if you do not already have a trusted CA certificates in the PEM format:

1. Generate the root CA key and do not give it to anyone:

openssl genrsa -out RootCA.key 2048

2. Generate the root CA certificate in the PEM format:

openssl req -x509 -new -nodes -key RootCA.key -days 2048 -
out RootCA.pem
3. Enter the Distinguished Name (DN) information for the certificate.

= Common Name(CN) is the exact Fully Qualified Domain Name (FQDN) of the
host on which you use the certificate.

= All other fields are optional. If you purchase an SSL certificate from a Certificate
Authority, these additional fields may be required.
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To create a client certificate file in the P12 format (for Log Exporter)
1. Generate the client key and do not give it to anyone:
openssl genrsa -out log exporter.key 2048
2. Generate the client certificate sign request:
openssl req -new -key log exporter.key -out log exporter.csr
3. Use the CA files to sign the certificate:
openssl x509 -req -in log exporter.csr -CA RootCA.pem -CAkey

RootCA.key —-CAcreateserial -out log exporter.crt -days 2048
-sha256

4. Convert the certificate file to the P12 format:

openssl pkcsl2 -inkey log exporter.key -in log exporter.crt
-export -out log exporter.pl?2

o Note - The challenge phrase used in this conversion is required in the "1og
exporter" TLS configuration.

After you created the required certificates, you must update the security parameters on the
Check Point Management Server / Log Server.

To update the security parameters

1. Connect to the command line on the Management Server / Log Server.
2. Log into the Expert mode.

3. On a Multi-Domain Server / Multi-Domain Log Server, switch to the required Domain:

mdsenv <IP Address or Name of Domain Management Server /
Domain Log Server>

4. Go to the directory with the applicable Log Exporter Configuration:
cd SEXPORTERDIR/targets/<Name of Log Exporter Configuration>

5. Create a new directory for the certificates:

mkdir -v certificates

cd certificates

6. Transfer these certificate files to the new directory "certificates™
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B RootCA.pem
B ]og exporter.pl?2

7. Give the certificate files the execution permission:

chmod -v +r RootCA.pem

chmod -v +r log exporter.pl?2

8. Go to the directory with the applicable Log Exporter Configuration:

cd SEXPORTERDIR/targets/<Name of Log Exporter Configuration>

9. Update the targetConfiguration.xml file:

a. Editthefile:

vi targetConfiguration.xml

b. Configure the full path to the new certificate files and the challenge phrase used
to create the P12 certificate.

c. Save the changes in the file and exit the editor.
To create a target server certificate
1. Generate the server key and do not give it to anyone:

openssl genrsa -out syslogServer.key 2048
2. Generate the server certificate sign request:

openssl reqg -new -key syslogServer.key -out syslogServer.csr
3. Use the CA files to sign the certificate:

openssl x509 -req -in syslogServer.csr -CA RootCA.pem -CAkey

RootCA.key -CAcreateserial -out syslogServer.crt -days 2048
-sha256
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Log Exporter Advanced Configuration
Parameters

After deploying a new instance of Log Exporter, all configuration files for that deployment are
located in this directory:

SEXPORTERDIR/targets/<Name of Log Exporter Configuration>/

Note - On a Multi-Domain Server / Multi-Domain Log Server, the value of the
environment variable EXPORTERDIR changes automatically when you switch
between Domain server contexts with the mdsenv command.

o Important:

® You must restart the Log Exporter instance for the new settings to take effect.
Runthe"cp log export restart"command

® Forinformation on how to backup and restore your Log Exporter configuration,
see sk127653.

You can configure specific parameters to control how Log Exporter exports the logs.

Target Server Configuration
The Log Exporter configuration for the target server is saved in this file:

SEXPORTERDIR/targets/<Name of Log Exporter
Configuration>/targetConfiguration.xml

These are some of the configuration options:

Valid /
Parameter Description Default
Values
<version></version> Current Log Exporter version - used for
upgrades.
<is enabled></is Determines if the Log Exporter process is | true
enabled> monitored by the watch dog. false
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Destination Parameters

Parameter

Log Exporter Advanced Configuration Parameters

Description

Valid /
Default
Values

type

<ip></ip>

<port></port>

<protocol></protocol>

<reconnect
interval></reconnect
interval>

Reserved for future use.

The IP address of the target server that
receives the logs.

The port on the target.

The protocol used in the connection.

Determines how frequently to start the
connection to the target server after it is
lost.

Any IPv4
address or
FQDN

Any valid
port number

TCP or UDP

Number of
minutes
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Log Exporter Advanced Configuration Parameters

These are discussed in more detail in "Log Exporter TLS Configuration" on page 254.

Parameter

Valid / Default

<security></security>

<pem ca file></pem ca file>

<pl2 certificate file></pl2
certificate file>

<client certificate
challenge phrase></client
certificate challenge
phrase>

Description Values
Determines if the B clear-
connection is sent in clear clear text
text or encrypted. (this is the
default)
B tls-
encrypted
The location of the root
Certificate Authority
certificate file in the PEM
format.

The location of the client
key pair in the P12 format.

The challenge phrase that
was used to create the
P12 certificate.

The value is hashed when
the Log Exporter is started
or restarted.
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Parameter

<folder></folder>

<log files></log
files>

<log_types></log_
types>

<read mode></read
mode>

Log Exporter Advanced Configuration Parameters

Description

The path where the log files are
located.

Determines which log records
to export or how far back to
read the log records from the
SFWDIR/log/fw.log file.

Determines which logs to
export.

Determines whether to export
complete logs or only their
delta.

Valid / Default Values

Default location is
SFWDIR/1log/

<Number> - reads
logs from the
specific number
(default=1) of days
back
(recommended)
<Specific File
Name> - reads logs
from the specified
file

B on-line
® |f no valueis

specified, uses 'on-
line'

all - Security and
Audit (default)

® ]og - Security only
® audit - Auditonly

semi-unified
(default)

raw
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Resolver Parameters

Parameter

Description

Valid /
Default
Values

<mappingConfiguration></mappingCo
nfiguration>

<exportAllFields>true</exportAllF
ields>

Configures the XML file
that contains the log field
mapping scheme.

If left empty, uses the
default settings.

When this field is set to
'true', all log fields are
sent regardless of whether
they appear in the
mapping scheme, except
for specifically black-listed
fields in the relevant log
format mapping file (
<exported>false</ex
ported>).

When this field is set to
'false', only those fields
which appear in the
relevant log format
mapping file are sent (with
exported flag setto 'true":
<exported>true</exp
orted>)

Default
values
are based
on the
format

B tru
e

m fal
se

Format Parameters

Parameter

Description

Valid /
Default
Values

<formatHeaderFile></formatHeaderFile> Configures the

XML file that
contains the log
header format
scheme.

If left empty, uses
the default
settings.

Default
values are
based on
the format
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SmartView Link Parameters

Valid / Default

Parameter Description

aramete escriptio Values

export log Adds a field to the exported log that represents a B true

link link to SmartView that shows the log card. B false
(default)

export Adds a field to the exported log that represents a B true

attachment link to SmartView that shows the log card and B false

link automatically opens the attachment. (default)

export link | Makes the above two links use a customized IP = |Pv4

ip address (for example, for a NATed Log Server). address

= empty

(default)

Filter Parameters

This configuration allows Log Exporter instance to filter out the Security Gateway traffic logs
for several Software Blades (VPN-1 & Firewall-1, HTTPS Inspection, and Security
Gateway/Management).

o Note:

® Security Gateway session logs are still exported (generated by tracking a
Security Gateway rule per session).

® HTTPS Inspection logs, Security Gateway logs generated not from rules, and
a few NAT update logs are still exported.

Valid / Default

Parameter Description

Values
<filter filter out Determines whether to filtered out the B true
by Access logs. ®m false
connection="false"> When set to true, VPN-1 & Firewall-1

logs are filtered out (HTTPS Inspection
logs are still exported).

Note - These are the only Software
Blade filters currently supported.
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Format Configuration
The Log Exporter format configuration is saved in these files:

SEXPORTERDIR/targets/<Name of Log Exporter
Configuration>/conf/*FormatDefinition.xml

o Important - Do not edit the original *FormatDefinition.xml files. Doing so
causes a data loss after an upgrade. Instead, create a copy of the file and modify
the copied file, while leaving the original intact. After modifying the copied file, refer
to it (using a full path) in the <formatHeaderFile> elementin the applicable
targetConfiguration.xml file.

Body

LEE Gen LogR

Parameter RSA

F eric  hythm

<start The (
message charact
body></start | erthat

message body> | preced
es the

log data
payloa
d.

<end message | The ]
body></end charact
message body> | erthat
follows
the log
data
payloa
d.

<message The &#10; &#1 &#1 &#1 (
separator></ delimet (&#10;= | O; 0; 0; n'
message er that ='\n") (
separator> separat n'
es logs.

~ /
[>g]
+=
'_\
(@)
~.
g}
=
'_\
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Parameter
<fields The g | SR ISV b
separatator> | delimet | (semi (pip | (spa | 9; (spa | (pipe) | (spa
</fields erthat | colon, e) |ce) |(<T |ce) ce)
separatator> | separat | space) A

es log B>)

fields.

<field value_ | The : = = = = = =
separatator> asggn
</field ment
value operato
separatator> r.

<value The " " "
encapsulatio value

n_ encaps

start>&quot; ulation

</value operato

encapsulatio | r(start).

n start>

<value The " " "
encapsulatio value

n_ encaps

start>&quot; ulation

</value operato

encapsulatio | r(end).

n start>

R82 Logging and Monitoring Administration Guide | 264



Parameter

Log Exporter Advanced Configuration Parameters

<escape
chars>
<char>
<orig></
orig>
<escaped
></escaped>
</char>
</escape
chars>

To g === = 17\ = -
escape | \\ ->
unwant " \\ \= A\
ed "
charact | \" = - | = -
ers. -> -> 0; ->
The
escape | ->
functio
nality ]
replace
s the v v v
string
that is | -
encaps -
ulated \ |
by the
orig
tags

with the
string
encaps
ulated
by the
escap
ed

tags.

Header

Parameter

<header

format></header

format>

Default

Description values

for sysl

The delimeter between the header
values and the number of values.
Every {} is replaced with one value.

"' (space) | |

Default
values
for CEF
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o Notes:

® To add a constant string to the header, add the string to the <header
format> tag value.

® To add a new field to the header, add a new header format replacement
string (for example: { }) to the <header format>tagand addthe
applicable information in the <headers> tag.
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Field Mapping Configuration

Every format has its own predefined fields configuration file that allow to change the name /
value of the exported field, filter out irrelevant fields, and so on.

The Log Exporter format configuration is saved in these files:

SEXPORTERDIR/targets/<Name of Log Exporter
Configuration>/conf/*FieldsMapping.xml

o Important - Do not edit the original *FieldsMapping. xml files. Doing so
causes a data loss after an upgrade. Instead, create a copy of the file and modify
the copied file, while leaving the original intact. After modifying the copied file, refer
to it (using a full path) in the <formatHeaderFile> elementin the applicable
targetConfiguration.xml file.

Valid / Default
Values

Parameter Description

<table> Some fields appear in the tables

based on the log format.

This information can be found in the
.elg logfile - one entry for every

new field.

A field can appear in multiple tables.

Each distinct instance is considered

a new field.
<exported></exported> Optional B true
You can use the exported true/false ®m false

tag in the mapping configuration file
to filter out specific fields.
Alternatively, if the
exportAllFields taginthe
targetConfiguration.xml file
is setto false, only those fields
which are listed in the mapping file
are exported.

<origName></origName> The name of the field that is mapped
to <dstName>

<dstName></dstName> The new mapping scheme name for
the applicable field.

<required></required> Optional ® true
When set to true, only logs that ®m false
contain this field are exported.
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Log Exporter Instructions for Specific SIEM

This section shows how to configure SIEM applications to receive logs optimally.

o Notes:

® When using Client Authentication, you must provide the absolute path to the
client certificate.
® Make sure the "Common Name" is unique in every certificate.

Rsyslog
Procedure

By default, Rsyslog is not configured to use the RFC 5424 timestamp format.

Therefore, you should manually change the setting on the Rsyslog server for it to be
compliant with the Log Exporter output format.

1. Editthe /etc/rsyslog.conf file

vi /etc/rsyslog.conf

2. Comment out this line (add the # character in the beginning), if it is not commented out
already:

#"SActionFileDefaultTemplate RSYSLOG TraditionalFileFormat"
3. Add this line in the file:
SActionFileDefaultTemplate RSYSLOG SyslogProtocol23Format

4. Save the changes in the file and exit the editor.

5. Restart the Rsyslog service:

service rsyslog restart

ArcSight

Procedure

ArcSight recommends to name the server certificate file as "syslog-ng".

To name the certificate:

Convert the key to the P12 format:
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openssl pkcsl2 -inkey syslogServer.key -in syslogServer.crt -
export -out syslog-ng.pl2 -name "syslogng-alias" -password
pass:changeit

To make sure the value of the environment variable ARCSIGHT_HOME is the
connector install directory:

1. Run the certificates manager on the Linux KDE console:

SARCSIGHT HOME/current/bin/arcsight agent keytoolgui
2. From the File menu, open the keystore:

SARCSIGHT HOME/current/jre/lib/security/cacerts

The password "changeit".
3. From the menu, select Import Trusted Certificate.
4. From the file dialog, select Ca.pem and save it.

5. Save the changes and close the certificate manager.
To edit the "agent.properties" file to enable mutual authentication:
1. Edit the file:
vi SARCSIGHT HOME//current/user/agent/agent.properties
2. Change this value to true:
syslogng.mutual.auth.enabled=true
3. Add these lines to the end:

syslogng.tls.keystore.file=user/agent/syslog-ng.pl2

syslogng.tls.keystore.alias=syslogng-alias
4. Restart the connector service:

/etc/init.d/arc _connector name restart
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Splunk

Procedure
1. Generate the server certificate file in the PEM format:

cat syslogServer.crt syslogServer.key RootCA.pem >

splunk.pem

2. Update the inputs.conf file on the Splunk server:

a. Editthefile:

vi /opt/splunk/etc/apps/<Name of the app, where the

configuration is saved>/local/inputs.conf

b. Configure these settings to use TLS:

[SSL]
serverCert = <Full path to CA PEM file>
sslPassword = <Challenge Password>
requireClientCert = true

[tcp-ssl://<Port>]
index = <Index>

c. Save the changes in the file and exit the editor.

3. Update the server. conf file on the Splunk server:

a. Edit the file:

vi /opt/splunk/etc/system/local/server.conf

b. Configure these settings:

[sslConfig]
sslRootCAPath = <Full path to CA PEM file>

[SSL]

cipherSuite = TLSv1+HIGH:TLSv1.2+HIGH:(@STRENGTH

c. Save the changes in the file and exit the editor.

4. Restart the Splunk service:

/opt/splunk/bin/splunk restart
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QRadar

Procedure

1. In the Authentication Mode field, select TLS And Client Authentication.

When you use Client Authentication, you must provide the absolute path to the client
certificate.

2. Upload the Check Point certificate and private key to QRadar to the same directory.

3. Enter the absolute path to the uploaded files in the Provide Certificate option.

Add a log source

Log Source Name

Log Source Description

Log Source Type Check Point M
Protocol Configuration TLS Syslog j

Log Source Identifier

TLS Listen Port 0 6514

Authentication Mode € TLS And Client Authentication j
Client Certificate Path €

Certificate Type € Provide Certificate j
Provided Server Certificate Path )

Provided Private Key Path @)

Maximum Connections € 50

TLS Protocols TLS 1.2 and above j
Enabled

Credibility 5 j

Target Event Collector eventcollector0 :: bizdev j
Coalescing Events
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Transition from LEA to Log Exporter

To move from the existing LEA connector to the new Log Exporter:

1. In SmartConsole, delete the OPSEC application object if it is the only use for the OPSEC
application. If not, remove the LEA client entity.

OPSEC Application Properties - OpsecApp &

| General AMON Options ._

Name: OpsecApp
Comment:
|| oo -
Host: L] opsecHost v [ New.
Application properties
Vendor: [User defined 4 ]
Product: Version:
Server Entities Client Entities
Flcve ‘ [@ELA
TJUFP V|LEA
[V]AMON )SAM
[1cPmMi
JOMI
|UAA
Serure Intemal Cammunicatinn

2. Ifthis is the only OPSEC LEA client, configure the SFWDIR/conf/fwopsec.conf file
to not allow LEA:

a. Connect to the command line on the Management Server / Log Server with Log
Exporter.

b. Login to the Expert mode.

c. Back up the current file:

cp -v SFWDIR/conf/fwopsec.conf{, BKP}
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d. Editthe currentfile:
vi SFWDIR/conf/fwopsec.conf

e. Comment out these lines (add the # character in the beginning):

lea server auth port 18184 | # lea server auth port 18184

lea server port 0 # lea server port 0

f. Save the changes in the file and exit the editor.
3. Configure the Log Exporter settings in one of these ways:
® |n SmartConsole - "Configuring Log Exporter in SmartConsole" on page 227

® |n CLI - see "Configuring Log Exporter in CLI" on page 230

o Note - Reading logs through LEA, which were configured manually in the SmartLog
custom settings file, is not available in R80.x.
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Transition from CPLogToSyslog to Log Exporter

To move from the existing CPLogToSyslog to the new Log Exporter:
1. Use CPUSE to uninstall the CPLogToSyslog package. See section 4-C in sk92449.
2. Configure the Log Exporter settings in one of these ways:
® |n SmartConsole - "Configuring Log Exporter in SmartConsole" on page 227

® |n CLI - see "Configuring Log Exporter in CLI" on page 230
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Log Exporter - Appendix
Special Log Fields

Field Description

loguid Log Unification ID.

Some Check Point logs are updated over time.

Updated logs have the same Log UID value.

Check Point SmartLog client correlates those updates into a single unified log.
When the update logs are sent to 3rd party servers, they arrive as distinct logs.
Administrators can use the "1oguid" field to correlate updated logs and get the
full event chain.

Note - Log Exporter's new semi-unified mode correlates all previous logs into
one, so the latest log always shows the complete data.

Examples of updated logs:

® The total amount of bytes sent and received over time.
® The severity field which is updated over time as more information
becomes available.

hll_key High Level Log Key.

This concept was introduced in R80.10.

Multiple connection logs can comprise one session with one shared HLL Key.
For example, when you browse to a webpage, the Security Gateway may
generate multiple connection logs which are related to the same session.
Connection logs which are part of the same session share the same "h11 key"
value.

Syslog-NG Listener Configuration

We recommend you use the syslog-protocol flag when you configure a source on a Syslog NG
server.

For example:

source s network { network(transport ("tcp") port(514) flags
(syslog-protocol) ); };
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Splunk Listener Configuration

We recommend that you add these time settings to your "sourcetype":

B TIME FORMAT =

o0

S
® TIME PREFIX = time=

® MAX TIMESTAMP LOOKAHEAD = 15
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ArcSight Listener Configuration

The Log Exporter solution does not work with the OPSEC LEA connector. Instead, you must
install the ArcSight Syslog-NG connector.

ArcSight Common Event Format (CEF) Mapping

CEF is an extensible, text-based format that supports multiple device types by offering the
most relevant information. Message syntax is reduced to work with ESM normalization.
Specifically, CEF defines a syntax for log records comprised of a standard header and a
variable extension, formatted as key-value pairs. The CEF format can be used with on-
premises devices by implementing the ArcSight Syslog SmartConnector. CEF can also be
used by cloud-based service providers by implementing the SmartConnector for ArcSight
Common Event Format REST.

CEF Header Format
eDewc Device
Produ Event Class Name Severity
ID
(o
Defau | CEF:0 | Check | Log Check | Log Log 0
It Point Updat | Point
e
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Devic

o Device
: Event Class Name Severity
Versi
ID
(o]
Value | - - Produ | - = Attack
S ct Name ® Protect
Name ® Protect . .
(Blad ion lon " Applic
e) Type _ ;l\am-e at.lon
® Verdict ppllc R!Sk
= Match ation ® Risk |
od Name ® Severit
Categ ® Messa y
ory ge Info
x DLP = S?[r)wc
Data u gervic
Type
® Applic ©
ation
Categ
ory
® Applic
ation
Proper
ties
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QRadar Log Event Extended Format (LEEF) Mapping

The LEEF is a customized event format for IBM Security QRadar.

LEEF Header Format
LEEI.: Vendor Product Version EventID
Version
Default LEEF:2.0 Check Log Update 1.0 Check Point Log
Point
Values - - Product Name - ® Protection
(Blade) Name
® Application
Name
B Action

Note - The time format is not compliant with the official LEEF format.

As there is currently no Epoch time format, Log Exporter with LEEF format is only partially
supported.
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Logs in Milliseconds

Many users export logs to third parties. In some cases, the volume of logs is so large that
several logs arrive all at the same second. To construct a chain of events from the logs’ arrival,
you must know the specific order the logs arrive. Now you can send the time of arrival in a
format that includes milliseconds.

Logs in milliseconds is intended for customers who:
® Use Log Exporter.
® Have environments with high logging rates.

This feature is disabled by default.

To control the feature on the Security Gateway side:

Note - This procedure restarts the FWD process.
1. Connect to the command line on the Security Gateway / each Cluster Member.
2. Login to the Expert mode.

3. Gotothe SFWDIR/scripts/ directory:

cd $SFWDIR/scripts/

4. Run the script with the applicable parameter:
enable disable time in milli.sh {1 | 0}

® To enable the feature, run the script with the value 1.

® To disable the feature, run the script with the value 0.

To control the feature on the Log Server side:
1. Connect to the command line on the Log Server.
2. Login to the Expert mode.

3. To create a new exporter to export logs with the milliseconds format, run these
commands:

cp_log export add name <Name of Exporter> target-server <IP
Address of Target Server> target-port <Port Number on Target
Server> protocol {tcp | udp} time-in-milli {true | false}

cp_log export restart name <Name of Exporter>

R82 Logging and Monitoring Administration Guide | 280



Logs in Milliseconds

4. To modify an existing exporter to export logs with the milliseconds format, run these
commands:

cp_log export set name <Name of Exporter> time-in-milli {true
| false}

cp_log export restart name <Name of Exporter>

After Log Exporter is configured to export logs in milliseconds, the additional field is added to
the time field.

Logs from Security Gateways without this feature enabled are exported with the value 000 for
the additional time field.
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APl for Logs

Overview

API for Logs lets you use a single management APl command to query for logs or top
statistics. The API uses the same filter parameters as entered in the SmartConsole Logs tab
search bar (see Configuration below).

Use Case

For customers who do not have access to SmartConsole and are familiar with using
management APIs. The API for logs can be used inside a customer's automation script to get
logs and run statistics on the logs without the need to access SmartConsole.

Run the APl on the Management Server to get the logs from the environment.
With API for Logs, you can:
® Fetch Logs:

You can fetch logs from any Log Server in the environment with a single management
API command.

Optional query parameters include: Matching logs with all fields in JSON
» Logs type: Traffic / Audit format.
o Time-frame
» Filter criteria - Equivalent to query line in
SmartConsole.
» Query from specific Log Servers.
» Limit results count

= Page through Logs:

Logs are fetched in small chunks (default and max limit is 100) so queries do not
overload the Log Server.

The first "page" of results shows a limited number of logs.

To get the next set of results from a previously run query, enter the query-id from the
APl command.

= Get Top Statistics:

Query for the top statistics for multiple fields, including top sources and top destinations.
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® Fetch Log Attachments:
® Eachlogin a query response indicates whether it contains an attachment.
An attachment can be a packet capture or Threat Emulation report.

® Another APl command ("Log Attachments API" on page 286) fetches the
attachment by log ID, and returns all the attachments in a single JSON response.

® Generate APl Commands in SmartConsole:

In SmartConsole, click the button to generate an APl command according to the
currently presented query in the Logs tab.

This includes:
e Time-frame.
» Selected log servers.
« Filter criteria - Query line.
 Limit of 50 results by default.
The mechanism for API for logs is the same as for SmartConsole log queries.

Permissions are enforced according to the logged in user profile.

Configuration

For a new logs query:

mgmt cli show-logs new-query.filter product:<product name> new-
query.time-frame <time-frame> new-query.max-logs-per-request
<limit>

Parameter Description
filter The filter as entered in SmartConsole/SmartView.
Type: String
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Parameter Description

time-frame Specify the time frame to query logs.
Valid values:

last-7-days
last-hour
today
last-24-hours
yesterday
this-week
this-month
last-30-days
all-time
custom

Default: last-7-days
Type: String

custom-start Type: String
Must be in ISO861 format.

custom-end Type: String
Must be in ISO861 format .

max-logs-per-request | Valid values: 1-100
Default: 10
Type: String

type Type of logs to return
Valid values: logs, audit
Default: logs

Type: String

log-servers List of IPs of log servers to query
Default: all
Type: String

To get results for custom time frames:

mgmt cli show logs new-query.time-frame "custom" new-query.custom-
start YYYY-MM-DD new-query.custom-end YYYY-MM-DD
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To get results for top statistics:

mgmt cli show-logs new-query.filter product:<product name> new-
query.top.field blades new-query.top.count <number> --format json
-r true

Parameter Description

count Valid values: 1-50
Type: String

field Valid values:

sources
destinations
services
actions
blades
origins
users
applications

Type: String

To get more results for an existing query:

mgmt cli show-logs query-id <query-id> --session-id <session-id>

Parameter Description

query-id Get the next page of the last run query with a specified limit.
Type: String

ignore-warnings | Ignore warnings if they exist.
Type: Boolean

Limitations

® The parameter "time-frame" in the APl command does not accept this format as input:

yyyymmddThhmmss 2z

® The command does not support non-index mode log queries.
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Log Attachments API

Log Attachments API provides an automated way to fetch log attachments. Each blade has its
own type of attachments. For example, IPS logs contain packet captures, and Threat
Emulation logs contain a summary report. Logs are not usually exported with all their
attachments to save traffic load.

Use Cases:
This feature is intended for users who:

® Use Log Exporter to get log attachments in an external syslog system and use specific
scripts in their automation process.

® Use Log Exporter and do not have (or want to provide) SmartConsole access to end
users.

® Use API for Logs.
Log Attachments API supports all gateway versions.
There are two different modes to fetch log attachments:
® | og Exporter - Provides attachment ID.
= API for Logs - Log ID provided in the results.
Log Exporter

Log Exporter exports logs to a third party SIEM and adds an identifier called log-attachment-id
which represents all attachment IDs, separated by a space. Log Exporter has a new parameter
which lets you export the attachment-id.

You get the identifier and use it to get a json response with the desired attachment. The json
format contains encoded base64 data of the attachment and must be decoded and putin a
specified destination folder so it can be used.

To get a log attachment using Log Exporter, run these commands:

1. cp log export set name <name> [domain-server <domain-server>]
export-attachment-ids true

2. cp_log export restart name <name> [domain-server <domain-server>

3. mgmt cli get-attachment attachment-id ”“<id from the exported
log’>”
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To disable Log Exporter from exporting attachment IDs, run these commands:

1. cp _log export set name <name> [domain-server <domain-server>]
export-attachment-ids false

2. cp_log export restart name <name> [domain-server <domain-
server>|

API for Logs

Run a query for logs on the Management Server. In the json response, there is a field “id” for
each log in the response. After you have the log-id, run the log attachments API and get all the
attachments for that log.

To get an attachment for one of the log results:
1. Use the management API to fetch logs:
Run:mgmt cli show-logs

2. Runimgmt cli get-attachment id “<log id from the previous
response>”
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Command Line Reference

See the R82 CL| Reference Guide.
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Appendix: Manual Syslog Parsing

Many third-party devices use the syslog format to log. The Log Server reformats the raw data
to the Check Point log format to process third-party syslog messages. SmartEvent can take
the reformatted logs and convert them into security events.

You can use the Log Parsing Editor to make a parsing file (see "Importing Syslog Messages"
on page 52). As an alternative you can manually create a parsing file. This section shows you
how to do that.

0 Warning - Manual modifications to out-of-the-box parsing files cannot be preserved
automatically during an upgrade. Mark your modifications with comments so you can
remember what changed.

Planning and Considerations

1. Learn the accurate structure of the logs the device generates with these guides.

a. The vendor logging guide, or other documentation that specifies the logs the
device can generate and their structure. Documentation is important to make
sure that you found all possible logs. Usually it is sufficient to write the parsing
file.

b. Log samples, as many as possible. Use logs generated from the actual devices
to be used with SmartEvent. Samples are important to examine the parsing file
and to tune it accordingly.

2. Learn and know "The Free Text Parsing Language" on page 294 and the necessary
parsing files and their location on the Log Server (see "The Parsing Procedure" on
page 306).

3. Compare existing parsing files of an equivalent product.

4. Select the fields to extract from the log. The fields to extract are different from one device
to another. But devices of the same category usually have equivalent log fields. For

example:
Device Type Typical Log Fields
Firewall, router and other source |IP address, destination IP address, source
devices that send connection port, destination port, protocol, accept/reject
based logs indication
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Device Type Typical Log Fields
IDS / IPS, application Firewall attack name/ID
and other devices that send

attack logs
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The Parsing Procedure

The procedure occurs on the Log Server and starts with the syslog daemon. The syslog
daemon that runs on the Log Server receives the syslogs and calls for their parsing. The
parsing involves many parsing files, which contain the different parsing definitions and
specifications, and can be found in the $FWDIR/conf/syslog/ directory. In these files there are
the device-specific parsing files, which define the actual parsing and extraction of fields,
according to each device specific syslog format.

The parsing starts with the syslog_free_text_parser.C file. This file defines the different
"Dictionary" on page 305 terms and parses the syslog. The file extracts fields, which are
common to all syslog messages (such as PRI, date and time), and the machine and
application that generated the syslog.

The syslog_free_text_parser.C file uses the allDevices.C file (which refers to two files:
UserDefined/UserDefinedSyslogDevices.C and CPdefined/CPdefinedSyslogDevices.C).

® The first file (UserDefined/UserDefinedSyslogDevices.C) contains the names of the
devices parsing files that the user defines.

® The second file (CPdefined/CPdefinedSyslogDevices.C) contains devices parsing files
that Check Point defines.

The allDevices.C file goes over the device parsing files, and tries to match the incoming
syslog with the syslog format parsed in that file.

After the parsing-file succeeds in the preliminary parsing of the syslog (that is, it matches the
syslog format and is therefore the syslog origin), the remaining of the syslog is parsed in that
file. If a match is not found, the file will continue to go over the Check Point device parsing files
until it finds a match.
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Manual Syslog Parsing

To parse a syslog file:

1.
2.
3.

5.

Create a new parsing file called <device product name>.C.
Put this file in the directory $FWDIR/conf/syslog/UserDefined on the Log Server.

On the Log Server, edit the file
$FWDIR/conf/syslog/UserDefined/UserDefinedSyslogDevices.C to add a line that
includes the new parsing file. For example:

(

:command (
:cmd name (include)
:file name ("snortPolicy.C")

)

. Optional: If required.

a. Create a new dictionary file called <device product name>_dict.ini. See
"Dictionary" on page 305.

b. Putitin the directory $FWDIR/conf/syslog/UserDefined on the Log Server.

A dictionary translates values with the same meaning from logs from different
devices into a common value. This common value is used in the Event Definitions.

c. Editthe file
$FWDIR/conf/syslog/UserDefined/UserDefinedSyslogDictionaries.C on the Log
Server.

d. Add a line to include the dictionary file. For example:

:filename ("snort dict.ini")

To examine the parsing, send syslog samples to a Check Point Log Server.

To send syslog samples:

1.

To configure the Log Server to accept syslogs, connect to the Security Management
Server with SmartConsole.

In Logs and Masters > Additional Logging Configuration, enable the property Accept
Syslog messages.

Edit the Log Server network object.
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4. Runthe commands cpstop & cpstart, orfwkill fwd & fwd -n.
The fwd procedure on the Log Server restarts.
5. Send syslogs from the device itself, or from a syslog generator.

For example: Kiwi Syslog Message Generator, available at
http://www.kiwisyslog.com/software downloads.htm#sysloggen.

Troubleshooting:

If SmartConsole does not show the logs as expected, there can be problems with the parsing
files:

® |f there is a syntax error in the parsing files, an error message shows. To read a specified
error message, set the TDERROR_ALL_FTPARSER value to 5 before you run the
procedure fwd -n.

® |f the syslogs show in SmartConsole with 'Product syslog', the log was not parsed
properly, but as a general syslog.

® |f the Product field contains another product (not the one you have just added) this
means there is a problem with the other product parsing file. Report this to the Check
Point SmartEvent team.

® |f the product reports correctly in the log, look for all the fields you extracted. Some of
them are in the Information section. Some fields can be seen only when you select More
Columns.
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The Free Text Parsing Language

The free text parsing language enables to parse an input string, extract information, and define
log fields. These log fields which show as part of the Check Point log in the Log Server. They
are used in the definition of events. Each parsing file contains a tree of commands. Each
command examines or parses part of the input string (sometimes it adds fields to the log as a
result), and decides if to continue to parse the string (according to the success/failure of its
execution).

The Commands

Each command consists of these parts:
® cmd name - the name of the command.
® command arguments - arguments that define the behavior of the command.

® on success (optional) - the next command executed if the current command execution
succeeds.

" on fail (optional) - the next command executed if the current command execution
fails.

Sample

:command (
:cmd_name (try)
:try_arguments

ton_success (
:command ()
)
con_fail (
:command ()
)
)
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Try

The try command matches a regular expression against the input string.

'Try' Command Parameters

Argument Description

parse start position -runthe regular expression from the start of the input
from string.

last position -run the regular expression from the last position of the
previous successful command.

regexp The regular expression to match.

add_field | One or more fields to add to the result (only if the regular expression is
successful).

"Try' Command - Sample

:command (
:cmd_name (try)
:parse_from (start_position)
crregexp (" ([0-9]+\.[0-9]+\.[0-9]1+\.[0-9]+)"™)
radd_field (
:type (index)
:field name (Src)
:field type (ipaddr)
:field index (1)
)
)

In the above example, we try to match the regular expression" ([0-9]+\. [0-9]+\. [0-
9]+\.[0-9]+)"thatlooks at the entire log (parse from (start position))-parse
from the start of the log). If the regular expression is matched, we add a source field.
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Group_try
The command group try executes one or more commands in one of these modes:

® "try all"tries all commands in the group, and ignores the return code of the
commands.

B "try all successively"tries all the commands in the group, and ignores the return
code of the commands.

Each command tries to execute from the last position of the earlier successful command.
® "try until success"tries all the commands until one succeeds.
® "try until fail"tries all the commands until one fails.

The command "group try"is commonly used when it parses a "free-text" piece of a log,
which contains a number of fields we want to extract.

For example:

$PIX-6-605004: Login denied from 194.29.40.24/4813 to
outside:192.168.35.15/ssh for user 'root'

When you look at see this section of the log, you can use this structure:

'Group_try' Command - Sample 1

:command (

:cmd_name (group_try)

:mode (tryiallisuccessively)

: (
# A "try" command for the source.
:command ()

)

: (
# A "try" command for the destination.
:command ()

)

: (
# A "try" command for the user.
:command ()

)

In this example, the first try command in the "group try" block (for the source) is
executed.

If the source, destination and user are not in a specified sequence in the syslog, use the
"try all"modeinsteadof"try all successively".
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'Group_try' Command - Sample 2

In this example, the regular expressions in the different commands try to match more
specified logs.

At most, one command in the group try block will be successful.

When it is found, it is not necessary to examine the others:

:command (
:cmd_name (group_try)
:mode (try until success
= (

:command (

:regexp ("(\(|) (login|su) (\)|).* session (opened|closed) for user ([a-z,A-Z,0-9]%)")
)
)
< (

:command (

:regexp ("(\(l)su(\)|).* authentication failure; logname=([a-zA-Z0-9]%*).* user=([a-zA-Z0-9]*)")
)
)

Note - When you add a new device, the first "t ry" command in the parsing file must use the
"try until success" parameter:

:cmd_name (group_try)
:mode (try_until_success
s

?

)

Switch

This command enables to compare the result of a specified field against a list of predefined
constant values.

'Switch' Command Parameters

Parameter Description

Parameter Description
field name | The field name whose value is checked.
case One or more case attributes followed by the value with which to compare.

default Execute only if no relevant case is available. The default value is optional.
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'Switch' Command - Sample

:command (
:cmd_name (switch)
:field name (msgID)
< (
:case (302005)
:command ()

:case (302001)
:icase (302002)
:command ()
)
:default (
:command ()

)

Unconditional_try

This command is an "empty" command that allows you to add fields to the result without any
conditions.

'Unconditional_try' Command - Sample 1

:command (
:cmd_name (unconditional try)
radd_field (

:type (const)

:field name (product)

:field type (string)

:field value ("Antivirus")
)

A common usage of unconditional try is with the switch command.

'Unconditional_try' Command - Sample 2

In this example, each message ID is attached with its corresponding "message" field which
denotes its meaning.

:command (

:cmd_name (switch)

:field name (msgID)

(

:case (106017)

:command (
:cmd_name (unconditional try)
radd_field (
:type (const)
:field name (message)
:field type (string id)
:field value ("LAND Attack")
)

)

)

: (

:case (106020)

:command (
:cmd_name (unconditional try)
radd_field (
:type (const)
:field name (message)
:field type (string id)
:fieldivalue ("Teardrop Attack™)
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Include

This command enables the inclusion of a new parsing file.

file The full path plus the file name of the file to be
name included.

'Include’ Command - Sample

:command (

:cmd_name (include)

:file_name ("c:\freeTextParser\devicelantivirusPolicy.C")
)

Add_field

Each"add field"has some parameters:

" Type - The type of the "add field" command. This parameter has these possible
values:

* Index - Part of the regular expression will be extracted as the field. The "field
index" value denotes which part will be extracted (see "field index" bullet).

» Const - Add a constant field whose value does not depend on information
extracted from the regular expression. See field value bullet.

= field_name - the name of the new field.

There are some fields, which have corresponding columns in SmartConsole > Logs &
Events > Logs.

This table shows the names to give these fields to show in their Logs & Events > Logs
column (and not in the Information field, where other added fields appear):

Field Name to be Given Column in Logs & Events > Logs

Src Source

Dst Destination

proto Protocol

s_port Source Port

product Product

service Service (when resolved includes the port
and protocol.)
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Field Name to be Given Column in Logs & Events > Logs

Action Action
ifname Interface
User User

When you name the above fields accordingly, they are placed in their correct column in
Logs & Events > Logs.

This enables them to participate in all filtering done on these columns. These fields
automatically take part in existing event definitions with these field names.

= field_type - the type of the field in the log.

This table shows the possible field types.

Field Type Comment

int

uint

string

ipaddr For IP addresses used with the Src and Dst fields.

pri Includes the facility and severity of a syslog.

timestmp Includes the date and time of the syslog. Supports the format 'Oct 10
2019 15:05:00'.

time Supports the format '15:05:00'.

string id | Fora more efficient usage of strings. Used when there is a finite
number of possible values for this field.

action Supports these actions: drop, reject, accept, encrypt, decrypt,
vpnroute, keyinst, authorize, deauthorize, authcrypt, and default.

ifdir 0 - inbound

1 - outbound
ifname For an interface name (used with the "ifname" field).
protocol The field name should be "proto".
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Comment

port

For "service", "s_port" or "port" fields.

The field type of the field names in this table must be as mentioned:

Field Name Field Type

Src

Dst
proto

S port
service
Action

ifname

ipaddr
ipaddr
protocol
port
port
action

ifname

® field_index or field_value - The parameter used depends on the value of the "t ype"

field.

 Ifthe "type"field isindex, the"field index"shows.

 Ifthe "type"field is const, the "field value"shows.

The"field index" denotes which part of the regular expression is extracted,
according to the grouping of the patterns.

To make this grouping, write a certain expression in brackets.

In this expression, the number inthe "field index" denotes the bracket number
whose pattern is taken into account.
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'Add_field' Command - Sample 1

:command (

:cmd_name (try)

:parse_from (last_position)

:regexp ("Failed password for ([a-zA-Z0-9]+) from ([0-9]1+\.[0-9]1+\.[0-9]+\.[0-9]+) port ([0-9]+)")

radd_field (
:type (index)
:field name (User)
:field type (string)
:field index (1)
)

radd_field (
:type (index)
:field name (Src)
:field type (ipaddr)
:field index (2)

)

radd_field (
:type (index)
:field name (port)
:field type (port)
:field index (3)

)

)

The pattern for the User, "[a-zA-2Z0-9]+", is located in the first pair of brackets.
Therefore, the "field index"isone.

The pattern for the Source address, "[0-9]+\. [0-9]+\. [0-9]+\.[0-9]+",is
located in the second pair of brackets. Therefore, the index is two.

The pattern for the port is in the third pair of brackets.

In each parsed regular expression the maximum number of brackets must be up to
nine.

To extract more than nine elements from the regular expression, break the expression
into two pieces.

The first regular expression contains the first nine brackets.

The remaining of the regular expression is in the "on success" command.
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:command (
:cmd_name (try)
:parse_from (start_position)
:regexp ("access-list (.*) (permitted|denied|est-allowed) ([a-zA-Z0-9_\([a-zA-20-9 \\.[0-9]+\.[0-91+\.[0-9]1+)\(([0-9]*)\)
=> "))
radd_field (
:type (index)
:field name (listID
:field type (string)
:field index (1)
)
radd_field (
:type (index)
:field name (action)
:field type (action)
:field index (2)
)
radd_field (
:type (index)
:field name (proto)
:field type (protocol)
:field index (3)
)
radd_field (
:type (index)
:field name (ifname)
:field type (ifname)
:field index (4)
)
radd_field (
:type (index)
:field name (Src)
:field type (ipaddr)
:field index (5)
)
ton_success (
:command (
:cmd_name (try)
:parse_from (last_position)
:regexp (" ([a-zA-20-9 \\.[0-9]+\.[0-9]+\.[0-9]+)\ (([0-9]1*)\) hit-cnt ([0-9]+) ")
radd_field (
:type (index)
:field name (destination_interface)
:field type (string)
:field _index (1)
)
)

'Add_field' Command - Sample 2

The"field value"is the constant value to be added.

:command (
:cmd_name (try)
:parse_from (last_position)
:regexp ("SPIX-([0-9])-([0-9]*)"))
radd_field (
:type (const)
:field name (product)
:field type (string_id)
:field value ("CISCO PIX")

® dict_name is the name of the dictionary to use to convert the value. If the value is not
found in the dictionary, the value is the result.

The free text parser enables us to use dictionaries to convert values from the log. These
conversions are used to translate values from logs from different devices, with the same
meaning, into a common value, which is used in the event definitions.

Each dictionary file is defined as an . ini file.

Inthe . ini file the section name is the dictionary name and the values are the dictionary
values (each dictionary can include one or more sections).

R82 Logging and Monitoring Administration Guide | 303



The Free Text Parsing Language

[dictionary name]
Namel = vall
Name2 = val2
[cisco_action]
permitted = accept
denied = reject

[3com_action]
Permit = accept
Deny = reject

'Add_field' Command - Sample 3

:command (
:cmd_name (try)
:parse_from (start_position)
:regexp ("list (.*) (permitted|denied) (icmp)
packet™)
radd_field (
itype (index)
:field name (action)
:field type (action)
:field index (2)

:dict_name (cisco_action)

([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+

->

([0=-9]1+\. [0-9]+\. [0-9]+\.[0-9]+) .*
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Dictionary

The free text parser enables us to use dictionaries to convert values from the log. These
conversions are used to translate values from logs from different devices, with the same
meaning, into a common value, which is used in the event definitions.

Each dictionary file is defined as an . ini file. Inthe . ini file the section name is the
dictionary name and the values are the dictionary values (each dictionary can include one or
more sections).

[dictionary name]

Namel = vall

Name2 = valZ2

[cisco_action] [3com action]

permitted = accept Permit = accept

denied = reject Deny = reject
Example

The reference to a dictionary in the parsing file is shown in this table:

:command (

:cmd name (try)

:parse from (start position)

:regexp ("list (.*) (permitted|denied) (icmp) ([0-9]+\.[0-
91+\.[0-9]1+\.[0-9]1+) -> ([0-91+\.[0-9]1+\.[0-9]+\.[0-9]+) .%
packet")

:add field (
:type (index)
:field name (action)
:field type (action)
:field index (2)
:dict name (cisco_action)
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The Parsing Procedure

The procedure occurs on the Log Server and starts with the syslog daemon. The syslog
daemon that runs on the Log Server receives the syslogs and calls for their parsing. The
parsing involves many parsing files, which contain the different parsing definitions and
specifications, and can be found in the $FWDIR/conf/syslog/ directory. In these files there are
the device-specific parsing files, which define the actual parsing and extraction of fields,
according to each device specific syslog format.

The parsing starts with the syslog_free_text_parser.C file. This file defines the different
"Dictionary" on page 305 terms and parses the syslog. The file extracts fields, which are
common to all syslog messages (such as PRI, date and time), and the machine and
application that generated the syslog.

The syslog_free_text_parser.C file uses the allDevices.C file (which refers to two files:
UserDefined/UserDefinedSyslogDevices.C and CPdefined/CPdefinedSyslogDevices.C).

® The first file (UserDefined/UserDefinedSyslogDevices.C) contains the names of the
devices parsing files that the user defines.

® The second file (CPdefined/CPdefinedSyslogDevices.C) contains devices parsing files
that Check Point defines.

The allDevices.C file goes over the device parsing files, and tries to match the incoming
syslog with the syslog format parsed in that file.

After the parsing-file succeeds in the preliminary parsing of the syslog (that is, it matches the
syslog format and is therefore the syslog origin), the remaining of the syslog is parsed in that
file. If a match is not found, the file will continue to go over the Check Point device parsing files
until it finds a match.
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A

Anti-Bot
Check Point Software Blade on a Security Gateway that blocks botnet behavior and
communication to Command and Control (C&C) centers. Acronyms: AB, ABOT.

Anti-Spam
Check Point Software Blade on a Security Gateway that provides comprehensive
protection for email inspection. Synonym: Anti-Spam & Email Security. Acronyms: AS,
ASPAM.

Anti-Virus

Check Point Software Blade on a Security Gateway that uses real-time virus signatures
and anomaly-based protections from ThreatCloud to detect and block malware at the
Security Gateway before users are affected. Acronym: AV.

Application Control
Check Point Software Blade on a Security Gateway that allows granular control over
specific web-enabled applications by using deep packet inspection. Acronym: APPI.

Audit Log
Log that contains administrator actions on a Management Server (login and logout,
creation or modification of an object, installation of a policy, and so on).

B

Bridge Mode
Security Gateway or Virtual System that works as a Layer 2 bridge device for easy
deployment in an existing topology.

C

Cluster
Two or more Security Gateways that work together in a redundant configuration - High
Availability, or Load Sharing.
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Cluster Member
Security Gateway that is part of a cluster.

Compliance
Check Point Software Blade on a Management Server to view and apply the Security

Best Practices to the managed Security Gateways. This Software Blade includes a
library of Check Point-defined Security Best Practices to use as a baseline for good
Security Gateway and Policy configuration.

Content Awareness
Check Point Software Blade on a Security Gateway that provides data visibility and
enforcement. Acronym: CTNT.

Cooperative Enforcement
Integration of an on-premises Harmony Endpoint Security Server and Security Gateway.

CoreXL
Performance-enhancing technology for Security Gateways on multi-core processing

platforms. Multiple Check Point Firewall instances are running in parallel on multiple
CPU cores.

CoreXL Firewall Instance
On a Security Gateway with CoreXL enabled, the Firewall kernel is copied multiple

times. Each replicated copy, or firewall instance, runs on one processing CPU core.
These firewall instances handle traffic at the same time, and each firewall instance is a
complete and independent firewall inspection kernel. Synonym: CoreXL FW Instance.

CoreXL SND
Secure Network Distributer. Part of CoreXL that is responsible for: Processing incoming
traffic from the network interfaces; Securely accelerating authorized packets (if
SecureXL is enabled); Distributing non-accelerated packets between Firewall kernel
instances (SND maintains global dispatching table, which maps connections that were
assigned to CoreXL Firewall instances). Traffic distribution between CoreXL Firewall
instances is statically based on Source IP addresses, Destination IP addresses, and the
IP 'Protocol' type. The CoreXL SND does not really "touch" packets. The decision to stick
to a particular FWK daemon is done at the first packet of connection on a very high level,
before anything else. Depending on the SecureXL settings, and in most of the cases, the
SecureXL can be offloading decryption calculations. However, in some other cases,
such as with Route-Based VPN, it is done by FWK daemon.
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CPUSE
Check Point Upgrade Service Engine for Gaia Operating System. With CPUSE, you can

automatically update Check Point products for the Gaia OS, and the Gaia OS itself.

Custom Report
User-defined report for a Check Point product, typically based on a predefined report.

D

DAIP Gateway
Dynamically Assigned IP (DAIP) Security Gateway is a Security Gateway, on which the
IP address of the external interface is assigned dynamically by the ISP.

Data Loss Prevention
Check Point Software Blade on a Security Gateway that detects and prevents the

unauthorized transmission of confidential information outside the organization. Acronym:
DLP.

Data Type
Classification of data in a Check Point Security Policy for the Content Awareness

Software Blade.

Distributed Deployment
Configuration in which the Check Point Security Gateway and the Security Management

Server products are installed on different computers.

Dynamic Object
Special object type, whose IP address is not known in advance. The Security Gateway
resolves the IP address of this object in real time.

E

Endpoint Policy Management
Check Point Software Blade on a Management Server to manage an on-premises

Harmony Endpoint Security environment.

Event
Record of a security or network incident that is based on one or more logs, and on a

customizable set of rules that are defined in the Event Policy.
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Event Correlation
Procedure that extracts, aggregates, correlates, and analyzes events from the logs.

Event Policy
Set of rules that define the behavior of SmartEvent.

Expert Mode
The name of the elevated command line shell that gives full system root permissions in

the Check Point Gaia operating system.

G

Gaia
Check Point security operating system that combines the strengths of both
SecurePlatform and IPSO operating systems.

Gaia Clish
The name of the default command line shell in Check Point Gaia operating system. This
is a restricted shell (role-based administration controls the number of commands
available in the shell).

Gaia Portal
Web interface for the Check Point Gaia operating system.

H

Hotfix
Software package installed on top of the current software version to fix a wrong or
undesired behavior, and to add a new behavior.

HTTPS Inspection
Feature on a Security Gateway that inspects traffic encrypted by the Secure Sockets

Layer (SSL) protocol for malware or suspicious patterns. Synonym: SSL Inspection.
Acronyms: HTTPSI, HTTPSI.
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ICA
Internal Certificate Authority. A component on Check Point Management Server that
issues certificates for authentication.

Identity Awareness
Check Point Software Blade on a Security Gateway that enforces network access and

audits data based on network location, the identity of the user, and the identity of the
computer. Acronym: IDA.

Identity Logging
Check Point Software Blade on a Management Server to view Identity Logs from the
managed Security Gateways with enabled Identity Awareness Software Blade.

Internal Network
Computers and resources protected by the Firewall and accessed by authenticated

users.

IPS
Check Point Software Blade on a Security Gateway that inspects and analyzes packets

and data for numerous types of risks (Intrusion Prevention System).

IPsec VPN
Check Point Software Blade on a Security Gateway that provides a Site to Site VPN and

Remote Access VPN access.

Jumbo Hotfix Accumulator
Collection of hotfixes combined into a single package. Acronyms: JHA, JHF, JHFA.

K

Kerberos
An authentication server for Microsoft Windows Active Directory Federation Services

(ADFS).
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Log Server
Dedicated Check Point server that runs Check Point software to store and process logs.

Logging & Status
Check Point Software Blade on a Management Server to view Security Logs from the

managed Security Gateways.

M

Management Interface
(1) Interface on a Gaia Security Gateway or Cluster member, through which

Management Server connects to the Security Gateway or Cluster member. (2) Interface
on Gaia computer, through which users connect to Gaia Portal or CLI.

Management Server
Check Point Single-Domain Security Management Server or a Multi-Domain Security

Management Server.

Manual NAT Rules
Manual configuration of NAT rules by the administrator of the Check Point Management

Server.

Mobile Access
Check Point Software Blade on a Security Gateway that provides a Remote Access VPN

access for managed and unmanaged clients. Acronym: MAB.

Multi-Domain Log Server
Dedicated Check Point server that runs Check Point software to store and process logs

in a Multi-Domain Security Management environment. The Multi-Domain Log Server
consists of Domain Log Servers that store and process logs from Security Gateways that
are managed by the corresponding Domain Management Servers. Acronym: MDLS.

Multi-Domain Server
Dedicated Check Point server that runs Check Point software to host virtual Security

Management Servers called Domain Management Servers. Synonym: Multi-Domain
Security Management Server. Acronym: MDS.
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N

Network Object
Logical object that represents different parts of corporate topology - computers, IP
addresses, traffic protocols, and so on. Administrators use these objects in Security
Policies.

Network Policy Management
Check Point Software Blade on a Management Server to manage an on-premises
environment with an Access Control and Threat Prevention policies.

O

Open Server
Physical computer manufactured and distributed by a company, other than Check Point.

P

Predefined Report
Default report included in a Check Point product that you can run right out of the box.

Provisioning
Check Point Software Blade on a Management Server that manages large-scale
deployments of Check Point Security Gateways using configuration profiles. Synonymes:
SmartProvisioning, SmartLSM, Large-Scale Management, LSM.

Q

QoS
Check Point Software Blade on a Security Gateway that provides policy-based traffic

bandwidth management to prioritize business-critical traffic and guarantee bandwidth
and control latency.
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R

Report
Summary of network activity and Security Policy enforcement that is generated by Check
Point products, such as SmartEvent.

Rule
Set of traffic parameters and other conditions in a Rule Base (Security Policy) that cause

specified actions to be taken for a communication session.

Rule Base
All rules configured in a given Security Policy. Synonym: Rulebase.

S

SecureXL
Check Point product on a Security Gateway that accelerates IPv4 and IPv6 traffic that

passes through a Security Gateway.

Security Gateway
Dedicated Check Point server that runs Check Point software to inspect traffic and

enforce Security Policies for connected network resources.

Security Management Server
Dedicated Check Point server that runs Check Point software to manage the objects and

policies in a Check Point environment within a single management Domain. Synonym:
Single-Domain Security Management Server.

Security Policy
Collection of rules that control network traffic and enforce organization guidelines for

data protection and access to resources with packet inspection.

SIC
Secure Internal Communication. The Check Point proprietary mechanism with which

Check Point computers that run Check Point software authenticate each other over SSL,
for secure communication. This authentication is based on the certificates issued by the
ICA on a Check Point Management Server.
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SmartConsole
Check Point GUI application used to manage a Check Point environment - configure

Security Policies, configure devices, monitor products and events, install updates, and
soon.

SmartDashboard
Legacy Check Point GUI client used to create and manage the security settings in

versions R77.30 and lower. In versions R80.X and higher is still used to configure
specific legacy settings.

SmartEvent Correlation Unit
SmartEvent software component on a SmartEvent Server that analyzes logs and detects

events.

SmartEvent Server
Dedicated Check Point server with the enabled SmartEvent Software Blade that hosts

the events database.

SmartProvisioning
Check Point Software Blade on a Management Server (the actual name is
"Provisioning") that manages large-scale deployments of Check Point Security
Gateways using configuration profiles. Synonyms: Large-Scale Management,
SmartLSM, LSM.

SmartUpdate
Legacy Check Point GUI client used to manage licenses and contracts in a Check Point

environment.

Software Blade
Specific security solution (module): (1) On a Security Gateway, each Software Blade

inspects specific characteristics of the traffic (2) On a Management Server, each
Software Blade enables different management capabilities.

Standalone
Configuration in which the Security Gateway and the Security Management Server

products are installed and configured on the same server.

System Counter
SmartView Monitor data or report on status, activity, and resource usage of Check Point

products.
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T

Threat Emulation
Check Point Software Blade on a Security Gateway that monitors the behavior of files in

a sandbox to determine whether or not they are malicious. Acronym: TE.

Threat Extraction
Check Point Software Blade on a Security Gateway that removes malicious content from

files. Acronym: TEX.

U

Updatable Object
Network object that represents an external service, such as Microsoft 365, AWS, Geo

locations, and more.

URL Filtering
Check Point Software Blade on a Security Gateway that allows granular control over

which web sites can be accessed by a given group of users, computers or networks.
Acronym: URLF.

User Directory
Check Point Software Blade on a Management Server that integrates LDAP and other

external user management servers with Check Point products and security solutions.

\Y

VSX
Virtual System Extension. Check Point virtual networking solution, hosted on a computer
or cluster with virtual abstractions of Check Point Security Gateways and other network
devices. These Virtual Devices provide the same functionality as their physical
counterparts.

VSX Gateway
Physical server that hosts VSX virtual networks, including all Virtual Devices that provide

the functionality of physical network devices. It holds at least one Virtual System, which
is called VSO.
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y4

Zero Phishing
Check Point Software Blade on a Security Gateway (R81.20 and higher) that provides
real-time phishing prevention based on URLs. Acronym: ZPH.
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