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Important Information
Latest Software
We recommend that you install the most recent software release to stay up-to-
date with the latest functional improvements, stability fixes, security
enhancements and protection against new and evolving attacks.

Certifications
For third party independent certification of Check Point products, see the Check
Point Certifications page.

Check Point Cloud Firewall for OCI Auto-Scaling Instance Pool Deployment
Guide

Latest Version of this Document in English
Open the latest version of this document in a Web browser.
Download the latest version of this document in PDF format.

Feedback
Check Point is engaged in a continuous effort to improve its documentation.
Please help us by sending your comments.

Revision History

Date Description

09 Mar 2025 First release of this document

https://www.checkpoint.com/products-solutions/certified-check-point-solutions/
https://www.checkpoint.com/products-solutions/certified-check-point-solutions/
https://sc1.checkpoint.com/documents/IaaS/WebAdminGuides/EN/CP_CloudGuard_Network_for_OCI_Autoscaling_Instance_Pool_DeploymentGuide/Default.htm
https://sc1.checkpoint.com/documents/IaaS/WebAdminGuides/EN/CP_CloudGuard_Network_for_OCI_Autoscaling_Instance_Pool_DeploymentGuide/CP_Cloud_Firewall_for_OCI_Autoscaling_Instance_Pool_DeploymentGuide.pdf
mailto:cp_techpub_feedback@checkpoint.com?subject=Feedback on Cloud Firewall for OCI Auto-Scaling Instance Pool Deployment Guide
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Overview of Cloud Firewall for OCI
Instance Pools
Use this guide to deploy a Check Point Cloud Firewall for OCI Instance Pools solution.

Note - For the list of supported versions, refer to the Support Life Cycle Policy.

Licensing
Check Point Cloud Firewall Gateways and Check Point Security Management Server must
have a license.

The Cloud Firewall for OCI Instance Pools solution uses the BYOL licensing model.

Important - All Cloud Firewall Gateways in the Instance Pool must use BYOL.

To buy BYOL licenses, contact Check Point Sales.

For more information about licensing, see the Cloud Firewall Central License Management
Utility guide.

Introduction to OCI Instance Pools
OCI Instance Pools let you deploy and manage groups of identical virtual machines (VMs) in
Oracle Cloud. They automatically adjust VM numbers based on your needs. Each OCI
Instance Pool spreads VMs across different Availability Zones for reliability. A Load Balancer
sends network traffic to these VMs.

Check Point Cloud Firewall protects OCI Instance Pools from cyber attacks, and it must be as
scalable, as the resources it protects.

The system uses these key parts:

n Cloud Firewall Gateways shield your resources (VMs).

n A Security Management Server manages all Cloud Firewall Gateways.

n Oracle Autoscale monitors your Instance Pool size and adds or removes Cloud Firewall
Gateways as needed.

Notes:

n Cloud Firewall Gateway count must match your Instance Pool size.
n The Security Management Server can run in Oracle Cloud or on-
premises.

https://www.checkpoint.com/support-services/support-life-cycle-policy
https://www.checkpoint.com/about-us/contact-us/
https://support.checkpoint.com/results/sk/sk109713
https://support.checkpoint.com/results/sk/sk109713
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Prerequisites
Make sure you are familiar with these topics:

Vendor Topics

Oracle Cloud Infrastructure n Instance Pool
n Auto-Scaling
n Load Balancers

Check Point n Cloud Firewall
Gateway

n Cloud Firewall for
OCI

Components of the Check Point Deployed
Solution
The diagram below depicts an OCI Virtual Cloud Network (VCN) with the deployed Check
Point solution.

Network Diagram

There are two backend subnets - WebApp1 and WebApp2.
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WebApp1 and WebApp2 are each a user-deployed backend subnet. Each has its own load-
balanced web server.

The Check Point deployed solution has these components:

n Frontend subnet

n Instance Pool

The number of instances that you can deploy in the Cloud is dynamic.

n Internal Load Balancer

n Backend subnet

n External Load Balancer

Note - Instance Pool cannot host different VM types.
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Scale-In and Scale-Out Events in
Cloud Firewall for OCI Instance
Pools
Oracle Autoscale adjusts the number of Cloud Firewall Gateways in the Instance pool based
on the traffic load.

It uses two main events:

n Scale Out: Adds Cloud Firewall Gateways to the Instance pool when the traffic load
increases.

n Scale In: Removes Cloud Firewall Gateways from the Instance pool when the traffic load
decreases.

To view or edit Oracle Autoscale settings, go to OCI Portal > Compute > Autoscaling
Configurations.

Default Cloud Firewall Gateway CPU thresholds to trigger autoscaling events:

n Scale Out: Triggers at 80% CPU use (5-minute average).

n Scale In: Triggers at 60% CPU use (5-minute average).

Note - To use Cloud Firewall Metrics as triggers for scale-in and scale-out events, you
need special permissions. For more information, see Adding proper permissions for
metrics.

Scale Out
When a scale-out event triggers:

1. Oracle Autoscale launches new Cloud Firewall Gateways.

2. New Cloud Firewall Gateways automatically run the First Time Configuration Wizard and
reboot.

3. The Security Management Server:

a. Detects new Cloud Firewall Gateway instances.

b. Creates a Secure Internal Communication (SIC) channel with these Cloud Firewall
Gateway instances.

c. Installs a Security Policy on each new Cloud Firewall Gateway.

4. The External Load Balancer starts sending traffic to these new Cloud Firewall Gateways.
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Note - New Cloud Firewall Gateways report their status and send logs to the Security
Management Server.

Scale In
When a scale-in event triggers:

1. Oracle Autoscale marks one or more Cloud Firewall Gateways as candidates for
termination.

2. The External Load Balancer stops sending traffic to marked Cloud Firewall Gateways.

3. Oracle Autoscale terminates marked Cloud Firewall Gateways.

4. The Security Management Server removes terminated Cloud Firewall Gateways from its
database.

Important - : Keep at least two Cloud Firewall Gateways (one in each Availability
Zone) running for redundancy and availability.

Testing Scale-In and Scale-Out Processes
The initial solution deployment process includes these steps:

1. When the Check Point Cloud Firewall for OCI Instance Pools solution is deployed, it
creates Cloud Firewall Gateways.

2. Each new Cloud Firewall Gateway automatically runs the First Time Configuration
Wizard. This usually takes 10 minutes to complete. Large Virtual Machines may require
additional time.

3. After configuration completes, the Security Management Server automatically installs
the Security Policy on these Cloud Firewall Gateways.

4. To verify deployment success, use SmartConsole to:

n Confirm the Security Policy installation.

n Verify log generation and transmission by Cloud Firewall Gateways.

To test scale-in and scale-out processes, simulate high CPU load on Cloud Firewall Gateways

Step Description

1 Connect to the Cloud Firewall Gateway command line interface (CLI) over
SSH.

2 Enter Expert mode.
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Step Description

3 Download the CPU load simulation script (simulate_cpu_load.sh) from
this link:
https://raw.githubusercontent.com/CheckPointSW/CloudGuardIaaS/master/c
ommon/simulate_cpu_load.sh

4 Place the script in the correct directory of the Cloud Firewall Gateway:

/var/tmp/simulate_cpu_load.sh

5 Set execute permissions to the script:

chmod u+x /var/tmp/simulate_cpu_load.sh

6 Validate script syntax:

sh -n /var/tmp/simulate_cpu_load.sh

7 Execute the script to simulate high CPU load:

./var/tmp/simulate_cpu_load.sh

8 In a separate terminal, monitor CPU load (it must be at a high level):

top

Note - After 10 minutes of high CPU load, a scale-out event triggers. Oracle
Autoscale provisions a new Cloud Firewall Gateway.

9 After the new Cloud Firewall Gateway is provisioned, press any key to stop the
simulation script on the original Cloud Firewall Gateway.

10 In a separate terminal, monitor CPU load (it must return to normal levels):

top

Note - After 10 minutes of normal CPU load, a scale-in event triggers. Security
Management Server automatically removes the newly provisioned Cloud Firewall
Gateway.

https://raw.githubusercontent.com/CheckPointSW/CloudGuardIaaS/master/common/simulate_cpu_load.sh
https://raw.githubusercontent.com/CheckPointSW/CloudGuardIaaS/master/common/simulate_cpu_load.sh
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Configure Load Balancers in Cloud
Firewall for OCI Instance Pools
Network Diagram

Load Balancers Overview
In the diagram above, you can see Load Balancers at three levels.

These routes describe the flow of traffic through the Load Balancers

n Level 1: External Load Balancer (handles Internet traffic)

n Level 2: Internal Load Balancer (of the deployed Check Point solution)

n Level 3: Web Server Load Balancers

Note - Subnets with load-balanced hosts (Web Servers) use Level 3 Load Balancers.

Routing Tables
Note - WebApp1 and WebApp2 routing tables have the same VNET address, but different
subnet addresses.
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Load Balancing Rules of the External Load Balancer

1 Example 1 Frontend
WebApp1:80

Backend port
8081

Example 2 Frontend
WebApp2:80

Backend port
8083

Frontend Routing Table - User Defined Routes (UDR)

2 Destination
10.0.0.0/16

Nexthop
None (Drop)

10.0.1.0/24 Virtual Network

Backend Routing Table - User Defined Routes (UDR)

3 Destination
0.0.0.0/0

Nexthop
None (Drop)

WebApp1 - User Defined Routes (UDR)

4 Frontend Nexthop

10.0.0.0/16 -VNET address 10.0.2.4 -IP
address of
the Internal
Load
Balancer

0.0.0.0/0 10.0.2.4 -IP
address of
the Internal
Load
Balancer

10.0.2.0/24 Virtual
Network

10.0.3.0/24 (WebApp1) - Subnet
address

Virtual
Network

WebApp2 - User Defined Routes (UDR)

5 Frontend Nexthop
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10.0.0.0/16 -VNET address 10.0.2.4 -IP address of the Internal Load
Balancer

0.0.0.0/0 10.0.2.4 -IP address of the Internal Load
Balancer

10.0.2.0/24 Virtual Network

10.0.4.0/24 (WebApp2) - Subnet
address

Virtual Network

Hosts

6 WebApp1 (subnet) load balanced Instance Pool
WebApp2 (subnet) load balanced Instance Pool
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Traffic Flows in Cloud Firewall for
OCI Instance Pools
Inbound Traffic - Request
Inbound traffic - request flow:

1. The request traffic from the Internet reaches the External Load Balancer in the deployed
Check Point solution.

2. The External Load Balancer receives the request traffic on port 80 and sends it to the
Cloud Firewall Gateway of the Instance Pool.

3. The Cloud Firewall Gateway:

a. Inspects the request traffic.

b. Performs Source NAT and Destination NAT on the request traffic.

c. Forwards the request traffic to the Web Server Host.

Inbound Traffic - Reply
Inbound traffic - reply flow:

1. The Web Server host sends its reply to the Cloud Firewall Gatewaythat processed the
connection.

2. The Cloud Firewall Gateway:

a. Inspects the reply traffic.

b. Reverses NAT and restores the original destination.

c. Forwards the reply traffic to the destination on the Internet.

Outbound Traffic - Request
Outbound traffic - request flow:

1. The request traffic from the Web Server host reaches the Internal Load Balancer in the
deployed Check Point solution.

2. The Internal Load Balancer sends the request traffic to the Cloud Firewall Gateway of the
Instance Pool.

3. The Cloud Firewall Gateway:
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a. Inspects the request traffic.

b. Performs Hide NAT on the request traffic.

c. Forwards the request traffic to the destination on the Internet.

Outbound Traffic - Reply
Outbound traffic - reply flow:

1. The reply traffic from the Internet reaches the Cloud Firewall Gateway of the Instance
Pool.

2. The Cloud Firewall Gateway:

a. Inspects the reply traffic.

b. Reverses Hide NAT.

c. Forwards the reply traffic to the Web Server host.

East-West Outbound Traffic - Request
East-West outbound traffic - request flow:

1. The request traffic from the Web Server host reaches the Internal Load Balancer in the
deployed Check Point solution.

2. The Internal Load Balancer sends the request traffic to the Cloud Firewall Gateway of the
Instance Pool.

3. The Cloud Firewall Gateway:

a. Inspects the request traffic.

b. Forwards the request traffic to the Application's Internal Load Balancer.

4. The Application's Internal Load Balancer forwards the request traffic to the App Server
host.

East-West Outbound Traffic - Reply
East-West outbound traffic - reply flow:

1. The reply traffic from the App Server host reaches the Internal Load Balancer in the
deployed Check Point solution.

2. The Internal Load Balancer sends the reply traffic to the same Cloud Firewall Gateway
that processed the request traffic from the Web Server host.

3. The Cloud Firewall Gateway:
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a. Inspects the reply traffic.

b. Forwards the reply traffic to the Web Server host.

Intra-Subnet Traffic
Traffic within the same subnet flows directly. No inspection or routing are required.
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Configure Cloud Firewall for OCI
Instance Pools
Step 1: Prepare your OCI Account
The Check Point Security Management Server uses an API signing key to monitor Instance
Pools and Cloud Firewall Gateway provisioning.

To set up user permissions:

1. Create a permission group:

n In your OCI account, navigate to Identity & Security.

n Under Identity, click Domains.

n Select the target user domain.

n On the left pane, click Groups.

n Click Create Group to create a new group for autoscale permissions.

2. Configure Security Policies:

n Navigate to Identity & Security > Policies.

n Create a new policy for the previously created group (use the group name for
<group_name>) with these permissions:

Allow group <domain>/<group_name> to manage instance-family in
compartment <compartment_name>
Allow group <domain>/<group_name> to inspect vnic-attachments
in compartment <compartment_name>
Allow group <domain>/<group_name> to manage virtual-network-
family in compartment <compartment_name>
Allow group <domain>/<group_name> to inspect instance-pools in
compartment <compartment_name>

3. Assign target users to the created permission group. For that, go to the group and click
Assign user to groups.

To generate an API Signing Key pair, refer to the OCI documentation for the most up-to-date
instructions. After generating an API signing key, write down these values for the "Configure
the Check Point Security Management Server" step:

https://docs.oracle.com/en-us/iaas/Content/API/Concepts/apisigningkey.htm#two
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n User OCID

n Tenancy OCID

n Private API key.

To allow the Cloud Firewall Gateway to publish metrics to the Monitoring service, you must set
up necessary permissions:

1. Create a Dynamic Group.

n In your OCI Account, navigate to Identity & Security.

n Under Identity, click Domains.

n Click Create domain. For Domain type, select Free.

n Click on the created domain. Under Identity domain, select Dynamic groups.

n Click Create dynamic group. For the matching rules, select Match any rules
defined below and add the following:

Any {instance.compartment.id = '<compartment_name>'}

2. Configure Security Policies:

n Navigate to Identity & Security/ > Policies.

n Click Create Policy. For Policy Builder, press Show manual editor and add these
permissions:

allow dynamic-group <domain>/<dynamic_group> to use metrics in
compartment <compartment_name>

Step 2: Install the Check Point Security
Management Server
These steps are required only if you do not have an installed Check Point Security
Management Server.

If you already have the Security Management Server installed, skip to Step 3.

Requirements for the Check Point Security Management Server

Must start connections to the Cloud Firewall Gateways.

Requirements for Cloud Firewall Gateways

Must start connections to the Security Management Server. For example, to send logs.
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Deploying a Security Management Server in OCI

From the OCI Marketplace, deploy the solution "Cloud Firewall Security Management".

Deploying a Security Management Server on-premises

Follow the instructions in the Check Point Installation and Upgrade Guide for your Security
Management Server version.

Step 3: Configure the Check Point Security
Management Server

Do these steps to manage Instance Pools with the Check Point Security Management
Server:

1. In SmartConsole, change the IP address of the Security Management Server object to
be its public IP address.

2. "Downloading and Installing the Latest CME Version" on page 32 of CME.

3. "Configuring the CME on the Security Management Server" on page 32

4. Configure the Security Policy in SmartConsole.

Note - By default, each Cloud Firewall Gateway and Security Management Server's
Gaia Portal is accessible from the internet by browsing to http://<virtual-machine-
public-ip>. Restriction of access to the Gaia Portal is possible by configuring a
Security List, or by configuring the Cloud Firewall Gateway and Security Management
Server settings.

Step 4: Deploy the Check Point Instance Pool
To deploy the Check Point Instance Pool, do these steps:

1. Find the stack by searching for "Cloud Firewall AutoScale - BYOL Stack" in the OCI
marketplace, agree to the licensing terms, and click Launch Stack.

2. Name your stack and add a description. Use the default Terraform version.

3. Use these parameters in the Compute Configuration section:

Parameter Description

Compartment The OCI compartment where the Instance Pool is
deployed.
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Parameter Description

Minimum Instance
Count in Pool

The minimum number of Cloud Firewall Gateway
instances in the Instance Pool.
We recommend a minimum of two.

Maximum Instance
Count in Pool

The maximum number of Cloud Firewall Gateway
instances in the Instance Pool.

Scale In CPU
Threshold

The CPU utilization threshold percentage to scale in.

Scale Out CPU
Threshold

The CPU utilization threshold percentage to scale out.

4. For the Network Configuration section, choose to either create a new VCN and subnets
or use an existing one.

5. Use these parameters in the Additional Configuration section:

Parameter Description

Name of the Existing
Management with CME

Must exactly match the management name
configured in CME on the Security Management
Server.

Name of the Template for
this stack.

Must exactly match the configuration template name
configured in CME on the Security Management
Server.

Management interface to
use.

Select which interface to use as the management
interface for the Instance Pool:

n eth0: frontend VNIC
n eth1: backend VNIC

Indicates if the management
interface is using its public IP
address or private IP
address to connect.

Public:
Manage the Cloud Firewall Gateway Instance Pool
with the public IP addresses of the instance.
Private:
Manage the Cloud Firewall Gateway Instance Pool
with the private IP address of the instance. The
Security Management Server must have access to
the private IP addresses.
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Parameter Description

Enable Cloud Firewall
metrics

Enable Cloud Firewall metrics to send statuses and
statistics collected from instances to the OCI Monitor
service.
If the Cloud Firewall metrics are enabled:

n The Cloud Firewall metrics agent starts to send
metrics each minute.

n The Cloud Firewall metrics are sent to the OCI
Monitor resource immediately after the
instance pool deployment is completed.
Note - "To allow the Cloud Firewall Gateway to
publish metrics to the Monitoring service, you
must set up necessary permissions:" on
page 18

6. After reviewing that everything is correct, click Create.

7. The Stack Details page opens. Click Apply to start creation of the autoscale resources.

8. The next screen shows the status updates as the deployment proceeds, allowing you to
troubleshoot any problems if necessary.

The deployment includes a VCN and two subnets (if you decided not to use the existing
subnets), two network Load Balancers, and an Instance Pool with the configured minimum
number of Cloud Firewall Gateways.

After the deployment finishes successfully, it takes 1-3 minutes until the Security Management
Server finishes the configuration. Autoscaling is ready when the health check of the Load
Balancer passes (find it at OCI console > Compute > Instance Pools > Your Instance Pool
Stack > Load Balancers > Health Check).

All resources can be deleted by clicking Destroy on the Stack Details page.

Step 5: Set Up the Load Balancers

By default, the stack you deploy creates an external and internal Load Balancer.

The External Load Balancer:

n Listens on TCP port 80 on the static public IP address of the External Load Balancer.

n Forwards the traffic it receives to the pool of Cloud Firewall Gateways on TCP port 8081.

n Uses TCP health probes on port 8117 to know the health of the Cloud Firewall
Gateways.
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The Internal Load Balancer:

n Listens and forwards all TCP or UDP traffic on all ports.

n Uses TCP health probes on port 8117 to know the health of the Cloud Firewall
Gateways.

Notes:

n You cannot use ports 80, 443, 444, 8082, 8117, and 8880 for forwarded traffic.
n In addition, you cannot use the ports defined in sk52421 (used by Check Point
software), and 32768 – 65535 as defined in sk162619 (FWD daemon listening
on multiple random high ports).

n Do not change the health probes.
n The Instance Pool deployment includes a default security list that allows all
outbound and inbound traffic.

Creating Dynamic Objects 'LocalGatewayExternal' and
'LocalGatewayInternal'
You must also create these Dynamic Objects in SmartConsole:

n LocalGatewayExternal

n LocalGatewayInternal

Procedure:

1. Click Objects menu > More object types > Network Object > Dynamic Object > New
Dynamic Object.

2. Enter this exact name (case-sensitive, no spaces):

LocalGatewayExternal

3. Click OK.

4. Click Objects menu > More object types > Network Object > Dynamic Object > New
Dynamic Object.

5. Enter this exact name (case-sensitive, no spaces):

LocalGatewayInternal

6. Click OK.

7. Publish the SmartConsole session

https://support.checkpoint.com/results/sk/sk52421
https://support.checkpoint.com/results/sk/sk162619
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Step 6: Configure Inbound Protection
Configure Access Control and NAT rules for Northbound-Southbound inbound traffic

Ste
p Description

1 Connect with SmartConsole to your Security Management Server or Multi-Domain
Server.

2 Create a host object to represent one of these:

n The Application Load Balancer that is related to your backend Instance
Pools.

n The specific Application Host you want to access through the Internet.

You must do this for each Application Load Balancer you use to balance your
servers.
Follow these steps:

a. Click Objects menu > New Host.
b. Enter a descriptive name. For example, application-load-

balancer-app-1
c. Enter the private IP address of the Application Load Balancer.
d. Click OK.

3 Create a new TCP service to represent the internal port of the External Load
Balancer or External Application Gateway configuration.
You must do this for each backend port, such as port 8081.
Do these steps:

a. Click Objects menu > More object types > Service > New TCP.
b. Enter a descriptive name. For example, http-8081.
c. In the Protocol field, select the applicable protocol (such as HTTP or

HTTPS).
d. In the Port field, select Customize and enter the port number. For

example, 8081.
e. Click OK.



Overview of Cloud Firewall for OCI Instance Pools

Cloud Firewall for OCI Auto-Scaling Instance Pool Deployment Guide      |      24

Ste
p Description

4 Create a corresponding Access Control rule for each External Load Balancer with
these values:

No Nam
e

Sour
ce Destination VP

N

Services
&
Applicati
ons

Actio
n

Trac
k

Insta
ll On

1 Descripti
ve name

Any LocalGatewayEx
ternal

Any The service
object that
represents the
internal port of
the External
Load Balancer

Accept Log Policy
Target
s

Note - Create only one LocalGatewayExternal object for each Security
Management Server. See "Creating Dynamic Objects 'LocalGatewayExternal'
and 'LocalGatewayInternal'" on page 22.

5 Create a NAT rule with these values for each Application Host or Application Load
Balancer.
In the Translated Source column:

1. Add the LocalGatewayInternal object.
2. Right-click on the LocalGatewayInternal object > select NAT Method > click

Hide.

N
o

Origi
nal
Sour
ce

Original
Destination

Origin
al
Servi
ces

Translated
Source

Transla
ted
Destina
tion

Transla
ted
Service
s

Inst
all
On

1 All_
Intern
et

LocalGatewayE
xternal

The
service
object that
represent
s the
internal
port of the
External
Load
Balancer

LocalGatewayI
nternal

The Host
object that
represents
the internal
Application
Host or
Application
Load
Balancer

The service
object that
represents
the port, on
which the
Internal
Load
Balancer or
Application
Host listens
(for
example,
http)

Polic
y
Targe
ts

Note - Do not use *Any in the Original Source column.
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Ste
p Description

This NAT rule:

n Matches any traffic that arrives at the Cloud Firewall Gateway on the
applicable backend port.

n Translates the Source IP address to match the IP address of the Cloud
Firewall Gateway that handles the connection ("eth1"). When you use this,
the packets that return are routed to the correct Cloud Firewall Gateway.

n Translates the destination IP address to the IP address of the Application
Load Balancer or Application Host associated with the Web Servers.

6 Publish the session.

7 Install the Access Control Policy on the Cloud Firewall Gateways.

Step 7: Configure Outbound and East-West
Protection
Configure UDR tables and NAT rules for Outbound and East-West traffic protection.

You can configure the Check Point Instance Pool to examine Outbound and East-West traffic
across internal subnets.

To configure the traffic inspection from servers in internal private subnets, you must route
traffic through the Check Point Instance Pool. Use the Check Point Internal Load Balancer as
the Next hop in the private subnet UDR. The Internal Load Balancer then forwards all the traffic
to one of the Cloud Firewall Gateways.

Configuring Outbound Protection
To configure Outbound Protection

Ste
p Description

1 Connect with SmartConsole to your Security Management Server or Multi-
Domain Server.
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Ste
p Description

2 Create a Network object that represents the OCI VCN:

a. Click Objects menu > New Network.
b. Enter a descriptive name.
c. From the left tree, click General.

Enter the applicable information.
d. From the left tree, click NAT.

Select Add automatic address translation rules.
This performs Static NAT for all outbound rules.

e. Click OK.

3 In SmartConsole, from the left navigation panel, click Security Policies.

4 In the Access Control section, click NAT.

5 Make sure these Automatic NAT rules exist:

No

Origin
al
Sourc
e

Original
Destinati
on

Origin
al
Servic
es

Translat
ed
Source

Translat
ed
Destinati
on

Translat
ed
Service
s

Insta
ll On

2 AllVnet AllVnet Any =Original =Original =Original Policy
Target
s

3 AllVnet Any Any HAllVnet =Original =Original Policy
Target
s

6 In the Access Control section, click Policy.

7 Add this explicit Access Control rule:

Name Sourc
e

Destinatio
n VPN

Services &
Applicatio
ns

Action Track Install
On

To
Internet

AllVnet All_Internet Any Any Accept Log Policy
Targets

8 In SmartConsole, install the Access Control Policy.

9 Connect to the OCI portal.

10 Add UDR rules with the Internal Load Balancer's private IP address as next hop.



Overview of Cloud Firewall for OCI Instance Pools

Cloud Firewall for OCI Auto-Scaling Instance Pool Deployment Guide      |      27

Example - UDR rules with the Internal Load Balancer's private IP address as the next hop

NAME ADDRESS
PREFIX NEXT HOP

to-internet 0.0.0.0/0 Private IP address of the Internal Load
Balancer.

Configuring East-West Protection Between Internal
Subnets.
Solution:

Do these steps for each subnet:

Ste
p Description

1 Connect with SmartConsole to your Security Management Server or Multi-Domain
Server.

2 Create a Network object:

a. Click Objects menu > New Network.
b. Enter a descriptive name (for example, "NetworkA").
c. From the left tree, click General.

Enter the applicable information.
d. From the left tree, click NAT.

Select Add automatic address translation rules.
This performs Static NAT for all outbound rules.

e. Click OK.

3 In SmartConsole, from the left navigation panel, click Security Policies.

4 In the Access Control section, click NAT.
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Ste
p Description

5 Make sure these Automatic NAT rules exist:

No

Origin
al
Sourc
e

Original
Destinati
on

Origin
al
Servic
es

Translat
ed
Source

Translat
ed
Destinati
on

Translat
ed
Services

Insta
ll On

2 Network
A

NetworkA Any = Original = Original = Original Policy
Target
s

3 Network
A

Any Any HNetworkA = Original = Original Policy
Target
s

6 Create a Network Group object to represent the full internal address space:

a. Click Objects menu > More object types > Network Object > Group > New
Network Group.

b. Enter a descriptive name. For example, AllInternalAddressSpace.
c. Add the VCN's Network objects you created in Step 2.
d. Click OK.

7 In the Access Control section, click NAT.

8 Add a Manual NAT rule to skip NAT for internal traffic between VCNs:

Original
Source

Original
Destination

Origin
al
Servic
es

Transla
ted
Source

Translat
ed
Destinat
ion

Transla
ted
Service
s

Inst
all
On

Network Group
object that
represents the full
internal address
space
(AllInternalAddress
Space)

Network Group
object that
represents the full
internal address
space
(AllInternalAddress
Space)

Any =
Original

= Original =
Original

Policy
Targe
ts

9 In the Access Control section, click Policy.
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Ste
p Description

10 Add this explicit Access Control rule to allow outbound access from the full internal
address space to the Internet:

Nam
e Source Destinati

on
VP
N

Services
&
Applicati
ons

Actio
n

Trac
k

Insta
ll On

To
Internet

Network Group
object that
represents the full
internal address
space
(AllInternalAddress
Space)

All_
Internet

Any Any Accept Log Policy
Target
s

11 In SmartConsole, install the Access Control Policy.

12 Connect to the OCI portal.

13 Add UDR rules for each internal private subnet:

a. Create the rule to 0.0.0.0/0, use the Internal Load Balancer’s private IP
address as the next hop to monitor outbound traffic.

b. Create the rule to a different internal private subnet, use the Internal Load
Balancer’s private IP address as the next hop to monitor outbound traffic.

Example - UDR rules for each internal private subnet

NAME ADDRESS
PREFIX NEXT HOP

to-Internet 0.0.0.0/0 Private IP address of the Internal Load
Balancer

to-internal-
subnet

10.0.2.0/0 Private IP address of the Internal Load
Balancer
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Cloud Firewall Instance Pool
Solution Upgrade
This section provides instructions for upgrading an already deployed Cloud Firewall Instance
Pool solution.

The upgrade procedure includes these steps:

1. Deploying a new version of the Cloud Firewall Instance Pool solution alongside the older
version (a side-by-side upgrade).

2. Reconfiguring OCI resources and Check Point configuration to use this new version of
the Cloud Firewall Instance Pool solution.

3. Deleting the older version of the Cloud Firewall Instance Pool solution.

Terms:

n Source - The original template and solution (with the lower version)

n Target - The new template and solution (with the higher version)

To upgrade the Cloud Firewall Instance Pool solution

Step Description

1 Log in to the OCI portal.

2 Deploy a target Cloud Firewall Instance Pool solution from the OCI
Marketplace. To do this:

a. Select the desired image version.
b. Use the same Security Management Server name as for the

source Cloud Firewall Instance Pool solution.
c. Use a different configuration template name than in the source

Cloud Firewall Instance Pool solution.
d. Use the same VCN and subnets as the source solution.
e. Deploy the stack.

3 Configure the CME template.
For this, run:

autoprov_cfg add template -tn "<Template-Name>" -
otp "<SIC-key>" -ver <Version> -po "<Policy-Name>"

https://sc1.checkpoint.com/documents/IaaS/WebAdminGuides/EN/CP_CME/Content/Topics-CME/CME_Structure_and_Configurations.htm?TocPath=CME%20Structure%20and%20Configurations%7CConfiguration%20Templates%20(gateway-configurations)%7C_____0#Configuration_Templates_(gateway-configurations)
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Step Description

4 Reconfigure the network load balancers in SmartConsole of the Security
Management Server to use the IP addresses of the load balancers
created by the target template.

5 Wait for provisioning to complete and for the policy to install on the new
Cloud Firewall Instance Pool instances.

6 Note - In this step, all open connections on the source Cloud
Firewall Instance Pool become closed.

Shut down the source Cloud Firewall Instance Pool and make sure that
traffic flows correctly.

7 Note - Before proceeding, make sure the target Instance Pool
handles all traffic (inbound, outbound, East-West) as expected.

Delete the CME template of the source Cloud Firewall Instance Pool.
For this, run:

autoprov_cfg delete template -tn "<Template-Name>"

8 Delete the corresponding Instance Pool resource.

Important - Do NOT delete the stack of the source Cloud Firewall
Instance Pool, as it can contain the VCN resources currently in use.
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Configure Cloud Management
Extension (CME)
Downloading and Installing the Latest CME
Version
To download and install the CME (Cloud Management Extension) on the Security
Management Server or Multi-Domain Server, see sk157492.

Configuring the CME on the Security
Management Server
The instructions below contain information about how to configure an Instance Pool
environment in CME. For more information about CME configurations, see the
"Overview" section in the Cloud Management Extension Administration Guide.

Note - Configuring CME in the Smart-1 Cloud GUI is not supported for the Cloud
Firewall for OCI Instance Pools solution.

Configure the CME on the Security Management Server with CME API (recommended)

With CME Management API you can configure the CME tool.

API Documentation:

n SwaggerHub: CME API

n Postman Collection: CME API Postman collection

Prerequisites:

n CME Take 139 or higher installed on the Security Management Server.

n Management API version 1.8 or higher installed on the Security Management Server
(see the Check Point Management API Reference (at the top, select the correct version)
).

1. To configure Security Management Server during the Cloud Firewall Gateway for Oracle
Instance Pool deployment:

Send a PUT request:

https://supportcenter.checkpoint.com/supportcenter/portal?action=portlets.SearchResultMainAction&eventSubmit_doGoviewsolutiondetails=&solutionid=sk157492
https://sc1.checkpoint.com/documents/IaaS/WebAdminGuides/EN/CP_CME/Default.htm
https://app.swaggerhub.com/apis-docs/Check-Point/cme-api/v1.3
https://github.com/CheckPointSW/CloudGuardIaaS/tree/master/common/cme_api_postman
https://sc1.checkpoint.com/documents/latest/APIs/index.html
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PUT https://<Management_IP_address>/web_api/v1.8/cme-
api/v1.3/management

Request body parameters:

Parameter Name Description

name Your OCI account name (for example, "my-management").

This operation returns "status-code": 200.

2. To configure CME on the Security Management Server:

Send a POST request:

POST https://<Management_IP_address>/web_api/v1.8/cme-
api/v1.3/accounts/oci

Request body parameters:

Parameter
Name Description

name Your OCI account name.

compartm
ent

Compartment OCID

region OCI region

realm_
domain

The domain of the realm
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Parameter
Name Description

credenti
als_data

Base64-encoded string of the following JSON:
{"user":"<USER OCID>","tenancy":"<TENANCY OCID>",
"key":"<CONTENTS OF PRIVATE KEY FILE>"}

Note - The value of "key" parameter should begin with "-----BEGIN
PRIVATE KEY-----" and end with "-----END PRIVATE KEY-----". To
ensure correct parsing, preserve the exact line breaks and spacing.
This can be achieved by either copying the key as-is or explicitly
appending newline characters (\n) at the end of each line within the
key.

Examples
n Directly copying and pasting the API key:
echo -n '
{"user":"ocid1.user.oc1..aaaaa","tenancy":"ocid
1.tenancy.oc1..aaaaa", "key":"-----BEGIN
PRIVATE KEY-----
<PRIVATE>
<KEY>
<CONTENT>
-----END PRIVATE KEY-----"}' | base64 -w 0

n Adding newline characters (\n) to the API key:
echo -n '
{"user":"ocid1.user.oc1..aaaaa","tenancy":"ocid
1.tenancy.oc1..aaaaa", "key":"-----BEGIN
PRIVATE KEY-----
\n<PRIVATE>\n<KEY>\n<CONTENT>\n-----END PRIVATE
KEY-----"}' | base64 -w 0

This operation returns "status-code": 200.

3. To configure gw_conf:

Send a POST request:

POST https://<Management_IP_address>/web_api/v1.8/cme-
api/v1.3/gwConfigurations/oci

Request body parameters:
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Parameter
Name Description

name The name of the relevant set of Instance Pool configurations to apply
(for example, "my-configuration-template-for-x").

base64_
sic_key

A random value that has at least 8 alphanumeric characters (for
example, "MySICkey123").

version The Cloud Firewall Gateway version.

policy The name of the policy to install (for example, "Standard").

related_
account

Your OCI account to associate with this configuration.

This operation returns "status-code": 200.

To configure the CME on the Security Management Server with autoprov-cfg

Step Description

1 Connect to the command line on the Security Management Server.

2 Log in to the Expert mode.

3 Execute this command (see the explanation of parameters below):
Run:

autoprov_cfg init OCI -mn "<Management-Name>" -tn
"<Configuration-Template-Name>" -otp "<SIC-key>" -ver
<Version> -po "<Policy-Name>" -cn "<Controller-Name>" -
co "<Compartment>" -rg "<Region>" -rd "<Realm-Domain>"
-cred "<Credentials-File-Data>"

Example:

autoprov_cfg init OCI -mn "my-management" -tn "my-
configuration-template" -otp "MySICkey123" -ver R81.20
-po "Standard" -cn "my-oci-controller" -co
"ocid1.compartment.oc1..12345" -rg "eu-frankfurt-1" -rd
"oraclecloud.com" -cred "eyJ1c...""

4 When this message shows, type yes and press Enter to apply the
modifications:

Would you like to restart the service now?
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Step Description

5 Confirm the configuration:

service cme test

Every controller in the configuration must have unique credentials.

6 Follow the instructions in the Enabling and Disabling Software Blades section
in the Cloud Management Extension Administration Guide.

Parameters

Important - The exact values that you select, must be typed exactly when you
deploy the Instance Pool. Make sure to write them down and enter them correctly.
Otherwise, the components cannot communicate with each other.

Paramet
er Description Example

"<Manag
ement-
Name>"

Select a descriptive name.
When you deploy the Check Point Instance Pool
with this name, the Check Point Security
Management Server identifies and automatically
provisions it.

"my-management"

"<Confi
guratio
n-
Templat
e-
Name>"

Configurations that automatically provision the
Cloud Firewall Gateways in the Instance Pool are
found in this template.
When you deploy the Check Point Instance Pool
with this template name, it references the
relevant set of configurations to apply to it.
Therefore, you can maintain multiple sets of
configurations and associate them with different
Instance Pools that are managed by the Security
Management Server.

"my-
configuration-
template-for-x"

"<SIC-
key>"

Select a random key that has at least 8
alphanumeric characters.

"MySICkey123"

<Versio
n>

The Cloud Firewall Gateway version. R8X.XX

"<Polic
y-
Name>"

The name of the policy to install.
The name of this policy has to be the exact same
name of the policy in SmartConsole.

"Standard"

https://sc1.checkpoint.com/documents/IaaS/WebAdminGuides/EN/CP_CME/Default.htm
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Paramet
er Description Example

"<Contr
oller-
Name>"

Select a name that represents the controller.
The controller name includes configurations for
your OCI environment, such as the compartment
OCID and region.
You can maintain different controllers to
automatically provision different Cloud
environments, with the Security Management
Server.

"OCI-Production"

"<Compa
rtmen
t>"

The compartment OCID. "ocid1.compartmen
t.Oc1..abcdefghij
klm"

"<Regio
n>"

An OCI region. "eu-frankfurt-1"

"<Real
m-
Domai
n>"

The domain for the realm. "oraclecloud.com"
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Paramet
er Description Example

"<Crede
ntials-
File-
Data>"

Base64-encoded string of the following JSON:
{"user":"<USER
OCID>","tenancy":"<TENANCY OCID>",
"key":"<CONTENTS OF PRIVATE KEY
FILE>"}

Note - The value of "key" parameter should
begin with "-----BEGIN PRIVATE KEY-----" and
end with "-----END PRIVATE KEY-----". To
ensure correct parsing, preserve the exact line
breaks and spacing. This can be achieved by
either copying the key as-is or explicitly
appending newline characters (\n) at the end of
each line within the key.

Examples

n Directly copying and pasting the API key:
echo -n '
{"user":"ocid1.user.oc1..aaaaa"
,"tenancy":"ocid1.tenancy.oc1..
aaaaa", "key":"-----BEGIN
PRIVATE KEY-----
<PRIVATE>
<KEY>
<CONTENT>
-----END PRIVATE KEY-----"}' |
base64 -w 0

n Adding newline characters (\n) to the API
key:
echo -n '
{"user":"ocid1.user.oc1..aaaaa"
,"tenancy":"ocid1.tenancy.oc1..
aaaaa", "key":"-----BEGIN
PRIVATE KEY-----
\n<PRIVATE>\n<KEY>\n<CONTENT>\
n-----END PRIVATE KEY-----"}' |
base64 -w 0

"eyJ1c…"

.
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Configure HTTPS Inspection
Follow the steps below to enable HTTPS Inspection.

Notes:

n If you have an outbound CA certificate you can skip these steps. Otherwise,
create one in "Creating an Outbound Certificate."

n Only want inbound SSL inspection.

Creating an Outbound Certificate
To create an Outbound Certificate

Step Description

1 In SmartConsole, go to Policy > HTTPs policy.

2 Go to the Destination column, and edit the default rule to be Any.

3 Go to the Track column, and edit to Log.

4 Go to Gateways and Servers.
Open one of the VMSS instances you have.

5 Open HTTPs Inspection and click Create Certificate.

6 Enter the information and click OK.

7 Click Enable HTTPs Inspection.

8 Publish the SmartConsole session.

9 Install policy.

Creating an HTTPS Inspection Rule to Inspect SSL Traffic
This procedure creates an HTTPS Inspection rule to inspect SSL traffic that belongs to a web
application

Step Description

1 In SmartConsole, from the left navigation panel, click Manage & Settings.

2 From the left tree, click Blades.

3 In the HTTPS Inspection section, click Configure in SmartConsole.
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Step Description

4 From the left tree, click Gateways.

5 At the bottom of the page, click Create Certificate.

6 Enter the information and click OK.

7 From the left tree, click Server Certificates.

8 Enter the information and click OK.

9 From the left tree, click Policy.

10 Add this rule:

n Source - Any
n Destination - Any (do not use the Internet object)
n Service - The HTTPS service you created
n Action - Inspect
n Certificate - The certificate you created

11 Save the changes:
Click Menu > File > Save.

12 Close the SmartConsole.

13 Publish the SmartConsole session
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IPS Geo Protection Based on X-
Forwarded-For HTTP Header
The IPS Geo protection filters and logs traffic based on the country, from each it arrives. This
protection is applied to both the source address of the connection, as well as to any IPv4
address present in an 'X-Forwarded-For' HTTP header.

Notes:

n The External Load Balancer does not hide the client's original IP address.
n If an HTTP request goes through multiple proxies or Load Balancers, the X-
Forwarded-For HTTP header is expected to contain multiple IP addresses.

n All IPv4 addresses contained in the X-Forwarded-For HTTP header, are
inspected by the IPS Geo protection.

n Any IPv6 address in the X-Forwarded-For HTTP header is ignored.

For more information, see sk115532 on IPS Geo protection based on X-Forwarded-For HTTP
header.

Use Case 1
Single user

1. A user is located in Dallas (USA), and the client opens a direct connection to the
External Load Balancer.

2. The Load Balancer forwards the connection to one of the Check Point Cloud Firewall
Gateways and leaves the source IP address unchanged.

3. The IPS Geo protection on the Cloud Firewall Gateway identifies the country of origin
as the United States.

4. The Cloud Firewall Gateway allows or drops the connection based on the policy.

Use Case 2
Multiple users

1. A user is located in Dallas (USA), and the client opens a direct connection to the
External Load Balancer.

The Load Balancer forwards the UserA's connection to one of the Check Point Cloud
Firewall Gateways and leaves the UserA's source IP address unchanged.

The IPS Geo protection on the Cloud Firewall Gateway identifies the country of origin
as the United States for the UserA's connection.

https://support.checkpoint.com/results/sk/sk115532
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2. UserB is also located in Dallas (USA), and the client uses a proxy server to connect to
the External Load Balancer.

The proxy adds an X-Forwarded-For HTTP header to the UserB's connection with the
IP address of the UserB's client in Dallas.

The Load Balancer forwards the connection to one of the Cloud Firewall Gateways.

The IPS Geo protection on the Cloud Firewall Gateways identifies the country of origin
as the United States for the UserB's connection.

3. The Cloud Firewall Gateway allows or drops the connections based on the policy.
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Limitations of Cloud Firewall for
OCI Instance Pools

n Anti-Spoofing is disabled by default on the Instance Pool instances eth0 and eth1 and
must not be enabled.

n Configuring CME in the Smart-1 Cloud GUI is not supported for Cloud Firewall for OCI
Instance Pools.
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